LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-26-2010, 12:26 AM   #1
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,546
Blog Entries: 28

Rep: Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176
autofs in Slackware 13.0. Some questions


Hello

autofs in Slackware 13.0 is version 3.1.7 which is quite old; the sample config files in /usr/doc/autofs-3.1.7/samples/ are dated 1997. The package is not of normal Slackware standard; the sample rc.autofs does not work on Slackware, it's only for Debian and RedHat (Alien Bob provides a fixed version).

I figure there is a reason for this unusual state of affairs. Perhaps autofs is no longer important, superseded by udev. Perhaps more current versions of autofs are not stable enough for Slackware.

AFAIK udev does not support auto-unmount and AFAIK this is important for using vchanger 0.8.5 with Bacula 5.0.0.

The problem is that option "--timeout=60" in /etc/autofs.master (as advised in the vchanger documentation) results in "automount[3300]: parse(sun): unknown option: -timeout=30" in syslog. It may not be supported in autofs 3.1.7.

What to do?
  • Stay with autofs 3.1.7 and find another way of doing timeout?
  • Install the latest autofs?
  • Find a way to implement automount (at vchanger's instigation) and timeout using udev?
Best

Charles
 
Old 02-26-2010, 02:25 AM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,910

Rep: Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326
Quote:
automount[3300]: parse(sun): unknown option: -timeout=30
Mind the correct syntax is "-timeout 30"

Btw I'm using this startup script, where you can define the timeout and remove it from /etc/auto.master
Quote:
elif [ -f $map ]
then
echo "/usr/sbin/automount -p /var/run/automount.pid -t 30 $dir file $map
$options $localoptions
Regards
 
Old 02-26-2010, 03:04 AM   #3
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,546
Blog Entries: 28

Original Poster
Rep: Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176
Quote:
Originally Posted by bathory View Post
Mind the correct syntax is "-timeout 30"

Btw I'm using this startup script, where you can define the timeout and remove it from /etc/auto.master
Thanks bathory -- to my rescue again

Where is the correct syntax described? In auto.master I tried --timeout=60 first then -timeout=60 and finally ---timeout=60 (it reportedly solved a problem on OpenSUSE). Only --timeout=60 resulted in automounting (without auto unmounting).

That's one clever startup script, re-writing the config files on the fly and moving any timeout option to an automounter command option.

As a workaround -- to allow project progress -- I've done the equivalent manually (KISS), deleting --timeout=60 from auto.master and adding as an automounter command option in (Alien Bob's) rc.autofs. It's auto unmounting OK.

Looking at kernel.org's autofs sources, there doesn't seem to have been a stable version yet
 
Old 02-26-2010, 03:17 AM   #4
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,910

Rep: Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326
Hi,

Yup, it goes to auto.master.
You don't need the equal sign"=". Just put a space instead, like: "--timeout 60"
Code:
/mnt	/etc/auto.misc	--timeout 20

Cheers
 
Old 03-03-2010, 12:34 PM   #5
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,546
Blog Entries: 28

Original Poster
Rep: Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176
Quote:
Originally Posted by bathory View Post
You don't need the equal sign"=". Just put a space instead, like: "--timeout 60"
Code:
/mnt	/etc/auto.misc	--timeout 20
Thanks bathory

Sorry it has taken a while. Tried it while installing on another computer that but it broke automounting. Removed --timeout and retested, changing nothing else. Automounting worked again.
Code:
root@CW8:~# /usr/sbin/automount --version
Linux automount version 3.1.7
 
Old 11-04-2011, 03:52 PM   #6
camerabambai
Member
 
Registered: Mar 2010
Distribution: Slackware
Posts: 40

Rep: Reputation: 0
A question about autofs and nfs4 under slackware.
Under redhat i use simply -fstype=nfs4 and work
under slackware i can't see only empty directories.
Why?
 
Old 11-04-2011, 04:44 PM   #7
Cedrik
Senior Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 2,140

Rep: Reputation: 242Reputation: 242Reputation: 242
Does it work if you add a fstab entry for a nfs mount and mount manually with mount command ?
 
Old 11-05-2011, 09:06 AM   #8
camerabambai
Member
 
Registered: Mar 2010
Distribution: Slackware
Posts: 40

Rep: Reputation: 0
Sure.
 
  


Reply

Tags
autofs, bacula, timeout


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
rc.autofs for slackware 12.2 pooryorick Slackware 2 02-18-2009 01:51 PM
Slackware 11, some questions fdahl_009 Slackware 16 10-17-2006 09:28 AM
Slackware 10.1 or Kernel 2.6.11.6 Autofs support novice26 Slackware 5 04-04-2005 06:14 AM
slackware many questions hosler Linux - Newbie 1 03-26-2005 11:55 PM
8 slackware questions aaronluke Slackware 2 10-20-2002 12:40 AM


All times are GMT -5. The time now is 03:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration