LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-01-2012, 09:33 PM   #1
detpenguin
Senior Member
 
Registered: Oct 2003
Location: lost in the midwest...
Distribution: Slackware
Posts: 1,091

Rep: Reputation: 45
auto mount dvd


i have been struggling with this for 2 days now. i know in the past i edited the fstab file to automatically mount my dvd drive, but i cannot figure out what i did. i can mount it as root using mount /dev/cdrom, but i know it's easier than that. can anyone guide in the right direction? i would be sincerely grateful!

Jeff
 
Old 11-02-2012, 02:06 PM   #2
/dev/random
Member
 
Registered: Aug 2012
Location: Ontario, Canada
Distribution: Slackware 14.1, LFS-current, NetBSD 6.1.3
Posts: 119

Rep: Reputation: 38
Add the option 'auto' to the entry.
 
Old 11-03-2012, 04:46 PM   #3
acummings
Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 615

Rep: Reputation: 49
In mine, a user can (easily) mount but it is not auto mount.

So maybe the noauto gets replaced with auto to make it auto mount?

Code:
al@ep451337_32:~$ cat /etc/fstab
/dev/sda6        swap             swap        defaults         0   0
/dev/sda8        /                ext4        defaults         1   1
/dev/sda1        /boot            ext2        defaults         1   2
/dev/sda9        /mnt/sda_9       ext4        noauto,users     0   0
/dev/sdb1        /mnt/sdb_1       ext4        noauto,users     0   0
/dev/cdrom       /mnt/cdrom       auto        noauto,users,ro  0   0
/dev/fd0         /mnt/floppy      auto        noauto,users     0   0
devpts           /dev/pts         devpts      gid=5,mode=620   0   0
proc             /proc            proc        defaults         0   0
tmpfs            /dev/shm         tmpfs       defaults         0   0
al@ep451337_32:~$
 
Old 11-04-2012, 02:28 AM   #4
GazL
Senior Member
 
Registered: May 2008
Posts: 3,383

Rep: Reputation: 913Reputation: 913Reputation: 913Reputation: 913Reputation: 913Reputation: 913Reputation: 913Reputation: 913
"auto" in fstab simply means that the system will attempt to mount it when you issue a 'mount -a' (which gets done for you during boot). It has nothing to do with automatically mounting of removable media on insertion. That is usually done by the desktop environment/file-manager though udev,udisks, dbus tend to be involved.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Auto-mount windows share on boot - manual OK, auto not ok! erskie Linux - Newbie 2 02-12-2008 06:42 PM
DVD (auto)mount problem, gnome-mount, hal, Fedora C 5 lazarion Linux - Hardware 5 01-10-2007 04:45 AM
My CD's and DVD's will not auto mount in 2007 rjw1678 Mandriva 1 10-20-2006 11:52 AM
? Auto mount Hard drive and CD/DVD roms Raticus Linux - Newbie 4 02-13-2006 10:22 AM
autofs enabled in kernel but auto.mount and auto.master are NOT in /etc! Alybyzrp Linux - General 0 11-11-2003 12:26 PM


All times are GMT -5. The time now is 01:46 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration