LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-09-2005, 10:24 PM   #1
dx0r515t
Member
 
Registered: Jan 2005
Location: USA
Distribution: Slackware 10.2 & 11.0
Posts: 155

Rep: Reputation: 30
auto load gui?


i want to bypass lilo's long wait automaticly and set it up to go to gui automaticly. how would i go about it?? adding some scripts? i'm at a loss there...


im using slack 9 btw.....
 
Old 02-09-2005, 10:29 PM   #2
JoannesX
Member
 
Registered: Dec 2004
Location: Brazil
Distribution: Slackware
Posts: 99

Rep: Reputation: 15
you don't have to change lilo configuration...
you only have to edit a file:

/etc/inittab

choose your favorite editor..
look for this line:

id:3:initdefault:

this number (3) indicates that you will start in console mode
for the gui, just change it to 4, ok?

hope it works!
 
Old 02-09-2005, 10:30 PM   #3
Tino27
Member
 
Registered: Aug 2003
Location: Akron, OH
Distribution: SuSE 8.2, Slackware current, OpenBSD 3.5-3.8, Fedora Core 2
Posts: 400

Rep: Reputation: 30
Set "timeout" equal to 0 in your /etc/lilo.conf file and then run "lilo -v" to write the changes (this must be done as root). This will bypass the timer countdown in the LILO page ... however, the start-up text screen will still run. So you won't go to X directly from LILO, but at least you won't have to wait for LILO to time out.
 
Old 02-09-2005, 10:31 PM   #4
secesh
Senior Member
 
Registered: Sep 2004
Location: Savannah, GA
Distribution: Ubuntu, Gentoo, Mythbuntu, ClarkConnect
Posts: 1,154

Rep: Reputation: 47
so, like run gdm/kdm/xdm by default, or something more crazy?

pico /etc/inittab, change line
id:3:initdefault:
to 4

edit:
here... so i can feel like i actually contributed something here (i guess i'm a slow typer)...
you might find this beneficial:
http://www.nesware.net/odin/gdmslack.php

Last edited by secesh; 02-09-2005 at 10:32 PM.
 
Old 02-09-2005, 10:32 PM   #5
dx0r515t
Member
 
Registered: Jan 2005
Location: USA
Distribution: Slackware 10.2 & 11.0
Posts: 155

Original Poster
Rep: Reputation: 30
thanks
 
Old 02-10-2005, 07:27 AM   #6
killerbob
Member
 
Registered: Oct 2004
Location: Ottawa, ON
Distribution: Slackware
Posts: 662

Rep: Reputation: 30
Quote:
Originally posted by Tino27
Set "timeout" equal to 0 in your /etc/lilo.conf file and then run "lilo -v" to write the changes (this must be done as root). This will bypass the timer countdown in the LILO page ... however, the start-up text screen will still run. So you won't go to X directly from LILO, but at least you won't have to wait for LILO to time out.
Setting the timeout to zero will actually make it last infinitely. You need to comment out (with a hash sign, #) the prompt line. That'll force LILO to skip the boot menu. Then run LILO, and it'll update the boot manager.

As for going directly into X, just edit /etc/inittab and change :id:3:initdefault to :id:4:initdefault
 
Old 02-10-2005, 08:37 AM   #7
Tino27
Member
 
Registered: Aug 2003
Location: Akron, OH
Distribution: SuSE 8.2, Slackware current, OpenBSD 3.5-3.8, Fedora Core 2
Posts: 400

Rep: Reputation: 30
According to the man page for lilo.conf ...

timeout=<tsecs>

sets a timeout (in tenths of a second) for keyboard
input at the boot: prompt. "timeout" only has
meaning if "prompt" is mentioned. If no key is
pressed for the specified time, the default image
is automatically booted. The default timeout is
infinite.

And just to be sure, I changed the "timeout" value to 0 in my own lilo.conf file, and rebooted. Sure enough, the LILO screen came up, but the default image (the first one listed) booted immediately.

Last edited by Tino27; 02-10-2005 at 08:38 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
grub doesn't auto-load kernel, time/date auto-change, k3b cannot load kenji1903 Red Hat 16 03-27-2005 08:48 PM
Auto Load bluehige Linux - Newbie 1 10-08-2004 03:57 PM
CUPS auto load DaveyB Linux - Software 2 09-03-2004 01:51 PM
Mozilla auto-load... dogn00dles Linux - Software 3 10-21-2003 07:09 AM
Auto-load into workspace MasterKin8T Linux - Software 1 09-20-2003 11:15 PM


All times are GMT -5. The time now is 02:04 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration