LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-26-2011, 09:01 AM   #1
MarcosPauloBR
Member
 
Registered: Feb 2011
Location: Santa Catarina - Brazil
Distribution: Slackware
Posts: 129

Rep: Reputation: 2
Question Audio work/don't work on Slackware 13.1


Hi people!

I have Slackware 13.1 on my desktop and my Laptop.

In both cases, my sound some times works, and some times doesn't works...

When audio does not works, I reboot some times (and make a alsaconf, alsactl store)...

Do you know what it can be??

Thanks!

OBS:
My audio drive(from lspci):
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

OBS2:
When I start the KDE and the sound Driver isn't working, is showed a window saying the Sound Card was removed.

Last edited by MarcosPauloBR; 04-26-2011 at 10:39 AM.
 
Old 04-27-2011, 02:04 AM   #2
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,230

Rep: Reputation: 286Reputation: 286Reputation: 286
Did you try running alsaconf as root to configure alsa for your sound card?
Then run alsamixer as a regular user to set your sound levels.
Then run alsactl store as root to save these settings.
Then reboot.
 
1 members found this post helpful.
Old 04-27-2011, 02:51 AM   #3
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
Do you have more than one audio-device i.e. does your laptop have HDMI?

As you know, with the command
Code:
lspci -k
the modules are shown which are in use a device. I'd recommend to check this in the following way: When you don't have sound, don't run alsaconf but "lspci -k" and look if the module for the soundcard is loaded. If it's not, load it with modprobe and find out if the sound is working now. alsaconf loads the modules for the sound-device, so if that's the problem you'll don't have to use alsaconf.

You may as a first step (when the sound is working) check which module is used. Then (the next time it doesn't work) check for the module. It may be, that the module isn't loaded automatically. The you can load it "manually" with modprobe.

If this is the problem, you can load the module at boot-time with modprobe in the /etc/modprobe.d directory. Be sure that the module isn't blacklisted.

Markus
 
Old 04-27-2011, 10:12 AM   #4
MarcosPauloBR
Member
 
Registered: Feb 2011
Location: Santa Catarina - Brazil
Distribution: Slackware
Posts: 129

Original Poster
Rep: Reputation: 2
Hi tommcd!

Yes, I did all this steps, and sometimes the KDE show a message that my Sound Card was removed...

Hi markush!

Now, my sound is OK, but when I do the command lspci -k only shows my audio card:

root@bahamut:/home/marcos-paulo# lspci -k | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
root@bahamut:/home/marcos-paulo#

Its strange??

For me yes =P

Thanks!!
 
Old 04-27-2011, 10:55 AM   #5
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
here as an example the output on my system:
Code:
markus@samsung:~$ /sbin/lspci -k | grep -iA3 audio
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
        Subsystem: Samsung Electronics Co Ltd Device c553
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel
--
01:00.1 Audio device: ATI Technologies Inc Manhattan HDMI Audio [Mobility Radeon HD 5000 Series]
        Subsystem: Samsung Electronics Co Ltd Device c553
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel
as you see there is the kernelmodule shown.

Markus
 
Old 04-27-2011, 09:27 PM   #6
MarcosPauloBR
Member
 
Registered: Feb 2011
Location: Santa Catarina - Brazil
Distribution: Slackware
Posts: 129

Original Poster
Rep: Reputation: 2
Thanks markush!

There is my output of my desktop

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
Subsystem: Intel Corporation Device d608
Kernel driver in use: HDA Intel
Kernel modules: snd-hda-intel

The sound is work on the 33.4 kernel.

I will try to compile the 38.4 with the /proc/config.gz of the 33.4 to see if my sound works =D

So, if the kernel 33.4 works sound(at this time...), so using this kernel configuration I can did it works on 38.4 too?? Or just copy the .config of the /usr/src/linux...33.4 to 38.4 and make a oldconfig ?

Thanks!
 
Old 04-28-2011, 02:01 AM   #7
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
Quote:
Originally Posted by MarcosPauloBR View Post
...
So, if the kernel 33.4 works sound(at this time...), so using this kernel configuration I can did it works on 38.4 too?? Or just copy the .config of the /usr/src/linux...33.4 to 38.4 and make a oldconfig ?...
Yes, this will work, and it is what I do in such cases.

What I meant in my first post was: if the sound does not work, you may check the modules and if they are not loaded, load them and check if the sound then works. In fact it is only one module to load.
I did not understand if you've checked this.

Markus
 
Old 04-29-2011, 06:00 AM   #8
MarcosPauloBR
Member
 
Registered: Feb 2011
Location: Santa Catarina - Brazil
Distribution: Slackware
Posts: 129

Original Poster
Rep: Reputation: 2
So, this never happen =D

I think its allright now!

Thanks for you markush, and all who helps!
 
Old 04-29-2011, 05:38 PM   #9
MarcosPauloBR
Member
 
Registered: Feb 2011
Location: Santa Catarina - Brazil
Distribution: Slackware
Posts: 129

Original Poster
Rep: Reputation: 2
People, it happen again... now on my laptop.....

By the way, I'm using the kernel 38.4(I happens on some kernels and on 33.4 too...)

It happens after I tryed to use my compiled kernel 39-rc5, and When i tried to start the KDM, my scrren become black, and I needed to press the shutdown button....

Do you think that the shutdown method can crash my audio driver(or his mapping on system)?

And, this is the output:

Code:
root@bahamut:/home/marcos-paulo# lspci -k | grep -iA3 audio
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
        Subsystem: FIRST INTERNATIONAL Computer Inc Device 3009
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel
And, my KDE says there my audio device was removed....

Its strange, because it happens in a random period....

Thanks!

Last edited by MarcosPauloBR; 04-29-2011 at 05:41 PM.
 
Old 04-29-2011, 05:42 PM   #10
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
The KDE message may result from a missing HDMI-driver in your graphics-driver. I have a Radeon HD 5470 graphics-adapter and when I use the kerneldriver (radeon) instead of ATI's fglrx driver I have always this message of KDE. As you know HDMI is a Video/Audio-port.

Markus
 
Old 04-30-2011, 06:26 AM   #11
MarcosPauloBR
Member
 
Registered: Feb 2011
Location: Santa Catarina - Brazil
Distribution: Slackware
Posts: 129

Original Poster
Rep: Reputation: 2
Hum...
Yesterday I made a test, and when I run a music player on root user, it works....

Can it be a permission to "see or execute" anything that uses the audio?

Thanks!
 
Old 04-30-2011, 06:34 AM   #12
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
you may find out to which groups you (the user) belong with the "id" command. You need to be at least member of the group audio.

Markus
 
Old 04-30-2011, 07:42 AM   #13
MarcosPauloBR
Member
 
Registered: Feb 2011
Location: Santa Catarina - Brazil
Distribution: Slackware
Posts: 129

Original Poster
Rep: Reputation: 2
Markus, I think you're right again =D

I was not a member of group audio, and When I put the audio group to my user and reboot, it works(ok ok, sometimes it can happens again...)

The most strange thing is that sometimes the audio works, and sometimes not...

But, I think that we can learn a lot with this type of problem!

Thanks again for our time!

Last edited by MarcosPauloBR; 04-30-2011 at 07:44 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
VOIP video + audio solutions you have tried that work properly or don't H_TeXMeX_H Linux - General 1 10-18-2010 06:26 AM
After first boot compiz, 3d, audio don't work. Gnome 5.1 Willrandship Sabayon 2 02-07-2010 01:40 PM
Some games don't work with audio enabled Googly Linux - General 1 01-02-2005 10:11 PM
Audio CDs don't work on Mandrake 10 Mike23 Mandriva 8 05-02-2004 06:25 AM
After 9.1 Kernal Compile Networking and Audio don't work nikko Slackware 7 11-08-2003 01:04 AM


All times are GMT -5. The time now is 09:52 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration