LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Audio Problems (http://www.linuxquestions.org/questions/slackware-14/audio-problems-843099/)

nova49 11-08-2010 05:26 PM

Audio Problems
 
I am unable to get any audio to play. I configured alsa and checked to make sure nothing was muted. I think the problem might be KDE related but I'm not sure.

Also when I restart the computer I get this error. "the audio playback device HDA intel (ALC887 Analog) does not work". Any suggestions would be good because I'm out of ideas.

onebuck 11-08-2010 05:39 PM

Hi,

Welcome to LQ!

Try removing '/etc/asound.state' then reboot to see if this corrects things. A new '/etc/asound.state' will be created.
:hattip:

nova49 11-08-2010 05:49 PM

I removed the file and it still doesn't work. I got the same error again too. The error is

Phonon: KDE's Multimedia Library
The audio playback device HDA intel (ALC889 Analog) does not work

onebuck 11-08-2010 06:00 PM

Hi,

How exactly did you setup the sound card?
Quote:

excerpt 'man alsaconf';

alsaconf - configuration tool for the Advanced Linux Sound Architecture

SYNOPSIS
alsaconf [options]

DESCRIPTION
This manual page documents briefly the alsaconf command.

Alsaconf is a simple shell script which tries to detect the sound cards on
your system and writes a suitable configuration file for ALSA. It will try to
guess what GNU/Linux distribution you're running, and will act accordingly to
the standards of that distribution, if specific support is available.

Alsaconf will write a module-init-tools (or modutils) snippet which can be
then used by module-init-tools (or modutils) to load the correct parameters
for your sound card.
Try 'alsaconf' from the cli as root. Then configure alsamixer settings, then do a 'alsactl store'. See what happens.
:hattip:

nova49 11-08-2010 06:23 PM

I was using alsaconf to configure the drivers. I also saved the settings useing alsactl store. So I don't think its that but I try again.

When setting it up I am given three options.
hda-intel - intel corporation 82801G (ICH7 Family) High Definition Audio
hda-intel - ATI technologies Inc HD48x0 audio
legacy - Probe leacy ISA (non-PnP) chips

onebuck 11-08-2010 06:37 PM

Hi,

What do you see for the audio device with 'lspci -vv'?
:hattip:

nova49 11-08-2010 07:49 PM

There were two with the label of audio device so Ill paste both.

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
Subsystem: Giga-byte Technology Device a002
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 4 bytes
Interrupt: pin A routed to IRQ 16
Region 0: Memory at fdff8000 (64-bit, non-prefetchable) [size=16K]
Capabilities: [50] Power Management version 2
Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
Capabilities: [60] MSI: Enable- Count=1/1 Maskable- 64bit+
Address: 00000000fee0300c Data: 4179
Capabilities: [70] Express (v1) Root Complex Integrated Endpoint, MSI 00
DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <64ns, L1 <1us
ExtTag- RBE- FLReset-
DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop+
MaxPayload 128 bytes, MaxReadReq 128 bytes
DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr+ TransPend-
LnkCap: Port #0, Speed unknown, Width x0, ASPM unknown, Latency L0 <64ns, L1 <1us
ClockPM- Surprise- LLActRep- BwNot-
LnkCtl: ASPM Disabled; Disabled- Retrain- CommClk-
ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
LnkSta: Speed unknown, Width x0, TrErr- Train- SlotClk- DLActive- BWMgmt- ABWMgmt-
Capabilities: [100] Virtual Channel <?>
Capabilities: [130] Root Complex Link <?>
Kernel driver in use: HDA Intel
Kernel modules: snd-hda-intel

This is the second one.

01:00.1 Audio device: ATI Technologies Inc HD48x0 audio
Subsystem: Dell Device aa30
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 4 bytes
Interrupt: pin B routed to IRQ 25
Region 0: Memory at fdefc000 (64-bit, non-prefetchable) [size=16K]
Capabilities: [50] Power Management version 3
Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
Capabilities: [58] Express (v2) Legacy Endpoint, MSI 00
DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <4us, L1 unlimited
ExtTag+ AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+
MaxPayload 128 bytes, MaxReadReq 128 bytes
DevSta: CorrErr- UncorrErr+ FatalErr- UnsuppReq+ AuxPwr- TransPend-
LnkCap: Port #0, Speed 2.5GT/s, Width x16, ASPM L0s L1, Latency L0 <64ns, L1 <1us
ClockPM- Surprise- LLActRep- BwNot-
LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- Retrain- CommClk-
ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
LnkSta: Speed 2.5GT/s, Width x4, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
DevCap2: Completion Timeout: Not Supported, TimeoutDis-
DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis-
LnkCtl2: Target Link Speed: 2.5GT/s, EnterCompliance- SpeedDis-, Selectable De-emphasis: -6dB
Transmit Margin: Normal Operating Range, EnterModifiedCompliance- ComplianceSOS-
Compliance De-emphasis: -6dB
LnkSta2: Current De-emphasis Level: -6dB
Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
Address: 00000000fee0300c Data: 4189
Capabilities: [100] Vendor Specific Information <?>
Kernel driver in use: HDA Intel
Kernel modules: snd-hda-intel

Daedra 11-08-2010 10:14 PM

It looks like what may be going on here is that you have two soundcards in your system and index=0 if being taken over by the secondary soundcard. You can fix this by editing your /etc/modprobe.d/sound.conf file settings to make your desired sound card the "first" soundcard alsa finds. For instance I have a asus xonar and usb webcam with microphone, so to set my xonar as soundcard 0 i edit like so...


alias snd-card-0 snd-virtuoso
alias sound-slot-0 snd-virtuoso
options snd-virtuoso index=0
alias snd-card-1 snd-usb-audio
alias sound-slot-1 snd-usb-audio
options snd-usb-audio index=1

more information on this can be found at this post
http://www.linuxquestions.org/questi...device-713793/

This may not be whats going, but it might be worth a look.

rfernandez 11-08-2010 11:12 PM

Which groups you belong to? Are you part of the audio group?

nova49 11-09-2010 07:31 AM

I logged into root and that seemed to fix the problem. Thanks from every one who helped. When I get home I'll fix the groups that user is part of. I was so convinced that it was software error that I didn't even think about user error.

onebuck 11-09-2010 08:36 AM

Hi,

Glad it was something as simple as 'groups'.

You should be sure to add the 'user' to;
Code:

users floppy audio video cdrom plugdev power netdev
This can be done when you do a 'adduser' after the 'user' addition, press the up-arrow for suggest groups. You can edit this line with cursor keys.

BTW, if the thread is solved then mark as such via the 'Thread Tools'.
:hattip:

nova49 11-09-2010 05:01 PM

One quick questions. I did a quick Google search and turned up nothing on this so I'm asking here. Is it possible to change the user groups a user is in with out having to delete the account and recreating it.

onebuck 11-09-2010 05:14 PM

Hi,

'useradd' will let you manage user accounts. Do a 'man useradd'.


Look at 2 & 7 below.


Just a few links to aid you to gaining some understanding;



1 Linux Documentation Project
2 Rute Tutorial & Exposition
3 Linux Command Guide
4 Bash Beginners Guide
5 Bash Reference Manual
6 Advanced Bash-Scripting Guide
7 Linux Newbie Admin Guide
8 LinuxSelfHelp
9 Getting Started with Linux

The above links and others can be found at 'Slackware-Links'. More than just SlackwareŽ links!

nova49 11-09-2010 05:25 PM

Thanks for all of the help.

rfernandez 11-09-2010 09:46 PM

onebuck gave you better directions for your problem, but a direct answer for your question is yes, you can change the groups the user is part of without removing the user. In terminal, as root, you can use gpasswd or usermod (though the last one is not recommended).


All times are GMT -5. The time now is 12:33 PM.