LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   audio cds won't mount/play but dvds in same drives play. Running SW12.2current. (http://www.linuxquestions.org/questions/slackware-14/audio-cds-wont-mount-play-but-dvds-in-same-drives-play-running-sw12-2current-728658/)

lestoil 05-26-2009 02:29 PM

audio cds won't mount/play but dvds in same drives play. Running SW12.2current.
 
I can play dvds with Mplayer. Web music and video play fine. When I put in music cd in /dev/hdc(top drive) get message:"dev/hdc is write-protected,mounting read-only;mount:/dev/hdc:can't read superblock". When I use lower cdrom(/dev/hdd) I get error:"mount:mount point /mnt/media does not exist." A message pops up on inserting cd in either drive: "Devices recently plugged in: optical disk: extract digital audio with K3b." Amarok and Audacious can't seem to find or play cds(?) So I can't play audio cds at all.
"/etc/fstab" has /dev/cdrom /mnt/cdrom auto noauto,owner,user 0 0
/dev/hdd /mnt/media auto noauto,owner,user 0 0

"/etc/group" has me as member of audio,video,plugdev,cdrom,and disk.

"/etc/udev/rules.d/persistent-cd.rules" has NEC_DVD_RW_ND-3520A ide-1:1
SYMLINK+=cdrom0 and DVDRW_16x16x ide-1:0 SYMLINK+=cdrom0

"/root/dev" has files with "?" for cdrom0,cdrom1,dvdrom0,dvdrom1,cdrw0,cdrw1,etal
Can anyone lead me to solving this problem? "/etc/fstab" and "/etc/group" are unchanged from SW12.2. Thanks.

lestoil 05-26-2009 02:50 PM

audio cds won't mount/play but dvds in same drives play. Running SW12.2current.
 
I can play dvds with Mplayer. Web music and video play fine. When I put in music cd in /dev/hdc(top drive) get message:"dev/hdc is write-protected,mounting read-only;mount:/dev/hdc:can't read superblock". When I use lower cdrom(/dev/hdd) I get error:"mount:mount point /mnt/media does not exist." A message pops up on inserting cd in either drive: "Devices recently plugged in: optical disk: extract digital audio with K3b." Amarok and Audacious can't seem to find or play cds(?)
"/etc/fstab" has /dev/cdrom /mnt/cdrom auto noauto,owner,user 0 0
/dev/hdd /mnt/media auto noauto,owner,user 0 0

"/etc/group" has me as member of audio,video,plugdev,cdrom,and disk.

"/etc/udev/rules.d/persistent-cd.rules" has NEC_DVD_RW_ND-3520A ide-1:1
SYMLINK+=cdrom0 and DVDRW_16x16x ide-1:0 SYMLINK+=cdrom0

"/root/dev" has files with "?" for cdrom0,cdrom1,dvdrom0,dvdrom1,cdrw0,cdrw1,etal
Can anyone lead me to solving this problem? "/etc/fstab" and "/etc/group" are unchanged from SW12.2. Thanks.

H_TeXMeX_H 05-26-2009 03:21 PM

Look, you cannot mount an audio CD, period, it's just raw data, you can only mount filesystems. xine for example has a CD option which plays cdda.

lestoil 05-28-2009 01:05 PM

Finally got audio cd to play in audacious player by clicking infinity symbol to left of AUDACIOUS and choosing rescan cd. Have yet to find similar in Amarok which had cd option in drop down menu. Kaffeine had similar ease but it's not in Current.

H_TeXMeX_H 05-28-2009 01:56 PM

I distinctly remember answering this one ... yeah, in fact one of these is a double post:

http://www.linuxquestions.org/questi...rrent.-728665/

unSpawn 05-28-2009 04:02 PM

Please post your thread once and in only one forum. Posting a single thread in the most relevant forum will make it easier for members to help you and will keep the discussion in one place. Your threads have been merged.

lestoil 05-28-2009 07:33 PM

Solved audio cds won't mount/play in SW12current
 
It seems rebooting a few times got AUDACIOUS menu to have "rescan cd". I merely wanted audio cds to play not just have K3B extract the audio tracts.
Don't know how the double entry appeared. Sorry for that. It must have been when I tried to edit/add-to the original post that no audio cds would play at all.:)


All times are GMT -5. The time now is 07:49 AM.