LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-01-2004, 08:24 AM   #1
mijenks
Member
 
Registered: Mar 2004
Location: NY
Distribution: Gentoo
Posts: 112

Rep: Reputation: 15
Audio CD Doesn't Play - Slackware


I feel really dumb, because I've googled and searched for about three days and find people with similar problems, but whatever I do, I can't get this to work. I've searched and RTFM, so I'll save you the trouble.

I can mount data CDs (e.g. the Slack install disk) but I cannot play audio CDs.

I'm using BBCD in Blackbox. I've read that audio CDs don't get mounted, but then how do they get recognized/played? I don't know if the CD drive is connected directly to the sound card, though I would bet that it is NOT. lspci shows that I'm using a MATSHITA CD-RW, it's on a laptop.

One dumb thing I haven't checked is sound levels on alsamixer. I'm at work now and can't check, though.

I believe that the ide-scsi module is loaded, but not sure if it's relevant. FWIW, I am able to play CDs with FC1 (they autostart when I insert the disc).

Thanks for any help.
 
Old 07-01-2004, 10:05 AM   #2
lyceum
Member
 
Registered: Aug 2003
Location: N.C.
Distribution: rh9, fc1, slack 9.1, 10
Posts: 229

Rep: Reputation: 30
i would try the sequence:
Code:
alsaconf
which will probe for your sound card, then
Code:
alsamixer
and make sure that for instance the master isn't turned off. i think you press "m" to turn each one on that you need. there is also one for "cd." after getting your levels where you want them, then give the command:
Code:
alsactl store
to save them.

hope this helps.

a question: are you able to get any other sound from your system aside from system beeps?
 
Old 07-01-2004, 10:23 AM   #3
kevinatkins
Member
 
Registered: Jan 2004
Location: cheshire, uk
Distribution: Ubuntu Hoary
Posts: 605

Rep: Reputation: 32
hi,

you mentioned you're using a laptop, in which case it's quite possible (probable perhaps?) that there is no audio connection from your cd drive to the onboard sound.

you could try using xine to play an audio cd - it uses digital audio extraction over the ide bus. you'll need to configure xine so that it looks at your cd drive for audio playback.
 
Old 07-02-2004, 07:44 AM   #4
mijenks
Member
 
Registered: Mar 2004
Location: NY
Distribution: Gentoo
Posts: 112

Original Poster
Rep: Reputation: 15
Thanks for the help.

Yeah I have a feeling that, because it's a laptop, that the CD drive isn't directly connected. On the other hand, the Fedora partition uses the default CD player whenever I insert an audio CD, and from what I've seen/read, most of the 'simple' CD players (i.e. no other features like mp3 support, etc) cannot play a CD that isn't connected to the soundcard.

Note that I can easily mount data CDs (e.g. Slack Install disc).

Finally, I built a 2.6.7 kernel last night and had support for my soundcard driver built into the kernel, so sound worked. I don't know if I went about it the right way or what, but before I realized sound worked, I ran alsaconf and ALSA was not able to detect my soundcard. Once I ran alsamixer, though, I had sound. Unfortunately it was still only mp3 sound.

I will try playing the CD through Xine, but I would prefer to use bbCD, as it is much simpler. Let me just clarify that it is not possible to mount the audio CD, but it is possible to mount data CDs.

Again, thanks for the help.
 
Old 07-02-2004, 08:29 AM   #5
ringwraith
Senior Member
 
Registered: Sep 2003
Location: Indiana
Distribution: Slackware-current
Posts: 1,244

Rep: Reputation: 47
I use xmms to play cds, and no you do not moun them.
make sure in the preferences the device you are trying to play is the devive listed in your fstab table. You may have to set up the differnt input/outputs and configure them.
 
Old 07-04-2004, 11:45 AM   #6
mijenks
Member
 
Registered: Mar 2004
Location: NY
Distribution: Gentoo
Posts: 112

Original Poster
Rep: Reputation: 15
OK, well I was hoping to get CDs to play with bbCD or a similar simple cd player, but I couldn't get it to work.

I configed the cdread plugin for XMMS, but when I hit "check drive" I got an error, something about 'ioctl'. I decided I'd give Xine a shot (which I had installed already), and it worked like a charm. I assume that Xine handles the on-the-fly decompression that the cdread plugin is supposed to do for XMMS.

The 2.6.7 kernel I built included built-in support for my soundcard, too.
 
Old 07-04-2004, 04:25 PM   #7
ringwraith
Senior Member
 
Registered: Sep 2003
Location: Indiana
Distribution: Slackware-current
Posts: 1,244

Rep: Reputation: 47
on the xmms cd configure, did you make sure it is trying to play the right drive. if scsi emulation you have to reflect that. did you try digital audio extraction
 
Old 07-04-2004, 05:44 PM   #8
r_jensen11
Senior Member
 
Registered: Apr 2003
Location: Minnesota, USA
Distribution: Slack 10.0 w/2.4.26
Posts: 1,032

Rep: Reputation: 45
I'm using the 2.4.26 kernel right now (Customized, of course), and have scsi-emulation enabled both in the kernel and in LILO. If you have the same type of setup as me, you'll want to change the sybolic link of the CDRW from whatever it is (Probably /dev/hdc or /dev/hdd) to /dev/scd0. If you're using a 2.6 kernel, however, I suggest taking off scsi-emulation support. Then you can use the cdrw drive normally, having /dev/cdrom point to /dev/hdc or /dev/hdd, or whatever it is for you. If you don't have an audio cable running from the cdrom drive to the soundcard, try using XMMS and use Digital Audio Extraction instead of Analog for the play mode in the CD Audio Player configuration, and then hopefully it will work. If it doesn't, make sure that the actual device (Not the sybolic link) is chmodded something like 666 or something along the lines of that (You could have 777 if you'd wish, I just don't like giving out more permissions than I have to.)
 
Old 07-21-2004, 12:28 PM   #9
Qzukk
Member
 
Registered: Jun 2003
Posts: 132

Rep: Reputation: 15
One thing to remember is that your user has to have permission to operate the cdrom drive. Many distributions create a "cdrom" group for this, and you'll have to add the user to that cdrom group (if your distribution has a tool for group management, use it. Otherwise add the user to the end of the "cdrom" line in the /etc/group file). Some distributions may just use the "sound" or "audio" group for it, others may not have a group defined for it, and just expect you to give everyone read+write access to the device.

check the permissions on your cdrom device (typically the distribution will point /dev/cdrom to it, ls -l /dev/cdrom, then ls -l whatever it points to. Make sure /dev/cdrom points to the actual CD device (if mounting /dev/cdrom works, it is), since thats usually the default that all the software will use. Mounting and directly accessing the drive itself requires different permissions.

Your IOCTL error makes it sound like either the user doesn't have access to the cdrom drive, or you're trying to use the wrong device.

And they're right, you do not mount audio cds, they do not have a filesystem on them (unless they're those hybrid DRM cds that have the player software on them too)
 
Old 07-22-2004, 11:44 PM   #10
lyle_s
Member
 
Registered: Jul 2003
Distribution: Slackware
Posts: 388

Rep: Reputation: 52
Re: Audio CD Doesn't Play - Slackware

Quote:
Originally posted by mijenks
I can mount data CDs (e.g. the Slack install disk) but I cannot play audio CDs.
Quote:
Originally posted by mijenks
I had sound. Unfortunately it was still only mp3 sound.
I had the same problem. I solved it by changing the group owner of my cdrom device to 'cdrom'. The group owner of my cdrom device was 'disk' before I changed it to 'cdrom'.

Basically what I did:[list=1][*]Determine which device in /dev the /dev/cdrom symbolic link points to:

ls -l /dev/cdrom

In my case it was /dev/hdc
[*]Change that device's group owner to 'cdrom'. For example, (as root):

chown root.cdrom /dev/hdc

Change '/dev/hdc' above to the device your /dev/cdrom symbolic link points to.[/list=1]

Lyle
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to play audio cd in slackware 10.1? anindyanuri Slackware 13 06-26-2005 01:06 AM
why i can't play my CD audio mamasmoe DamnSmallLinux 1 08-12-2004 08:31 PM
Can't play audio cd melinda_sayang Slackware 12 03-20-2004 05:23 AM
Can't play CD Audio morrolan Linux - Software 3 01-05-2004 09:55 AM
DVD plays but no audio (can play audio cd's though)? guitarnix Linux - Newbie 2 10-05-2003 08:52 AM


All times are GMT -5. The time now is 02:15 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration