LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-28-2013, 09:16 PM   #1
a sandwhich
LQ Newbie
 
Registered: May 2012
Posts: 3

Rep: Reputation: Disabled
Audio available to only one process at a time


I'm running slackware 13.37 on a decent intel setup. Overall there haven't been very many issues at all, except for a problem with the audio. When it is working, it comes across just fine. The problem is that only one program can use it at a time. When starting up kde, I have to launch chrome within about 10 seconds in order for chrome to be able to use audio. If I want to switch audio from one tab to another tab, or from chrome to another program, I have to stop the audio completely in the old tab, and then wait a few seconds and start it in the new one. I have tried reconfiguring alsa, but that has yielded no significant change. Would anyone have any ideas how to fix this? "lspci | grep Audio" produces these two entries, and alsaconf only detects the first.

Code:
00:1b.0 Audio device: Intel Corporation 6 Series Chipset Family High Definition Audio Controller (rev 05)

01:00.1 Audio device: ATI Technologies Inc Device aa80
 
Old 03-28-2013, 11:54 PM   #2
SwiftTimber-Z80
LQ Newbie
 
Registered: Mar 2013
Posts: 20

Rep: Reputation: Disabled
Do the other programs have their own alsa settings?
 
Old 03-28-2013, 11:59 PM   #3
a sandwhich
LQ Newbie
 
Registered: May 2012
Posts: 3

Original Poster
Rep: Reputation: Disabled
I do not think so. The fact that it is consistent among them all would lead me to think it is a system-wide problem.
 
Old 03-29-2013, 01:58 AM   #4
Mark Pettit
Member
 
Registered: Dec 2008
Location: Cape Town, South Africa
Distribution: Slackware 14.1 64 Multi-Lib
Posts: 441

Rep: Reputation: 139Reputation: 139
It's not a problem - it's a feature. Would you want to listen to 2 mp3 songs and watch a movie at the same time ? Modern music is bad enough coming through by itself - no need to make it worse ! If you want the bug, install PulseAudio - it has that 'misfeature'.
 
Old 03-29-2013, 04:22 AM   #5
Stephen Morgan
Member
 
Registered: Feb 2011
Location: England
Distribution: Slackware
Posts: 154

Rep: Reputation: 15
Put this in your ~/.asoundrc :

Code:
pcm.dsp {
    type plug
    slave.pcm "dmix"
}
That fixed this issue for me. You'll have to log out and back in for it to take effect. It's meant to be enabled by default in modern versions of ALSA, but apparently that doesn't quite always work.
 
Old 03-29-2013, 07:49 AM   #6
Martinus2u
Member
 
Registered: Apr 2010
Distribution: Slackware
Posts: 350

Rep: Reputation: 56
Quote:
Originally Posted by a sandwhich View Post
The problem is that only one program can use it at a time.
I seem to have this problem only with certain proprietary 32 bit applications that use the OSS compatibility layer (on a 64 bit installation). Haven't found a solution yet.

Quote:
Originally Posted by Mark Pettit View Post
It's not a problem - it's a feature. Would you want to listen to 2 mp3 songs and watch a movie at the same time ? Modern music is bad enough coming through by itself - no need to make it worse ! If you want the bug, install PulseAudio - it has that 'misfeature'.
totally unhelpful statement. Even if I listen to only one sound source at the time, why shouldn't I be able to switch at runtime? Currently you have to shut down both applications and restart the silent one to enable it's sound. One of them may be a firefox with hundreds of tabs and flashplayer instances. The other one may be a MMORPG that you don't wanna shut down every other minute. And why the heck am I not allowed to check a youtube link someone sends me while online with my MMORPG?

This software behaviour is user hostile and patronizing, and words escape me how anyone can verbally turn such a behaviour into a feature.
 
Old 03-29-2013, 07:54 AM   #7
GazL
Senior Member
 
Registered: May 2008
Posts: 3,480

Rep: Reputation: 1016Reputation: 1016Reputation: 1016Reputation: 1016Reputation: 1016Reputation: 1016Reputation: 1016Reputation: 1016
Quote:
Originally Posted by Martinus2u View Post
I seem to have this problem only with certain proprietary 32 bit applications that use the OSS compatibility layer (on a 64 bit installation). Haven't found a solution yet.
What I do is blacklist the oss emulation kernel modules (You'll also need to edit rc.alsa and add the -b option to the modprobe lines) and then start the troublesome apps using 'aoss'
 
Old 03-29-2013, 09:23 AM   #8
fskmh
Member
 
Registered: Jun 2002
Location: South Africa
Distribution: Slackware64-current multilib
Posts: 235

Rep: Reputation: 55
Guys, I'm not a Lennart fan, but I installed Pulseaudio 3.0 on -current using the SlackBuild from SBo and some config info I found on this subforum, and it was pretty straightforward.

It's worth a little bit of work if you want software multiplexing and independent volume control for different apps. Also, if you have the patience to build all the Gnome binding libs (libglademm, gtkmm, atkmm, mm-common, pangomm, cairomm, glibmm (requires libsigc++ and optionally graphviz)) then you can also add PulseAudio Volume Controller which has some nice additional functionality.
 
Old 03-29-2013, 06:28 PM   #9
a sandwhich
LQ Newbie
 
Registered: May 2012
Posts: 3

Original Poster
Rep: Reputation: Disabled
Quote:
It's not a problem - it's a feature. Would you want to listen to 2 mp3 songs and watch a movie at the same time ? Modern music is bad enough coming through by itself - no need to make it worse ! If you want the bug, install PulseAudio - it has that 'misfeature'.
How can that be a feature? It is a feature that I have to restart applications to get audio working on one? Do you have this feature enabled and do you enjoy making use of it?

I tried the editing of .asoundrc and that didn't do anything, so I tried to install pulseaudio only to be met with compiler and build errors. Owell

Last edited by a sandwhich; 03-29-2013 at 06:49 PM.
 
Old 03-30-2013, 05:15 AM   #10
Martinus2u
Member
 
Registered: Apr 2010
Distribution: Slackware
Posts: 350

Rep: Reputation: 56
Quote:
Originally Posted by GazL View Post
What I do is blacklist the oss emulation kernel modules (You'll also need to edit rc.alsa and add the -b option to the modprobe lines) and then start the troublesome apps using 'aoss'
Thanks for the pointer. I'll look into aoss. Just need to build a new kernel as I tend to use static kernels on my machines...

Edit: just for the record, I have the alsa-oss-compat32 package, too, and the wrapper script uses the $LIB token for LD_PRELOAD, so everything should be fine under multilib as well. knock on wood. ^^

Last edited by Martinus2u; 03-30-2013 at 05:27 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
compute the run time and sleep time of a process in kernel 2.4 quartaela Linux - Kernel 0 12-19-2012 10:44 PM
[SOLVED] How to save the pid of a process at the time of process startup jhonnappier2007 Linux - Newbie 13 11-21-2011 12:54 AM
audio notify thingy, which process is it? KaKaj Fedora 2 12-27-2010 03:49 AM
how do i get the values for the user time and system time for a process. aloktiagi Linux - Newbie 3 08-04-2009 07:55 PM
M-Audio Fast Track Pro only accepts one audio connection at a time BorgAssimilator Linux - Hardware 0 09-29-2008 04:04 AM


All times are GMT -5. The time now is 11:27 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration