LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Audio available to only one process at a time (http://www.linuxquestions.org/questions/slackware-14/audio-available-to-only-one-process-at-a-time-4175455970/)

a sandwhich 03-28-2013 08:16 PM

Audio available to only one process at a time
 
I'm running slackware 13.37 on a decent intel setup. Overall there haven't been very many issues at all, except for a problem with the audio. When it is working, it comes across just fine. The problem is that only one program can use it at a time. When starting up kde, I have to launch chrome within about 10 seconds in order for chrome to be able to use audio. If I want to switch audio from one tab to another tab, or from chrome to another program, I have to stop the audio completely in the old tab, and then wait a few seconds and start it in the new one. I have tried reconfiguring alsa, but that has yielded no significant change. Would anyone have any ideas how to fix this? "lspci | grep Audio" produces these two entries, and alsaconf only detects the first.

Code:

00:1b.0 Audio device: Intel Corporation 6 Series Chipset Family High Definition Audio Controller (rev 05)

01:00.1 Audio device: ATI Technologies Inc Device aa80


SwiftTimber-Z80 03-28-2013 10:54 PM

Do the other programs have their own alsa settings?

a sandwhich 03-28-2013 10:59 PM

I do not think so. The fact that it is consistent among them all would lead me to think it is a system-wide problem.

Mark Pettit 03-29-2013 12:58 AM

It's not a problem - it's a feature. Would you want to listen to 2 mp3 songs and watch a movie at the same time ? Modern music is bad enough coming through by itself - no need to make it worse ! If you want the bug, install PulseAudio - it has that 'misfeature'.

Stephen Morgan 03-29-2013 03:22 AM

Put this in your ~/.asoundrc :

Code:

pcm.dsp {
    type plug
    slave.pcm "dmix"
}

That fixed this issue for me. You'll have to log out and back in for it to take effect. It's meant to be enabled by default in modern versions of ALSA, but apparently that doesn't quite always work.

Martinus2u 03-29-2013 06:49 AM

Quote:

Originally Posted by a sandwhich (Post 4920831)
The problem is that only one program can use it at a time.

I seem to have this problem only with certain proprietary 32 bit applications that use the OSS compatibility layer (on a 64 bit installation). Haven't found a solution yet.

Quote:

Originally Posted by Mark Pettit (Post 4920900)
It's not a problem - it's a feature. Would you want to listen to 2 mp3 songs and watch a movie at the same time ? Modern music is bad enough coming through by itself - no need to make it worse ! If you want the bug, install PulseAudio - it has that 'misfeature'.

totally unhelpful statement. Even if I listen to only one sound source at the time, why shouldn't I be able to switch at runtime? Currently you have to shut down both applications and restart the silent one to enable it's sound. One of them may be a firefox with hundreds of tabs and flashplayer instances. The other one may be a MMORPG that you don't wanna shut down every other minute. And why the heck am I not allowed to check a youtube link someone sends me while online with my MMORPG?

This software behaviour is user hostile and patronizing, and words escape me how anyone can verbally turn such a behaviour into a feature.

GazL 03-29-2013 06:54 AM

Quote:

Originally Posted by Martinus2u (Post 4921027)
I seem to have this problem only with certain proprietary 32 bit applications that use the OSS compatibility layer (on a 64 bit installation). Haven't found a solution yet.

What I do is blacklist the oss emulation kernel modules (You'll also need to edit rc.alsa and add the -b option to the modprobe lines) and then start the troublesome apps using 'aoss'

fskmh 03-29-2013 08:23 AM

Guys, I'm not a Lennart fan, but I installed Pulseaudio 3.0 on -current using the SlackBuild from SBo and some config info I found on this subforum, and it was pretty straightforward.

It's worth a little bit of work if you want software multiplexing and independent volume control for different apps. Also, if you have the patience to build all the Gnome binding libs (libglademm, gtkmm, atkmm, mm-common, pangomm, cairomm, glibmm (requires libsigc++ and optionally graphviz)) then you can also add PulseAudio Volume Controller which has some nice additional functionality.

a sandwhich 03-29-2013 05:28 PM

Quote:

It's not a problem - it's a feature. Would you want to listen to 2 mp3 songs and watch a movie at the same time ? Modern music is bad enough coming through by itself - no need to make it worse ! If you want the bug, install PulseAudio - it has that 'misfeature'.
How can that be a feature? It is a feature that I have to restart applications to get audio working on one? Do you have this feature enabled and do you enjoy making use of it?

I tried the editing of .asoundrc and that didn't do anything, so I tried to install pulseaudio only to be met with compiler and build errors. Owell

Martinus2u 03-30-2013 04:15 AM

Quote:

Originally Posted by GazL (Post 4921028)
What I do is blacklist the oss emulation kernel modules (You'll also need to edit rc.alsa and add the -b option to the modprobe lines) and then start the troublesome apps using 'aoss'

Thanks for the pointer. I'll look into aoss. Just need to build a new kernel as I tend to use static kernels on my machines...

Edit: just for the record, I have the alsa-oss-compat32 package, too, and the wrapper script uses the $LIB token for LD_PRELOAD, so everything should be fine under multilib as well. knock on wood. ^^


All times are GMT -5. The time now is 04:52 PM.