LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-26-2002, 09:33 PM   #1
TripleHex
Member
 
Registered: Aug 2002
Posts: 31

Rep: Reputation: 15
Audio


My next question is a bit harder.

So far my Slcakware has no Audio whatsoever from the speakers only the little beeps. I try to play a wave file and nothing plays. My sound card is an on Board SB AudioPCI 128 on my Intel VC820 PII motherboard. How in the world do i set this up? I have no idea.

T|-|><
 
Old 08-27-2002, 01:19 AM   #2
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
I think the SB PCI 128 would use the es1371 module. So you could try:

modprobe es1371

I believe it uses the Ensoniq 1371 chip after Creative bought out Ensoniq. If doing a kernel build then enable the Ensoniq 1371 support in the sound sections.
 
Old 08-27-2002, 03:47 AM   #3
nautilus_1987
Member
 
Registered: Aug 2002
Distribution: Slackware 8.1
Posts: 750

Rep: Reputation: 30
You should edit /etc/rc.d/rc.modules. There you will have to decomment (remove '#') one line in Sound section.
I think it is the first or second line, so those lines show what modules should be loaded and what not. You can decomment 1 or 2 line and your SB will work ( I think, my friend SB works that way )

Good luck!
 
Old 08-27-2002, 06:42 AM   #4
wonderpun
Member
 
Registered: Aug 2002
Location: Geekland, Planet Earth
Distribution: Slackware 9.1
Posts: 323

Rep: Reputation: 30
Both of the guys are right. You just open the file /etc/rc.d/rc.modules in some editor and then scroll down until you see the Sound section. There search for your sound card(I pretty sure that it's the sixth one(es1370)) an decomment the line with the name of your sound card.(Leave the commentaries commented) Then you can reboot or just type in the console:

modprobe es1370 (If this is the right one but if not then change it with the aprpriate one)

That's it! Enjoy the sounds!
 
Old 08-27-2002, 10:01 AM   #5
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
I think if the es1370 doesn't work you can also try modprobing sb16, the generic sb module.

I would give the attempt first to modprobe, and when you figure out which module you need, then edit the rc.modules file accordingly, but that's just my 0.02

Cool
 
Old 08-27-2002, 03:17 PM   #6
TripleHex
Member
 
Registered: Aug 2002
Posts: 31

Original Poster
Rep: Reputation: 15
nope nothing worked
i uncommented ALL devices ( i left the line "CARDXXX Support:" commented)

i reboot the system
boot into GNOME and tried the configuration tool with the sample souinds to test. none of them played.

then i exited X:

i tried modprobe es1370 -got device busy errors
i tried modprobe es1371-worked fine but still no sound
i tried modprobe sb16-sez it dont exist

i also tried editing rc.modules.new and did all of the above and still no sound.

maybe cuz i'm running Slackware 8.0 with kernel 2.2.19?
 
Old 08-27-2002, 03:52 PM   #7
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
After you do the modprobe es1371, do "lsmod" and "dmesg"
The lsmod should indicate what modules are loaded and they should include sound and es1371. The dmesg command should report at the end that it was detected and report some stats.

These should be as root and test the sound output as root. Some privileges will need to be set for normal users. If it still doesn't work then check the speaker connectors, power, volume, etc. Attempt to get a mixer running and see what the volume level is set at and that it is not muted.

Perhpas some these items will help.
 
Old 08-27-2002, 06:20 PM   #8
TripleHex
Member
 
Registered: Aug 2002
Posts: 31

Original Poster
Rep: Reputation: 15
can't say that didnt do anything. es1371 is now recognized as a module.
the little beeps now came from the right speaker. this shows the module works. i ran a mixer and turned up the left speaker equally. now the beeps come from both speakers. but i still can't hear mp3's or other sounds. how come?
 
Old 08-27-2002, 07:06 PM   #9
Marshall
LQ Newbie
 
Registered: Jul 2002
Posts: 11

Rep: Reputation: 0
Are you experiencing the same problems as root? This could simply be a permission problem.

This may be a long shot, but I had a similiar problem where I have both "line-out" and "speaker" connections on my sound card. If I connect my speakers to the wrong one, I did not get sound..... may not be your problem, but to be safe I would double check your connections.

Good luck!
 
Old 08-27-2002, 07:10 PM   #10
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
The mixer panel should have had at least 5 or 6 different level controls. LIke, main volume, PCM, MIDI, Line Input, Mic, CD Input, Record level, etc. The PCM control is the one that controls the MP3 input volume. If the levels are separated, left and right. The mixer should allow you to lock them in sync. Also, depending on the mixer control each of them can disabled or enabled. That should also have a method of control.

I use kmix myself. It uses green dots to indicate enabled and dark green to indicate disabled or muted. Clicking on the dots will toggle the state on or off.

Also, the MP3 player or CD Player may also have a volume control slider and that may need to be adjusted upward as well.
 
Old 08-27-2002, 07:56 PM   #11
TripleHex
Member
 
Registered: Aug 2002
Posts: 31

Original Poster
Rep: Reputation: 15
well all is configured well the PCM and all is fine. i know the sound card/speakers are connected well becuz i have a dual boot and all sonds work fine on windows NT. the thing thats confusing me is mayube the mp3 and everything work but i never actually see the file playing i use GQmpeg and it always stays at 0:00. KDE media player crashes. nothing really plays the files!!
 
Old 08-27-2002, 08:59 PM   #12
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
if you have KDE installed try "noatun" or "xmms" for your MP3's. Or even "kscd" to just play an audio CD. xmms should be in /usr/bin and the other two should be in /opt/kde/bin directories.
 
Old 08-27-2002, 11:52 PM   #13
TripleHex
Member
 
Registered: Aug 2002
Posts: 31

Original Poster
Rep: Reputation: 15
nope. ABSOLUTELY everything i try crashes X after i try to play the file. jeez what could be the problem. also in my first post in this thread i might have been confusing. The original beeps came from the computer and not the speakers. now they come from the speakers. What the hell could be the problem???
 
Old 08-28-2002, 02:26 AM   #14
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
Since you are running a 2.2.19 kernel and I haven't run a 2.2.x kernel in real long time. You might want to take a look at the alsa project.

http://alsa-project.org

They list two different but similar cards. PCI 128 and 128 PCI. They reference a "es1373" driver that I have never heard of as far as kernel support. Since I think your sound is integrated, it might be rather hard to identify between the two. My card is the PCI 64 flavor that uses the es1371 driver. I switched over to the alsa drivers a few weeks ago to give them a test drive and they have been working great for me. But I don't really see (hear) any difference than with kernel support.

The alsa drivers will require compiling before being installed and read the docs carefully.

Good luck.
 
Old 08-28-2002, 03:37 AM   #15
TripleHex
Member
 
Registered: Aug 2002
Posts: 31

Original Poster
Rep: Reputation: 15
i must've read that on like 5 websites "i have not ran a 2.2.x.x kernel in a long time"

i can get the 2.4.19 to work. i keep getting a kymos when i do make zImage or bzImage. i know what kymos.o is? when i work this out ill install 2.4.19 and then i wont need alsa right?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
AC'97 Conexant audio (aka, AC-Link Audio) (Gateway 7510GX) Vexamus Linux - Hardware 25 10-07-2009 10:15 PM
Why I can't use USB audio device when onboard audio enabled in install RockyZ Fedora 6 03-28-2009 08:40 PM
Reading audio data files as an actual audio file? Erik_the_Red Linux - Software 1 06-01-2005 08:22 AM
M-Audio Mobile Pre USB Audio interface will not work verdeboy Linux - Hardware 0 11-20-2003 11:20 AM
DVD plays but no audio (can play audio cd's though)? guitarnix Linux - Newbie 2 10-05-2003 08:52 AM


All times are GMT -5. The time now is 11:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration