LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Audacious won't play AAC AAC+, & no system sounds KDE 4.4.3 (http://www.linuxquestions.org/questions/slackware-14/audacious-wont-play-aac-aac-and-no-system-sounds-kde-4-4-3-a-808167/)

netcrawl 05-16-2010 12:40 PM

Audacious won't play AAC AAC+, & no system sounds KDE 4.4.3
 
I've got some sound problems since installing the last Slackware64 current updates...

Audacious and Xmms will not play AAC and AAC+ files. Mp3's, flac play fine. Xine and Amarok play AAC AAC+ same as ever. Anyone have an idea what's missing or changed, other than standard PEBKAC?

On another probably unrelated note, (no pun intended), KDE is not playing system sounds through the default soundcard I have specified in modprobe.d/sound.conf. Are there KDE 4.4.3 config files, or something similar, that I can edit to get KDE to use the soundcard I want?

Any suggestions are appreciated,
regards, netcrawl

David the H. 05-16-2010 04:41 PM

Have you checked to see that all the audacious input plugins are still there? I have no idea about slack, but most distros bundle the less common codecs into separate packages (something like audacious-plugins-extra).

Alien Bob 05-17-2010 05:27 AM

The new audacious no longer has its own internal source copy of libfaad (like xine still does), but instead relies on an external faad2 library for AAC decoding. Since faad2 is not part of Slackware, AAC playback has effectively been removed in Slackware's audacious package.

You can install faad2 from here: http://slackware.com/~alien/slackbuilds/faad2/ and then recompile the audacious package. That will give you AAC playback functionality again.

Faad2 will not be added to Slackware.

Eric

netcrawl 05-17-2010 07:43 AM

Thanks for the heads up Eric. Although it may not be much of an issue to most people, I use Audacious for streaming AAC daily, so I missed that option rather immediately.

As far as directing system noises from KDE to the default sound card, (snd_ice1724), instead of the onboard sound, (snd_hda_intel), I was trying various settings in Kmix and after muting "Multi Track Rate Locking", system noises started coming from the default card. I'm not sure what happened, and I can't re-create the situation, but it works like normal again, so I guess it will do.

Regards, netcrawl


All times are GMT -5. The time now is 12:09 PM.