LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Audacious associating with Firefox . . . can't find workaround (http://www.linuxquestions.org/questions/slackware-14/audacious-associating-with-firefox-cant-find-workaround-4175481798/)

Kallaste 10-22-2013 09:38 PM

Audacious associating with Firefox . . . can't find workaround
 
I am trying to find out where Firefox stores its default stylesheet so that I can modify it to make it print a whole webpage I want to print, instead of just the first formatted page of it (this is a common Firefox bug that has been around since 2003). However, due to another bug where Audacious opens in response to attempting some Firefox action, I cannot find out where the stylesheet is.

Here is what I did:

1. Enter "about:support" in the Firefox address bar.
2. Click on the "Open Directory" button next to the "Profile Directory" label.
3. Watch Audacious attempt to do something meaningful.

I thought I had seen a workaround somewhere for this issue, but I cannot find it now, and I may be wrong. All my file associations are set properly in exo-preferred-applications. I'm using XFCE.

I'd welcome any input or clarity.

jprzybylski 10-22-2013 09:51 PM

I'm unsure how to change the default file manager for Firefox, but your profile directory is in $HOME/.mozilla/firefox.

STDOUBT 10-22-2013 09:56 PM

In response to your title question,
You don't mention if you have tried in Firefox:
Edit/Preferences/applications

I have all mine set (by default) to either "Always ask" or "Preview in Firefox"
If your goal is to have something other than Audacious open files through Firefox,
you can just change those settings.

Also, you said:
"Audacious opens in response to attempting some Firefox action"
What action?

TommyC7 10-22-2013 09:57 PM

Are you looking for (in Firefox):

Edit -> Preference -> Applications (tab)?

jprzybylski 10-22-2013 10:09 PM

Quote:

Originally Posted by STDOUBT (Post 5050672)
In response to your title question,
You don't mention if you have tried in Firefox:
Edit/Preferences/applications

I have all mine set (by default) to either "Always ask" or "Preview in Firefox"
If your goal is to have something other than Audacious open files through Firefox,
you can just change those settings.

Unfortunately, he is trying to open a folder, which is not shown in that list.

Looking at this, you may want to try something like opening the file $HOME/.local/share/applications/mimeapps.list and changing the line(s)

Code:

inode/directory=someprogram.desktop
x-directory/normal=someprogram.desktop

so that someprogram is exo-file-manager.

chess 10-22-2013 10:26 PM

Perhaps some of the similar issues discussed in this thread might help:

http://www.linuxquestions.org/questi...pp-4175465310/

01micko 10-22-2013 10:32 PM

In KDE the same button opens filelight at the correct location $HOME/.mozilla/firefox

I found this strange but if then I grepped for filelight in /use/share/applications/mimeinfo.cache and there lies the answer to why, and for you too with audacious. I also found that any "open in folder" button opened filelight.

Code:

bash-4.2$ grep filelight /usr/share/applications/mimeinfo.cache
inode/directory=kde4-filelight.desktop;kde4-gwenview.desktop;kde4-dolphin.desktop;kde4-kfmclient_dir.desktop;kde4-cervisia.desktop;Thunar-folder-handler.desktop;audacious.desktop;

I'm going to back mine up and edit it, then see later if it gets overwritten, however this is a reasonably fresh -current install and I've never opened audacious.

Later: I edited that line and left the dolphin and thunar entries and now works for me as expected. I had no filelight entry in ~/.local/share/applications/mimeinfo.cache or mimeapps.list re jprzybylski's post above.

Kallaste 10-22-2013 10:44 PM

Quote:

Originally Posted by STDOUBT (Post 5050672)
In response to your title question,
You don't mention if you have tried in Firefox:
Edit/Preferences/applications

I have all mine set (by default) to either "Always ask" or "Preview in Firefox"
If your goal is to have something other than Audacious open files through Firefox,
you can just change those settings.

Those settings do not apply to what I am trying to do (oops, sorry, looks like jprzybylski pointed that out already).

Quote:

Also, you said:
"Audacious opens in response to attempting some Firefox action"
What action?
I said what action in my case. This one:

Quote:

1. Enter "about:support" in the Firefox address bar.
2. Click on the "Open Directory" button next to the "Profile Directory" label.
3. Watch Audacious attempt to do something meaningful.
I said the bug in general was to have Audacious open in response to "some Firefox action" because it happens in other cases as well and I know people have seen it before in other circumstances.

Quote:

Originally Posted by jprzybylski (Post 5050678)
Looking at this, you may want to try something like opening the file $HOME/.local/share/applications/mimeapps.list and changing the line(s)

Code:

inode/directory=someprogram.desktop
x-directory/normal=someprogram.desktop

so that someprogram is exo-file-manager.

Hmm, unfortunately I do not seem to have either of those lines in that file. But thanks for finding that page--now that I see it, I remember having that same issue with the "open containing folder" in the downloads window, though I didn't recall before now.

Kallaste 10-22-2013 11:00 PM

Quote:

Originally Posted by 01micko (Post 5050681)
In KDE the same button opens filelight at the correct location $HOME/.mozilla/firefox

I found this strange but if then I grepped for filelight in /use/share/applications/mimeinfo.cache and there lies the answer to why, and for you too with audacious. I also found that any "open in folder" button opened filelight.

Code:

bash-4.2$ grep filelight /usr/share/applications/mimeinfo.cache
inode/directory=kde4-filelight.desktop;kde4-gwenview.desktop;kde4-dolphin.desktop;kde4-kfmclient_dir.desktop;kde4-cervisia.desktop;Thunar-folder-handler.desktop;audacious.desktop;

I'm going to back mine up and edit it, then see later if it gets overwritten, however this is a reasonably fresh -current install and I've never opened audacious.

Later: I edited that line and left the dolphin and thunar entries and now works for me as expected. I had no filelight entry in ~/.local/share/applications/mimeinfo.cache or mimeapps.list re jprzybylski's post above.

Ha! It worked. Thank you, and thanks to everyone else who responded as well. Now I have one less bug to bother me tonight. :)

jprzybylski 10-22-2013 11:05 PM

Quote:

Originally Posted by BloomingNutria (Post 5050685)
Ha! It worked. Thank you, and thanks to everyone else who responded as well. Now I have one less bug to bother me tonight. :)

Great! :)

After the fact, I found this. Apparently xdg has been changing where they place configuration. Also every major DE does this more or less differently. Down this road, madness lays.

01micko 10-22-2013 11:27 PM

Ok, it's not quite solved as when you install something with slackpkg or installpkg the /usr/share/applications/mimeinfo.cache will get over written. I just tested this after a reboot (survived the reboot but not installing a desktop package).

In all DOTdesktop files there is the MimeType= entry, filelight has just inode/directory; whereas audacious has several including inode/directory. (EDITED) This would be a call like update-desktop-database /usr/share/applications from a doinst.sh (ref) . I just put my custom line for inode/directory= into ~/.local/share/mimeinfo.cache and that seems to be ok. There were no entries at all in that file. Now it looks like this:

Code:

bash-4.2$ cat ~/.local/share/applications/mimeinfo.cache
[MIME Cache]
inode/directory=kde4-dolphin.desktop;kde4-kfmclient_dir.desktop;kde4-cervisia.desktop;Thunar-folder-handler.desktop

EDIT: In dolphin I can fix it with the properties of a file and it puts an entry in ~/.local/share/applications/mimeapps.list as mentioned by jprzybylski.

Cheers

Kallaste 10-24-2013 12:00 PM

Quote:

Originally Posted by jprzybylski (Post 5050687)
Great! :)

After the fact, I found this. Apparently xdg has been changing where they place configuration. Also every major DE does this more or less differently. Down this road, madness lays.

He he he. I've been going down that road a lot lately. :D

Quote:

Originally Posted by 01micko (Post 5050693)
Ok, it's not quite solved as when you install something with slackpkg or installpkg the /usr/share/applications/mimeinfo.cache will get over written. I just tested this after a reboot (survived the reboot but not installing a desktop package).

In all DOTdesktop files there is the MimeType= entry, filelight has just inode/directory; whereas audacious has several including inode/directory. (EDITED) This would be a call like update-desktop-database /usr/share/applications from a doinst.sh (ref) . I just put my custom line for inode/directory= into ~/.local/share/mimeinfo.cache and that seems to be ok. There were no entries at all in that file. Now it looks like this:

Code:

bash-4.2$ cat ~/.local/share/applications/mimeinfo.cache
[MIME Cache]
inode/directory=kde4-dolphin.desktop;kde4-kfmclient_dir.desktop;kde4-cervisia.desktop;Thunar-folder-handler.desktop

EDIT: In dolphin I can fix it with the properties of a file and it puts an entry in ~/.local/share/applications/mimeapps.list as mentioned by jprzybylski.

Cheers

I read your references and added the same line, and I hope that fixes it. At least now I can go back and read again if it turns out I need to understand this better.

I appreciate the help with this from both of you!


All times are GMT -5. The time now is 05:54 PM.