LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 10-24-2010, 01:29 PM   #1
Squall90
Member
 
Registered: Oct 2009
Distribution: Currently several distros :S
Posts: 148

Rep: Reputation: 29
Audacious 2.3 doesn't play AAC+-Stream


Hi there,

I was trying to hear a webradio that streams in AAC+ with Audacious. (see: http://hi1.streamingsoundtracks.com:8000) I didn't work.
So I searched the web and found this Thread: http://www.linuxquestions.org/questi...-4-3-a-808167/
I installed faad2 from SlackBuilds.org and rebuild Audacious from Slackware's ftp server -> ftp://ftp.slackware.com/pub/slackwar...xap/audacious/
But Audacious still doesn't play that stream. Here is the "tail" of the strace output:
Quote:
sched_get_priority_min(SCHED_OTHER) = 0
sched_get_priority_max(SCHED_OTHER) = 0
mmap2(NULL, 8388608, PROT_READ|PROT_WRITE|PROT_EXEC, MAP_PRIVATE|MAP_ANONYMOUS|MAP_STACK, -1, 0) = 0xb525d000
mprotect(0xb525d000, 4096, PROT_NONE) = 0
clone(child_stack=0xb5a5c444, flags=CLONE_VM|CLONE_FS|CLONE_FILES|CLONE_SIGHAND|CLONE_THREAD|CLONE_SYSVSEM|CLONE_SETTLS|CLONE_PARE NT_SETTID|CLONE_CHILD_CLEARTID, parent_tidptr=0xb5a5cbd8, {entry_number:6, base_addr:0xb5a5cb70, limit:1048575, seg_32bit:1, contents:0, read_exec_only:0, limit_in_pages:1, seg_not_present:0, useable:1}, child_tidptr=0xb5a5cbd8) = 2657
access("/home/christian/.config/audacious/playlist.xspf", F_OK) = 0
futex(0xb6282680, FUTEX_WAKE_PRIVATE, 2147483647) = 0
stat64("/home/christian/.config/audacious/playlist.xspf", {st_mode=S_IFREG|0644, st_size=314, ...}) = 0
stat64("/home/christian/.config/audacious/playlist.xspf", {st_mode=S_IFREG|0644, st_size=314, ...}) = 0
stat64("/home/christian/.config/audacious/playlist.xspf", {st_mode=S_IFREG|0644, st_size=314, ...}) = 0
open("/home/christian/.config/audacious/playlist.xspf", O_RDONLY|O_LARGEFILE) = 9
_llseek(9, 0, [0], SEEK_CUR) = 0
read(9, "<?xml version=\"1.0\" encoding=\"UTF"..., 8192) = 314
read(9, ""..., 7878) = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++
I have to delete /home/christian/.config/audacious/playlist.xspf first, to get audacious running again.

How to enable AAC+ in Audacious?

Thanks
 
Old 10-24-2010, 05:05 PM   #2
andrew.46
Member
 
Registered: Oct 2007
Distribution: Slackware
Posts: 639

Rep: Reputation: 90
Hi,

Did you recompile the audacious-plugins as well? You should see the following when recompiling this:

Code:
Input Plugins
  -------------
  MPEG 1/2/3 (madplug):                   yes
  MPEG 4 Audio (AAC):                     yes <------------
  FFaudio (ffaudio):                      yes
  Module decoder (modplug):               yes
  MIDI modular plugin (amidi-plug):       yes
    -> ALSA backend:                      yes
    -> FluidSynth backend:                no
  CD Digital Audio (cdaudio_ng):          yes
  sndfile extensions:                     no
  Tone Generator:                         yes
  Ogg Vorbis (vorbis):                    yes
  Free Lossless Audio Codec (flacng):     yes
  Commodore 64 audio (SID):               no 
    -> libSIDPlay1 support:               no
    -> libSIDPlay2 support:               no
    -> distortion patched libSIDPlay2:    
  Game music (spc, nsf & gbs):            yes
  PlayStation (psf/psf2) audio (psf):     yes
  Nintendo 64 audio (usf):                no
  Nintendo DS audio (xsf):                yes experimental
  AdLib synthesizer (adplug):             no
  Apple Lossless Audio Codec (alac):      yes
  WavPack 4.31+ (wavpack):                yes
  Metronom:                               yes
Your stream certainly worked with my copy of audacious, although MPlayer does a better job, but that is a personal prejudice .

Andrew
 
1 members found this post helpful.
Old 10-25-2010, 12:31 PM   #3
Squall90
Member
 
Registered: Oct 2009
Distribution: Currently several distros :S
Posts: 148

Original Poster
Rep: Reputation: 29
Oh, that solved my problem.^^ I didn't notice that there is an audacious-plugins package. :S

Thank you!
 
  


Reply

Tags
aac, audacious


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Audacious won't play AAC AAC+, & no system sounds KDE 4.4.3 netcrawl Slackware 3 05-17-2010 07:43 AM
[SOLVED] Audacious can't play apple lossless Daedra Slackware 1 04-03-2010 07:54 PM
How to play a music CD with Audacious rtmex Linux - Software 3 02-18-2009 08:13 PM
How Can I Play Aac Media? 420friendly Linux - Software 3 08-07-2008 10:05 PM
Cannot play AAC with mplayer aje Slackware 1 05-13-2005 07:39 AM


All times are GMT -5. The time now is 02:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration