LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-22-2009, 09:00 PM   #1
hairykoala
LQ Newbie
 
Registered: Feb 2009
Posts: 5

Rep: Reputation: 0
Attempting to boot Slackware from USB flash drive, getting kernel panic error


Hi all,

A brief intro.
I recently got an HP tablet (Pavilion tx2500z) that came pre-loaded with Vista Home Premium 32 bit. I don't really like using Vista so much, though, and I wanted to get used to Linux. I'm pretty much a n00b, my only experience with it having been a brief tryst with Ubuntu last summer. The thing is, I need Vista (at least for now) for classwork and the like (I'm in my first year of undergrad) until I'm good enough with Slackware and WINE that I can use them comfortably. So I got a 4GB USB flash drive and decided to install Slackware on it. I used the small Slackware packages listed here with some additions - some extra packages in AP, all of L, all of X, and most of XAP. I didn't pass any extra parameters to hugesmp.s.

The installation went off smoothly - it took me a few attempts to get the partitions right (about 1GB for /, about 1GB for /home, and about 2GB for /usr, filesystem ext2 on all of them), but it went pretty well. I toggled the bootable flag on / in fdisk and used the default simple install for Lilo. The USB drive was /dev/sdb, the partitions being /dev/sdb1-3 in the order listed above.

When I rebooted from the USB drive (I'd set it to boot from CD drive, then USB, then HDD), Lilo loaded up and I chose Linux. It started loading it up, and text started scrolling down. It stopped, saying that it could not boot from the root drive, and that I needed to pass the parameter "root=" properly. It listed as my options the drives from my HDD (/dev/sda1-2), but my flash drive was not listed at all. After that, it was written "kernel panic - unable to load root", or something along those lines. I remember the "kernel panic" part, but I can't recall the rest of the error message.

So my question - how do I get this working? Also, how do I get the flash drive to mount with the relatime option enabled? I recall reading that relatime was the best balance between atime and noatime as far as lifespan of the drive and speed of operations went. Any help would be much appreciated.
 
Old 02-22-2009, 10:32 PM   #2
mlangdn
Senior Member
 
Registered: Mar 2005
Location: Kentucky
Distribution: Slackware64-current
Posts: 1,373

Rep: Reputation: 164Reputation: 164
At the lilo screen, after selecting Linux, just type "root=/dev/sdb1" - without quotes.

Last edited by mlangdn; 02-22-2009 at 10:33 PM.
 
Old 02-23-2009, 03:02 AM   #3
hairykoala
LQ Newbie
 
Registered: Feb 2009
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks for the quick response, much appreciated. I tried that, but it didn't work, I got the same thing. Tried it with root=/sda1, and it seemed to get past that stage. Now it's asking me for init= parameters, and I'm not really sure what to do. Sorry to be such a pain, but once again, any help would be appreciated.
 
Old 02-23-2009, 03:51 AM   #4
Frullet
LQ Newbie
 
Registered: Feb 2009
Location: Sydney,Australia
Distribution: Slackware
Posts: 12

Rep: Reputation: 0
Quote:
Originally Posted by hairykoala View Post
Thanks for the quick response, much appreciated. I tried that, but it didn't work, I got the same thing. Tried it with root=/sda1, and it seemed to get past that stage. Now it's asking me for init= parameters, and I'm not really sure what to do. Sorry to be such a pain, but once again, any help would be appreciated.
The init parameters you are looking for are read-only mate.

init=ro
 
Old 02-24-2009, 01:45 AM   #5
hairykoala
LQ Newbie
 
Registered: Feb 2009
Posts: 5

Original Poster
Rep: Reputation: 0
I tried init=ro and rdinit=ro (dunno why, really, I saw it mentioned while booting from the install disk), but neither work. with init=ro, it says something like "unable to load ro, attempting defaults...". The next line says "kernel panic - unable to sync." Then it tells me to pass an init= option to the kernel...which I did. I don't know what I'm doing wrong here...
 
Old 02-24-2009, 06:13 AM   #6
XGizzmo
Member
 
Registered: Mar 2007
Distribution: Slackware
Posts: 264

Rep: Reputation: 68
I maybe mistaken here but I seem to recall that when booting off a USB device you needed to use the rootdelay kernel option.
Something like this at the lilo prompt: hugesmp.s root=/dev/sdb1 rootdelay=10
As far as how to enable relatime once you get your system booted edit /etc/fstab and add relatime to the mount points you want.
Example: /dev/sdb1 / ext3 defaults,relatime 1 1
Next time you boot it will boot with relatime.
 
Old 02-24-2009, 06:14 AM   #7
ChrisAbela
Member
 
Registered: Mar 2008
Location: Malta
Distribution: Slackware 14.1
Posts: 467

Rep: Reputation: 87
I am also trying to install Slack 12.2 on a USB and up to now I am getting kernel panic as well. I tried the huge kernel, generic + mkinitrd c/w USB modules, but no progress yet. I failed to find any helpfull documentation but the Alien Bob wiki seems to indicate that he had managed but then it seems to be a works in progress. My impression is that this is not a tivial task, yet there is an easy method to install SLAX on a FAT USB if that is good enough for you.

Chris
 
Old 02-24-2009, 08:24 AM   #8
uppman
Member
 
Registered: Jul 2008
Location: Stockholm, Sweden
Distribution: Slackware 13.1 32-bit
Posts: 145

Rep: Reputation: 24
Please, no more tears. Just follow the link below for some light reading..

http://linuxconfig.dyndns.org:1184/l...vable_USB_disk
 
Old 02-25-2009, 01:20 PM   #9
hairykoala
LQ Newbie
 
Registered: Feb 2009
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks very much, everyone! rootdelay=10 seems to have gotten it working. It boots now, so I'm happy.

Um, one last question - how do I enable gui? It boots into command line, but I've installed X and I'd like to enable xfce if I can. Sorry if this is off-topic, I was just wondering.

Thanks again
 
Old 02-25-2009, 02:43 PM   #10
mlangdn
Senior Member
 
Registered: Mar 2005
Location: Kentucky
Distribution: Slackware64-current
Posts: 1,373

Rep: Reputation: 164Reputation: 164
After login:

startxfce4
 
Old 02-25-2009, 06:58 PM   #11
XGizzmo
Member
 
Registered: Mar 2007
Distribution: Slackware
Posts: 264

Rep: Reputation: 68
Quote:
Originally Posted by hairykoala View Post
Um, one last question - how do I enable gui? It boots into command line, but I've installed X and I'd like to enable xfce if I can. Sorry if this is off-topic, I was just wondering.
If you want it to boot into a GUI login then edit /etc/inittab and change:

# Default runlevel. (Do not set to 0 or 6)
id:3:initdefault:

to:

# Default runlevel. (Do not set to 0 or 6)
id:4:initdefault:
 
Old 02-25-2009, 07:46 PM   #12
hairykoala
LQ Newbie
 
Registered: Feb 2009
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks again!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
fatal error attempting to install /var/log/mount/slackware/a/kernel-modules-smp-2.6.2 v@ny@ Slackware - Installation 10 05-19-2010 01:40 AM
Slackware 12 on USB hard drive Kernel Panic mpyusko Slackware - Installation 6 12-15-2007 11:40 AM
how to boot a custom kernel built from slackware on a USB drive? krmane Slackware 68 08-15-2006 10:52 PM
Slackware on USB flash drive adds2one Slackware 5 03-19-2006 06:20 AM


All times are GMT -5. The time now is 01:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration