LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   ATI Radeon 9000 Mobility and Slack 9.0 (http://www.linuxquestions.org/questions/slackware-14/ati-radeon-9000-mobility-and-slack-9-0-a-56787/)

zaubara 04-25-2003 04:49 PM

ATI Radeon 9000 Mobility and Slack 9.0
 
Hey there,

im trying to get OpenGL running, but it wont work ;(

Thats what glxinfo tells me:

bash-2.05b$ glxinfo
name of display: :0.0
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x21 24 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x22 24 dc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None

Running glxgears directly show me this:

bash-2.05b$ glxgears
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't get an RGB, Double-buffered visual


BTW, as far as i know, the Mobilitychip is exactly the same as the normal 9000er!
I also tried the one from linux-drm-4.3.0-kernelsource.tar.gz
- still no results, same error msg ;(

Pls help out a little noob ...

LoungeLizard 04-28-2003 09:47 AM

have you checked to see if you laptop manufacture has updated drivers for linux or drivers for linux at all for your mobility card?

zaubara 04-28-2003 10:41 AM

Check it out for yourself:

ftp://ftp.gericom.com/Notebook/linux/

Thats all i find for Linux. In my Notebook folder ( /Notebook/Radeon9000mobility ) there are two files:

k_deflt-2.4.18-58.i386.rpm
oss.tgz

I dont know what they are for or what they do :(

Thx for the answer btw, i already felt lost :D

LoungeLizard 04-28-2003 11:17 AM

Also what distro are you running?

zaubara 04-28-2003 01:08 PM

"ATI Radeon 9000 Mobility and Slack 9.0" :D
So, im running Slackware 9.0 :)

mindfrost82 11-24-2003 08:27 PM

I have a Dell Inspiron 8200 with an ATI Radeon Mobility 9000. It works fine in RedHat 9, with 3D support and everything right out of the box. I have tried to install Slackware 9 and 9.1, and in xf86config it doesn't list my video card. When I installed RedHat 9, it gave me ATI Radeon M9. I read somewhere that XFree86 v. 4.3.0 supports this card, but Slack 9.1 has that, and my card wasn't an option. Dell doesn't have any drivers for this card, and ATI says that you must get it from the manufacturer of the computer. I would love to make the change over to Slackware instead of RedHat because I have heard good things about it. If anyone has any luck with this, please let me know. Because the Vesa drivers are nothing like my 3D experience in RedHat!


All times are GMT -5. The time now is 07:40 PM.