LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 07-27-2007, 06:17 AM   #1
Sn!per[SWE]
LQ Newbie
 
Registered: Oct 2006
Posts: 9

Rep: Reputation: 0
Unhappy ATi drivers on Slackware 12.0


Hi everybody.

After a clean install of Slackware 12.0 X won't start and locks the whole computer.

When I change the Driver line from the default 'vesa' to 'radeon' in the xorg.conf file everything works fine.

When I then try to install the proprietary drivers from ATi the installation finishes without errors, but starting X still doesn't work and locks up the whole system. Again changing the Driver line from 'fglrx' to 'radeon' makes it work.

Any proposals?
 
Old 07-27-2007, 07:11 AM   #2
iiv
Member
 
Registered: Jun 2007
Location: Russia, Moscow Region
Distribution: Slackware
Posts: 167

Rep: Reputation: 30
The same, simply i use neither vesa, nor fglrx and feeling happy.
 
Old 07-27-2007, 07:16 AM   #3
Hyakutake
Member
 
Registered: Apr 2004
Location: Portugal
Distribution: Slackware
Posts: 153

Rep: Reputation: 16
Hey Sn!per[SWE].

I'm using ATI's proprietary drivers with no problems, but i had to recompile the kernel.
I usually recompile else ATI's driver won't work

This is my kernel options for ATI driver
Code:
* Loadable module support -> Enable loadable module support: ENABLED
* Loadable module support -> Module unloading: ENABLED
* Loadable module support -> Automatic kernel module loading: ENABLED
* File systems -> Pseudo filesystems -> Virtual memory file system support: ENABLED
* Processor type and features -> MTRR (Memory Type Range Register) support: ENABLED
* Device drivers -> Character Devices -> /dev/agpgart (AGP Support): MODULE
* Device drivers -> Character Devices -> (pick the correct AGP chipset option from the list, depending on your motherboard): MODULE
* Device drivers -> Character Devices -> Direct Rendering Manager (XFree86 4.1.0 and higher DRI support): DISABLED
As for the last option I have tried both options (ENABLE/DISABLE) with no changes at all. I guess it's irrelevant

Currently
Kernel 2.6.21
ATI 8.38.6

EDIT: I also needed to add this line to fstab
Code:
tmpfs            /dev/shm         tmpfs       defaults         0   0

Last edited by Hyakutake; 07-27-2007 at 07:18 AM.
 
Old 07-27-2007, 09:12 AM   #4
Sn!per[SWE]
LQ Newbie
 
Registered: Oct 2006
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by iiv
The same, simply i use neither vesa, nor fglrx and feeling happy.
Nice to hear, but I really want hardware accelerated 3D (You can't be creative all the time, sometimes you wanna shoot mosters ).

Quote:
Originally Posted by Hyakutake
I'm using ATI's proprietary drivers with no problems, but i had to recompile the kernel.
I usually recompile else ATI's driver won't work
Thanks for the tip, but I don't think that's the solution. You see I've been using ATi's proprietary drivers back since Slackware 10.1 without having to compile my own kernel to get it working.

Quote:
Originally Posted by Hyakutake
EDIT: I also needed to add this line to fstab
Yes, I have that line as well, and the DRI Mode 0666 secton in xorg.conf, but still no succes.


There must be log files that I can look into and find what has gone wrong, I'm no extremely familiar with xorg, where do I find these?
 
Old 07-27-2007, 09:15 AM   #5
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware 14.0
Posts: 1,874

Rep: Reputation: 49
/var/log/Xorg.0.log
 
Old 07-27-2007, 10:43 AM   #6
Sn!per[SWE]
LQ Newbie
 
Registered: Oct 2006
Posts: 9

Original Poster
Rep: Reputation: 0
OK, I found two files Xorg.0.log and Xorg.0.log.old.

I searched through both files for the phrase 'fglrx', 0 hits in both files.

I kind of get the feelings that these logs are from my earlier succesful attempts with 'radeon' as Driver.

Any ideas/thoughts?
 
Old 07-27-2007, 11:19 AM   #7
thegoofeedude
Member
 
Registered: Aug 2004
Distribution: Slackware 13.37, 14.1
Posts: 70

Rep: Reputation: 16
I installed the the new ATI drivers (8.39.4) last night on Slackware 12, and used the generic-smp 2.6.21 kernel which is shipped with Slackware (avoided a recompile, luckily :-). I used the installer to make the Slackware packages and then installed them, and it all appears to be working just fine (playing 3d games works, and glxgears(not a benchmark, I know :-) runs at about 3500+ fps.)

try grep 'EE' /var/log/Xorg.0.log
Also, make sure the fglrx module is loaded properly in the kernel (lsmod | grep 'fglrx')

All else failing, try the newest drivers, as they were released about 4 days ago (on July 23, 2007)

Good luck!
 
Old 07-27-2007, 11:20 AM   #8
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware 14.0
Posts: 1,874

Rep: Reputation: 49
Look for errors in the most recent log indicated by "EE" - the old one is just that.

Also look in dmesg or /var/log/messages. There might be some clues in there about what's sinking the ship.
 
Old 07-27-2007, 12:25 PM   #9
perry
Member
 
Registered: Sep 2003
Location: USA & Canada
Distribution: Slackware 12.0
Posts: 978

Rep: Reputation: 30
12.0 is different

Thanks for the tip, but I don't think that's the solution. You see I've been using ATi's proprietary drivers back since Slackware 10.1 without having to compile my own kernel to get it working.

Did you read the description for Slack 12:

Quote:
There are two kinds of kernels in Slackware -- the huge kernels, which
contain support for just about every driver in the Linux kernel. These are
primarily intended to be used for installation, but there's no real reason
that you couldn't continue to run them after you have installed. The
other type of kernel is the generic kernel, in which nearly every driver
is built as a module. To use a generic kernel you'll need to build an
initrd to load your filesystem module and possibly your drive controller
or other drivers needed at boot time, configure LILO to load the initrd at
boot, and reinstall LILO. See the docs in /boot after installing for more
information. Slackware's Linux kernels come in both SMP and non-SMP types
now. The SMP kernel supports multiple processors, multi-core CPUs,
HyperThreading, and about every other optimization available. In our own
testing this kernel has proven to be fast, stable, and reliable. We
recommend using the SMP kernel even on single processor machines if it
will run on them.
Ran into the same problem just doing the first boot up after install. Compiling the kernel is no big deal, just requires your attention and you need to know what type of processor and motherboard your using. Doesn't hurt to know the rest of your hardware either.

cd /usr/src/linux
make menuconfig

be sure to setup your test kernel under a separate line option in lilo.conf so that you have a fall back position

cheers

- perry
 
Old 07-28-2007, 04:51 AM   #10
Hyakutake
Member
 
Registered: Apr 2004
Location: Portugal
Distribution: Slackware
Posts: 153

Rep: Reputation: 16
I always had problems with my ATI and the only way to solve was to recompile the kernel so it could work with ATI's driver.

Just out of curiosity what model is you card?

I have Radeon 9600 Pro.

thanks

BTW: the only way I know to check out if ATI's driver is working is fglrxinfo
Code:
bash-3.1$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI RADEON 9600 Series
OpenGL version string: 2.0.6474 (8.38.6)

bash-3.1$ glxinfo |grep direct
direct rendering: Yes
 
Old 07-29-2007, 03:24 PM   #11
iiv
Member
 
Registered: Jun 2007
Location: Russia, Moscow Region
Distribution: Slackware
Posts: 167

Rep: Reputation: 30
I'm some kind of being afraid of n proprietary driver by ati. I do have ati radeon mobility 9600 and if this is possible i'll be glad to seen step-by-step description of setup of the proprietary driver.
 
Old 07-30-2007, 07:53 AM   #12
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,119

Rep: Reputation: 818Reputation: 818Reputation: 818Reputation: 818Reputation: 818Reputation: 818Reputation: 818
I've just upgraded to Slackware 12.0 and, after fooling around with the supplied ATI driver and the optional one (neither did the job), I installed the ATI proprietary drivers and all works as expected (that is, it works). My test is Google Earth; if that starts up and zooms smoothly, all is well with the world (so to speak).

I should note that I start with a generated xorg.conf file in place using xorgsetup to do so. That reads the graphics card and display and builds an xorg.conf file that, frankly, is just fine for most every purpose. In my case, xortsetup accurately determines the horizontal and vertical frequency ranges, size of the bulb and all that and creates a useful xorg.conf.

What I do is compile the kernel using the config file from the disk 1 kernel directory. I know there is an argument back and forth about whether to do so or not, but I have found that not doing so results in an error message trying to install other things (including ATI drivers), so, what the heck. I do make and make modules, doesn't hurt, seems to help.

I execute ati-driver-installer-8.39.4-x86.x86_64.run, choose the defaults (automatic installation), let it finish, execute aticonfig --initial (on a new installation; an upgrade doesn't need that), then reboot (per the ATI instructions). aticonfig modifies the xorg.conf file that was created with xorgsetup earlier.

Works fine.
 
Old 08-07-2007, 09:48 PM   #13
perry
Member
 
Registered: Sep 2003
Location: USA & Canada
Distribution: Slackware 12.0
Posts: 978

Rep: Reputation: 30
Kernel compilation horrors...

Things seem to work just fine if I just leave it alone...

That seems to be the case with the out-of-the-box generic kernel however I'd like a couple customizations like the processor family changed from 386 to K8. No dice, for some obscure reason any attempt to compile the kernel results in lots of trouble for me. Guess I'll just have to slow and find out just what the precise problem is.

Cheers

- perry
 
Old 08-08-2007, 07:53 AM   #14
Sn!per[SWE]
LQ Newbie
 
Registered: Oct 2006
Posts: 9

Original Poster
Rep: Reputation: 0
Hi again, I'm back from vacation and ready to start struggling with the ATi drivers again.

Thanks for all the tips.

I compiled my kernel with the settings that Hyakutake suggested, still no success, but I got some interesting error messages that we should be able to work something out with.

First from /var/log/messages:

Aug 8 13:26:14 testslack kernel: [fglrx] module loaded - fglrx 8.39.4 [Jul 20 2007] on minor 0
Aug 8 13:26:14 testslack kernel: [fglrx] module unloaded - fglrx 8.39.4 [Jul 20 2007] on minor 0


Loading, then directly unloading, :S.

Then from /var/log/Xorg.0.log:

drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (No such device or address)
drmOpenDevice: open result is -1, (No such device or address)
drmOpenDevice: Open failed
[drm] failed to load kernel module "radeon"
(EE) RADEON(0): [dri] RADEONDRIGetVersion failed to open the DRM
[dri] Disabling DRI.


Hmmm, whadday think?

Last edited by Sn!per[SWE]; 08-08-2007 at 01:11 PM.
 
Old 08-08-2007, 02:48 PM   #15
symatic
Member
 
Registered: May 2007
Distribution: Slackware
Posts: 242

Rep: Reputation: 32
The radeon driver has problems with the ati driver. This is what I hear all the time. post your xorg.conf. most likely you need to remove radeon from the xorg.conf and rmmod radeon(possibly blacklist it). I've never had this problem but it is what i hear often.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
new to slackware, help with ati drivers swooshonln Slackware 7 04-27-2006 12:27 PM
ATI drivers on Slackware c_olin3404 Linux - Software 17 05-23-2005 04:05 PM
How to install ATI drivers in Slackware 10.1 kizuna Slackware 4 03-25-2005 04:22 PM
ATi Radeon drivers in Slackware 10 Neorio Slackware 1 07-11-2004 11:15 AM


All times are GMT -5. The time now is 05:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration