LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-15-2006, 05:20 AM   #16
cathectic
Member
 
Registered: Sep 2004
Location: UK, Europe
Distribution: Slackware64
Posts: 761

Rep: Reputation: 34

Quote:
Originally Posted by nykey
With Nvidia I had to comment out DRI and remove it from Kernel support. Anyway, if you must, you must.....
For some unfathomable reason, nVidia decided to fly in the face of everyone else and *not* use DRI. So this is an nVidia "bug" if you will (all the open source drivers and ATI's fglrx stick to DRI).

Quote:
Originally Posted by deftones
I installed the ati drivers like the other guy said using the xorg package.
Did you actually try the 'radeon' driver that comes with X.org? It has better support for your card than the broken fglrx drivers - IIRC, you need to load the DRI module, and have a DRI section to enable other users to access the card. If you run xorgconf, then just add these extra bits, it should work (I use the free drivers for my Mobility X700, and I don't remember needing to do much else).

e.g.

Code:
Section "Module"
  Load "dri"
  <etc...>
EndSection

Section "DRI"
 Mode 0666
EndSection

Section "Device"
 Identifier  "Card0"
 Driver      "radeon"
 <etc...>
EndSection
 
Old 07-15-2006, 08:40 AM   #17
hexan
LQ Newbie
 
Registered: Jul 2006
Distribution: Slackware 12.0
Posts: 10

Rep: Reputation: 0
I have got Slackware 10.2 with the precompiled bareacpi kernel Version 2.4.31.
I followed Old_Fogies guide in how to get 3D Acceleration, but skipped the part where he compiled
a 2.6.10 kernel.


I mounted POSIX Shared Memory with adding this line into /etc/fstab

Code:
tmpfs     /dev/shm           tmpfs        defaults            0 0

and checked that it worked with this command

Code:
bash-3.00$ mount | grep shm     
tmpfs on /dev/shm type tmpfs (rw)
Then I downloaded the latest ati driver from ati and installed it. Then run the aticonfig.
Code:
bash-3.00$ aticonfig --initial --input=/etc/X11/xorg.conf
Next step was to add this line into /etc/X11/xorg.conf
Code:
Section "dri"
    Mode 0666
EndSection
and uncomment the line where it says: Load "dri"
so it loks like this:
Code:
     Load       "dri"
instead of this:
Code:
#    Load       "dri"
And here is the result:

Code:
bash-3.00$ glxinfo | grep render
direct rendering: Yes
    GLX_ATI_render_texture
OpenGL renderer string: RADEON 9800 Pro Generic
And to really test it i did a Hardorce 24h Burn in test with glxgears

Code:
bash-3.00$ glxgears
43223 frames in 5.0 seconds = 8644.600 FPS
42998 frames in 5.0 seconds = 8599.600 FPS
IT WORKS
finaly i can play quake2 in openGL mode instead of software :P

Thanks to Old_Fogie.
 
Old 07-15-2006, 10:28 AM   #18
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Rep: Reputation: 66
Yea. He's dove into the intricities of ATI with the tenacity of a pitbull. I don't have any ATI cards, so I can't do what he has.

Fogie, keep "...doing the voodoo that you do so well"
 
Old 07-16-2006, 11:54 PM   #19
deftones
Member
 
Registered: Sep 2004
Location: Georgia
Distribution: Slackware
Posts: 49

Original Poster
Rep: Reputation: 15
Ok for the time being I installed my old Geforce 2 MX. downloaded the drivers from the nvidia site, ran the installer outside X. It had to compile the kernel modules. At the end it said everything was successful. Started X, and now when I run glxinfo I get "XLIB: extension "GLX" missing on display ":0.0"


EDIT: Ok got it to work finally. Seems that in xorg.conf it still was using xorg's "nv" driver. Changed it to "nvidia" and I finally got the ever elusive "Direct Rendering:Yes". Thanks guys for all your help.

Last edited by deftones; 07-17-2006 at 12:07 AM.
 
Old 07-17-2006, 11:15 PM   #20
Legolas327
Member
 
Registered: Apr 2006
Location: Atlanta, GA
Distribution: Ubuntu 9.10
Posts: 69

Rep: Reputation: 15
Hello, Newbie here. I have the same problems with the ATI 9800 Pro. After fiddling, but mostly reading loads and loads I came to the conclusion that I would buy an NVidia card and save me even more endless hours of frustration. From what my research reflects and since I don't have PCI capable Mother Board I was thinking of Getting a Nvidia 6600GT AGP video card. Any reasons I shouldn't or should I get something better?

Desperately trying to get my WOW playing again after changing to Linux.
 
Old 07-18-2006, 01:35 AM   #21
shepper
Member
 
Registered: Mar 2003
Location: Dry, Dusty and Conservative
Distribution: OpenBSD, Debian Wheezy/Jessie
Posts: 449

Rep: Reputation: 33
To the original poster running Slackware current the latest changelog explains why your ati
card does not provide dri and how to fix it.
Quote:
The name of the big kernel with many built-in options has been changed from
test26.s to huge26.s to reflect that Slackware 11.0 will consider the
2.6.16.x kernel series to be a supported kernel series. However, I'm
probably going to leave the bare.i 2.4.32 kernel as the default kernel (or
perhaps sata.i?) as it has very good performance and probably better security
due to the simpler and longer-tested design. I might apply or at least make
available in the kernel-source package for 2.4.32 a patch to fix direct
rendering with 2.4.x kernels and X.Org 6.9.0 or newer. Since anyone using
Slackware for server use isn't likely to be loading the DRI modules, it's
untouched code on those machines and won't affect server stability (well,
depending on what, if anything, outside of the module is changed in the
kernel). It is probably a safe enough patch to apply. I'd rather ship 100%
vanilla kernels (and might, with the patch "on the side"), but DRI does not
work without the patch past X.Org 6.8.2. Is this enough text here?
Perhaps I should rename this my "ChangeBlog".
Depending on what your time is worth you can get 3d acceleration running by
1) Being patient and seeing what solution Pat provides
or
2) Compiling your own kernel
or
3) Going back to Slack 10.2/Xorg 6.8
or
4) Buying an Nvidia card
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI x86_64 proprietary drivers fail to start direct rendering svenwinkle Linux - Hardware 3 09-20-2005 02:15 PM
Ati Mobility x600 Direct rendering help jplev22 Linux - Hardware 4 09-15-2005 05:28 PM
Direct Rendering (ATI Radeon) xbuzz Linux - Newbie 8 06-03-2005 06:38 PM
How do i get direct rendering ATI 8500? glenn69 Linux - Newbie 0 10-07-2004 11:25 PM
ATI Radeon Direct Rendering chodviolin Linux - Hardware 0 03-27-2004 03:23 PM


All times are GMT -5. The time now is 10:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration