LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 10-03-2006, 05:29 PM   #1
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Rep: Reputation: 62
ATI Driver Slackware 11.0 - StartX yields Xorg Version mismatch


hi all,

well I got the 11.0 installed.

i went with huge26 as i know that on 10.2 that kernel worked for me and gave me good DRI.

that said I followed the same procedure that I did on 10.2; I get successful building of the modules, and the initial loading of the module. However, from init3 typing startx gives me:

xversion mismatch
detected x.org 7.0.0.0 required x.org.6.8.0.0
failed to load module
module requirement mismatch

now I'm using ati's fglrx_6_8_0-8.29.6-1.i386

i simply downloaded the rpm and used rpm2tgz

then installpkg
then cd /lib/modules/fglrx/buildmod
then sh ./make.sh
then went to /lib/modules/fglrx and ran sh ./make_install.sh

again the module builds and I get success.

i also created in my fstab:
tmpfs /dev/shm tmpfs defaults 0 0

it was mounted and verified with 'mount | grep "shm"' in console

i removed it all, threw in the x11 radeon patch and still no luck after going thru the install process.

i then removed all x11 stuff and the ati patch, reinstalled the stock xorg's rebooted again, tried the ati 32bit installer and got a failure with that too.

am I doing something wrong here?
 
Old 10-03-2006, 05:31 PM   #2
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Original Poster
Rep: Reputation: 62
also I noticed that there is no "Section dri" "mode 0666" in xorg file...do we still use that I put it in.

I do have "glx" and "dri" modules in my xorg.conf

I added the section dri there too. the glx and dri are un-commented.
 
Old 10-03-2006, 05:41 PM   #3
sfaz32
LQ Newbie
 
Registered: Sep 2005
Posts: 16

Rep: Reputation: 0
You need the driver module for xorg 6.9 and higher. Xorg 6.9 and higher must use the "run" package not the rpm. The rpm you downloaded is for xorg 6.8 only. Just download the 55mb ATI installer and run it with "sh".
 
Old 10-03-2006, 06:29 PM   #4
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Original Poster
Rep: Reputation: 62
I don't get it...I ran this b4 and it faile and now it works

Now I still have a problem tho

As root in KDE...(yea i know) in konsole..glxgears runs fine, no error's. GLXINFO reports DRI yes.

Now as normal user, fogie...glxinfo reports yes for dri, glxgears and fgl_glxgears -fbo
echo this over and over on the screen:
Quote:
FGLTexMgr: open of shared memory object failed (Permission denied)
__FGLTexMgrCreateObject: __FGLTexMgrSHMmalloc failed!!!
This is at the bottom of my xorg:
Section "DRI"
Mode 0666
EndSection

Any idea why I get dri as a user...but permission errors when actually using the dri? is that what this patch that Pat issued is for?
 
Old 10-03-2006, 06:46 PM   #5
sfaz32
LQ Newbie
 
Registered: Sep 2005
Posts: 16

Rep: Reputation: 0
Check to make sure if you have /dev/shm mounted with the correct permission to read and write to it. As root, issue a "chmod 777 /dev/shm" to get the correct permission.
 
Old 10-03-2006, 06:52 PM   #6
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Original Poster
Rep: Reputation: 62
omg..........

I think?? but not sure, I did not enter a "carriage return" or hit enter for you younger folks after my /dev/shm line in my fstab.

interestingly enuff, I did not get the "no final newline error" in my boot process.

but I made that changed rebooted, and now all is well.

but I think the chmod 777 may be useful, i see many threads with this error of shared memory. i'll make a note of it in case i get the errors again.

Now off to figure out why my fstab is giving me errors for the fat32 partition I have, wierd
 
Old 10-03-2006, 11:10 PM   #7
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Original Poster
Rep: Reputation: 62
btw stafz32 I forgot to say thank you
 
Old 10-15-2006, 08:23 PM   #8
resaguk
Member
 
Registered: Aug 2004
Location: Leamington Spa, UK
Distribution: Slackware
Posts: 66

Rep: Reputation: 15
Angry

Quote:
Originally Posted by Old_Fogie
I think?? but not sure, I did not enter a "carriage return" or hit enter for you younger folks after my /dev/shm line in my fstab.
I try to keep two blank lines at the bottom of my /etc/fstab just to be sure that if I add a line in a rush it will always work!

Currently waiting for newer drivers to download, upgraded to Slack11 this weekend after a repartition and suddenly found that my ATI drivers don't like Xorg6.8!
 
Old 10-15-2006, 09:28 PM   #9
resaguk
Member
 
Registered: Aug 2004
Location: Leamington Spa, UK
Distribution: Slackware
Posts: 66

Rep: Reputation: 15
Quote:
Originally Posted by resaguk
Currently waiting for newer drivers to download, upgraded to Slack11 this weekend after a repartition and suddenly found that my ATI drivers don't like Xorg6.8!

Ah... now downloaded, but, at 1280x1024 I get:

Code:
iain@iain:~$ glxgears
625 frames in 5.0 seconds = 124.988 FPS
625 frames in 5.0 seconds = 124.995 FPS
625 frames in 5.0 seconds = 124.993 FPS
625 frames in 5.0 seconds = 124.992 FPS
Which is hardly earth shattering, especially for a P4 3.0GHz (although there is no increase in CPU load while running glxgears, so at least that's right)!

I have DRI enabled though:

Code:
iain@iain:~$ glxinfo | grep direct
direct rendering: Yes
And in /etc/fstab:

Code:
iain@iain:~$ cat /etc/fstab | grep shm
tmpfs            /dev/shm         tmpfs       defaults         0   0
In xorg.conf

Code:
Section "Module"
# This loads the GLX module
        Load  "dbe"     # Double buffer extension
        SubSection "extmod"
        Option      "omit xfree86-dga"   # don't initialise the DGA extension
        EndSubSection
        Load  "type1"
        Load  "freetype"
        Load  "glx"
        Load  "dri"
EndSection

...

Section "Device"
        Identifier  "X300SE"
        Driver      "fglrx"
EndSection

...

Section "DRI"
        Mode         0666
EndSection
So everything looks right...

System info:

Code:
iain@iain:~$ uname -r
2.6.17.13
And the card is a Radeon X300SE

If anyone can give me some ideas for how to up the performance they'd be most welcome!

Last edited by resaguk; 10-15-2006 at 09:30 PM.
 
Old 10-16-2006, 08:01 AM   #10
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,122

Rep: Reputation: 819Reputation: 819Reputation: 819Reputation: 819Reputation: 819Reputation: 819Reputation: 819
For what it's worth...

I have installed the ATI drivers (Slackware 11.0, kernel 2.6.18, Pentium 4 @ 3GHz, 1G RAM). Before installing the ATI drivers, I built xorg.conf with xorgconfig (so that's what was in /etc/X11), then rebuilt it with aticonfig (which merges with the existing xorg.conf and adds ATI-specific variables). Things that appear to matter at the manufacturer and model name of the display and the horizontal and vertical sync ranges. The graphic card is an ATI X300 series (don't know if there is some letter appended to the end of that, but I don't think it really matters).

Hope this helps some.

Running glxgears with the settings below yields:
glxgears
1310 frames in 5.0 seconds = 261.933 FPS
1334 frames in 5.0 seconds = 266.636 FPS
982 frames in 5.0 seconds = 196.248 FPS
1173 frames in 5.0 seconds = 234.414 FPS
1240 frames in 5.0 seconds = 247.812 FPS
Running fgl_glxgears yields:
fgl_glxgears
Using GLX_SGIX_pbuffer
882 frames in 5.0 seconds = 176.400 FPS
1098 frames in 5.0 seconds = 219.600 FPS
1090 frames in 5.0 seconds = 218.000 FPS
1114 frames in 5.0 seconds = 222.800 FPS
1090 frames in 5.0 seconds = 218.000 FPS
These are the relevant settings in xorg.conf; the Module section:
Section "Module"
Load "glx"
Load "extmod"
Load "xtrap"
Load "record"
Load "dbe"
Load "dri"
Load "freetype"
Load "type1"
EndSection
The Monitor section:
Section "Monitor"
Identifier "aticonfig-Monitor[0]"
Option "VendorName" "ATI Proprietary Driver"
#Option "ModelName" "Generic Autodetecting Monitor"
Option "ModelName" "SyncMaster"
HorizSync 30.0 - 85.0
VertRefresh 50.0 - 160.0
Option "DPMS" "true"
EndSection
The Device section:
Section "Device"
Identifier "Card0"
Driver "ati"
VendorName "ATI Technologies Inc"
BoardName "RV370 5B60 [Radeon X300 (PCIE)]"
BusID "PCI:1:0:0"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]"
Driver "fglrx"
EndSection
And the Screen section:
Section "Screen"
Identifier "aticonfig-Screen[0]"
Device "aticonfig-Device[0]"
Monitor "aticonfig-Monitor[0]"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1600x1200" "1280x1024"
EndSubSection
EndSection
The DRI section:
Section "DRI"
Mode 0666
EndSection
 
Old 10-16-2006, 01:12 PM   #11
resaguk
Member
 
Registered: Aug 2004
Location: Leamington Spa, UK
Distribution: Slackware
Posts: 66

Rep: Reputation: 15
Quote:
Originally Posted by tronayne
Before installing the ATI drivers, I built xorg.conf with xorgconfig (so that's what was in /etc/X11), then rebuilt it with aticonfig (which merges with the existing xorg.conf and adds ATI-specific variables).
Yes, conveniently aticonfig left my xorg.conf corrupt by putting random "0"s in the file, the only things that it seemed to do was rename my screen, monitor and device sections (while ignoring all the settings that I needed, such as resolutions, Hsync, Vsync and bit-depth) plus it stuck in the device line for:

Code:
Driver      "fglrx"
Starting X then failed due to (from memory):

Code:
(EE) Failed to launch "fglrx"
(EE) No screen found
So I copied the device line into a known good xorg.conf (generated by "xorgconfig" and tried that instead. Commenting out Section "DRI" leaves me with a whopping 11FPS at full screen, so it's doing something!

(I'll run aticonfig and then start X when I get home and post in the actual errors since this may help someone else...)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg update and ATI driver altella Mandriva 1 02-05-2006 03:53 PM
request for old ATI propietary driver for xorg 6.8 (8.12.10) bobbens Linux - Hardware 1 09-04-2005 05:46 AM
Xorg ATI Driver (working, but not fully) chup Linux - General 1 03-20-2005 05:41 PM
slackware startx starts the wrong version, i didn't even know i had another version edman007 Linux - Software 3 05-16-2004 08:38 PM
Error "Kernel version mismatch" when nic driver will be loaded grubjo Linux - Networking 1 10-03-2003 05:12 AM


All times are GMT -5. The time now is 02:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration