LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 10-28-2006, 10:18 PM   #1
darkarcon2015
Member
 
Registered: Jun 2004
Location: Potsdam, NY
Distribution: Fedora Core 6
Posts: 201

Rep: Reputation: 30
ATI Driver Issue (DRI Problem)


In my Xorg.log.0, I see the following:
Code:
(II) fglrx(0): DRI initialization successfull!
...
(II) fglrx(0): [DRI] installation complete
(II) fglrx(0): Direct rendering enabled
But when I run `glxinfo`, at the top it says:
Code:
direct rendering: No
...
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.4.1)
I'm not sure what I need to do to fix this, but this is, I'm pretty sure, what is preventing hardware acceleration to work on my box. Any help?

Note: I have a Mobility 9600, Slackware 11.0 RC2, kernel 2.6.16.27, and there are no errors in the Xorg log.
 
Old 10-28-2006, 11:19 PM   #2
masonm
Senior Member
 
Registered: Mar 2003
Location: Following the white rabbit
Distribution: Slackware64 13.37 Android 4.0
Posts: 2,244

Rep: Reputation: 45
xorg.conf?
 
Old 10-30-2006, 11:46 AM   #3
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Rep: Reputation: 65
Plus, ATI doesn't use glxinfo, it has it's own little bit of code.

A clue may be found in my post about DRI (Link in my sig)
 
  


Reply

Tags
ati, dri, fglrx


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't get DRI working with ati driver on slack 11 Crushing Belial Slackware 7 10-27-2006 04:03 AM
ATI Rage Mobility (Mach64) DRI Issue - Missing polygons? finite Linux - Hardware 1 08-06-2006 02:09 PM
oh no not another ati/dri problem...and this ones long blitzX Linux - Laptop and Netbook 6 06-03-2006 09:38 PM
ATI fglrx driver - can't get dri working SpruceMoose Linux - Hardware 1 06-20-2005 11:22 PM
ati problem..(DRI + tv out mix) NoirX252 Linux - Software 1 05-09-2004 01:04 PM


All times are GMT -5. The time now is 01:06 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration