LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   ATi Driver 9.x Series on Slackware ATi Radeon HD4850 (http://www.linuxquestions.org/questions/slackware-14/ati-driver-9-x-series-on-slackware-ati-radeon-hd4850-723383/)

vince4amy 05-03-2009 03:25 PM

ATi Driver 9.x Series on Slackware ATi Radeon HD4850
 
Has anyone got any drivers newer than 8.12 to work on Slackware 12.2 because it seems to me that there is a missing dependency with newer versions of the driver which isn't in Slackware since all driver versions after 8.12 haven't worked for me all I get is a white screen.

I have tried installing both with the --buildpkg Slackware/All and just following through the automatic steps as I do with other distros.

I've noticed this problem on Debian too with any drivers later than 8.12 so I'm sure that the system is missing something but I just can't figure out what it might be.

Hangdog42 05-04-2009 11:43 AM

I had the newest ATI running on Slackware current using that exact card, although it took a patch to get it running on a 2.6.29 kernel. If it runs on current, I would suspect it would run on 12.2. However, I just use the ATI installer, I don't try to make a package out of it. You might have a look in the ATI install logs and see if anything specific is cropping up.

amiga32 05-05-2009 07:00 AM

I think with the 9.x series you need to rebuild MSI support under bus options into the kernel for them to work. IF you have a PCIe video card, its not a bad idea to do this anyway.

vince4amy 05-05-2009 04:25 PM

Okay, I'll do that since I always recompile the kernel with PAE anyway.


All times are GMT -5. The time now is 12:22 AM.