LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   ATI 9200 SE screen flicker in screen saver (http://www.linuxquestions.org/questions/slackware-14/ati-9200-se-screen-flicker-in-screen-saver-334691/)

gargamel 06-17-2005 04:18 PM

ATI 9200 SE screen flicker in screen saver
 
Hi there,

I have a little cosmetic problem.

Normally my ATI 9200 SE based graphics card (from HIS) works fast and reliable. 2D is always excellent, and 3D works usually fine, too. Only with some 3D KDE screen savers the screen flickers. It reminds me of my Amiga times, when the effect was known as "Interlace".

Searching LQ and the web I found a hint that it might be helpful to add a line with the "ChipID", but in another post someone else said that this was only useful on older XFree86 versions.

Is this correct? Do you have other ideas?


Thanks!

gargamel

leadazide 06-17-2005 04:22 PM

Do you use DRI or fglrx drivers?
Maybe changing monitor refresh rate would help.
Maybe it's screen saver's fault.

egag 06-17-2005 04:28 PM

in this thread i posted my device section in the xorg.conf file.
i have a 9200se and i still need the chipid option.
( but if you need it , 3d acceleration won't work without it )

http://www.linuxquestions.org/questi...hreadid=334544

just take a look and compare it to what you have...

egag

gargamel 07-07-2005 11:09 AM

Ok, thanks for your hints, but unfortunately the problem is not yet solved, completely (though I have the impression, yet not evidence, that it got better).

I have
- kernel 2.6.11.9
- Xorg 6.8.2

and I get
Code:

$ glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: Mesa DRI R200 20040929 AGP 1x x86/MMX+/3DNow!+/SSE TCL

and
Code:

$ glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: Mesa DRI R200 20040929 AGP 1x x86/MMX+/3DNow!+/SSE TCL

I am not sure: One of the lines above seems to tell me that I have hardware support for 3D, the other one suggests that I don't.


In my xorg.conf I find this:
Code:


      Identifier  "Card0"
        Driver      "radeon"
        ChipId 0x5964
        VendorName  "ATI Technologies Inc"
        BoardName  "Radeon RV280 [Radeon 9200]"
        BusID      "PCI:1:0:0"
        Option "Overlay"
        Option "EnablePageFlip" "on"

in the Device section.

Any ideas? Thanks in advance!

gargamel

leadazide 07-07-2005 11:29 AM

You do have opengl acceleration, however you use XOrg DRI drivers. You may try official ATI Proprietary drivers.

gargamel 07-07-2005 01:52 PM

Thanks, I once tried ATI's proprietary "solution", and in fact the 3D support was great, but
- only at resolution up to 1024x768, while I use 1280x1024 as standard
- at the price of major stability problems
- and finally, I thought that Xorg has inbuilt "native" support for the chipset of my graphics card (not for newer models, but 9200 and 9200SE, which is what I have).

Maybe I'll give ATI a second chance, but I am sceptic.
- I prefer open source.
- I prefer to install "official" Slackware packages, because I can maintain them so comfortably with slackpkg --- I don't have to watch each site from which I install a package individually, as Pat V. does a very good job here for me (and you and all other Slackers)
- I don't want to put my system on a risc (especially after the bad experience I had with the first time I tried ATI's drivers)

So my question is:

Can you really *recommend* ATI's current drivers? Are they reliable?

Thanks in advance.

gargamel

egag 07-07-2005 01:59 PM

hi there,

i've also an ati9200se and the fglrx drivers never were stable here.
( 5 min.'s is the record )
i doubt it if the latest drivers are any better.

also when it worked, it gave no higher performance than the dri/radeon driver.
( about 750 fps with glxgears in a standard window )

egag

gargamel 07-07-2005 02:07 PM

Quote:

Originally posted by egag
hi there,

i've also an ati9200se and the fglrx drivers never were stable here.
( 5 min.'s is the record )
i doubt it if the latest drivers are any better.

also when it worked, it gave no higher performance than the dri/radeon driver.
( about 750 fps with glxgears in a standard window )

egag

But you didn't try the latest, did you?

Performance: Yes, that's what I observed, too, with a former version of fglrx. And performance overall is *not* my problem. 2D is great, and even some 3D animation run really smooth. Frames per second: 2177. Which is ok. Well, the icons Konqueror's file manager view flicker, while glxgears is running and the window is not covered.

Has anyone tried ATI's latest drivers with good success? Are they stable?
Or is there a configuration option for Xorg that I might try in addition to what I have?

Thanks!

gargamel

egag 07-07-2005 02:26 PM

i didn't try the latest.
but i'm happy as it is now.

i looked at the icons in konquerer while glxgears was running,
and there was no flickering here.
it might be related to your original prob.

egag

gargamel 07-07-2005 03:42 PM

Quote:

Originally posted by egag
i didn't try the latest.
but i'm happy as it is now.

i looked at the icons in konquerer while glxgears was running,
and there was no flickering here.
it might be related to your original prob.

egag


Ok, what's your resolution? I have 1280x1024.

Regarding flickering in Konqueror:
- it happens with views that contain many icons, not with ones with only one or two or so.
- when I move the Konqueror window and place it next to the glxgears window there's no flicker.
- once I move the glxgears window over the Konqueror window and drop it, the flickering starts.

I also notice flickering in the workspace icons on the task bar (panel or whatever the 'official' KDE name is...).

gargamel

egag 07-07-2005 04:19 PM

i use 1024x768@85.
1280x1024 works only at 60 Hz. and that hurts my eyes.

i also tried glxgears-on-konquerer and i see no flickering anywhere.
but i had the nasty fglrx-experience : it hang.
i never had that with standard drivers i use.
( must not happen to often... )

anyway, could your prob be related with the monitor ?
( i don't know )
i use a compaq 710.

egag

gargamel 07-07-2005 04:32 PM

Thanks, egag, again.

I have 1280x1024 at 85Hz. No flicker or interlace with 2D (I need 3D only occasionally, so all of this is more a cosmetic problem, as I said in my initial post; just something that prevents me from calling my beloved Slackware 'perfect'). ;-)

So I doubt, that it is monitor related. It's a Peacock Ergovision 19, probably totally unknown in your country. ;-)

When I have time, I'll try 1024x768. However, the specs of my graphics card claim that it is possible to get 1280x1024 at 85Hz with 3D. And for some 3D animations this seems to be true, but it may be that these are just pre-rendered films, as opposed to real-time animations.

gargamel

gargamel 07-09-2005 04:10 PM

Just would like to note that it is *definately* not a monitor problem. On my second system, SuSE 9.3 I have no such effects with quite the same KDE screen saver.

gargamel


All times are GMT -5. The time now is 04:09 AM.