LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-28-2009, 04:04 PM   #1
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,033

Rep: Reputation: 754Reputation: 754Reputation: 754Reputation: 754Reputation: 754Reputation: 754Reputation: 754
Atheros Wireless Network Adapter -- Problem with madwifi


lspci tells me I have a Network controller: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) (rev 01) and iwconfig tells me
Code:
lo        no wireless extensions.

eth0      no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11abgn  ESSID:""
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated
          Tx-Power=17 dBm
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

vboxnet0  no wireless extensions.

ppp0      no wireless extensions.
after getting madwifi-driver and madwifi-tools from SlackBuilds.org, building both with the provided dot-Slackbuild and it sure looks like the packages are installed;
Code:
/var/log/packages/madwifi-driver-0.9.4_2.6.29.6_smp-i486-2_SBo
/var/log/packages/madwifi-tools-0.9.4-i486-1_SBo
I probably missed something somewhere along the line and am wondering if I have to rebuild the kernel or something to get stuff to get going?
 
Old 10-28-2009, 04:23 PM   #2
jonpettimore
LQ Newbie
 
Registered: Jan 2009
Distribution: Slackware, Arch
Posts: 9

Rep: Reputation: 0
[/code]
I probably missed something somewhere along the line and am wondering if I have to rebuild the kernel or something to get stuff to get going?[/QUOTE]

Please note that I have mostly setup broadcom cards (and still consider myself new to linux overall) so take all of this with a grain of salt, and I'll try not to reveal too much of my ignorance.

do you have the proper madwifi module loaded? ("modprobe ath_pci" I believe is the most common)

What is set as the driver in /etc/rc.d/rc.inet1.conf ?

Also of interest may be the setup of /etc/rc.d/rc.wireless.conf

Hopefully with some more information this can be sussed out.
 
Old 10-28-2009, 06:59 PM   #3
plasmonics
Member
 
Registered: Jan 2009
Posts: 37

Rep: Reputation: 18
I am surprised that the Atheros does not work out of the box without the need for madwifi. That particular card uses the ath9k module. madwifi was necessary when there were still bugs in the kernel with respect to Atheros cards. As of kernel >= 2.6.27, those bugs should be gone.

I have a Atheros 242x card that uses ath5k. You don't have to modprobe anything. The wireless startup scripts take care of that.

Usually, all you have to do is bind wlan0 to the wireless access point. I used Alienbob's wireless page to connect mine via wpa2. You can also use wicd, but I never tried it.
 
Old 10-28-2009, 07:08 PM   #4
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,223

Rep: Reputation: Disabled
Quote:
Originally Posted by tronayne View Post
lspci tells me I have a Network controller: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) (rev 01) and iwconfig tells me
Code:
wlan0     IEEE 802.11abgn  ESSID:""
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated
          Tx-Power=17 dBm
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
What do you think your problem is? I see a wlan0 wireless interface, which by the way means, the kernel probably uses it's own atk5k driver instead of your madwifi driver (loading the madwifi driver results in a wireless interface named "ath0" usually).

You just need to configure the interface. Read "man rc.inet1.conf" and/or check out the information contained in http://alien.slackbook.org/dokuwiki/...eless_networks

If this is a laptop, it could be useful to install the wicd package from the /extra directory on your Slackware DVD. It simplifies the network configuration by providing a GUI.

Eric
 
Old 10-29-2009, 01:59 AM   #5
rkrishna
Member
 
Registered: Mar 2005
Location: chennai(madras), India
Distribution: slackware ofcourse
Posts: 654

Rep: Reputation: 32
most probably you have to unload the default kernel driver for your wireless card. and check your madwifi driver is loaded. if not, modprobe it.
for my wireless to work, i installed ndiswrapper.
and blacklisted the default kernel module, ath5k. for that put "blacklist ath5k" in the /etc/modprobe.d/blacklist.conf and reboot the machine.

as alien suggested, for a better management of the network, i suggest wicd package from the /extra of install cd.
 
Old 10-29-2009, 02:09 AM   #6
rkrishna
Member
 
Registered: Mar 2005
Location: chennai(madras), India
Distribution: slackware ofcourse
Posts: 654

Rep: Reputation: 32
Alien specific Question

dear alien, i was about to start a thread, this is regarding wicd.

i am running wicd and is working for me. i have a simple doubt.
1. since wicd demon is working do i need my rc.inet1 to be executable??
2. what about rc.wireless, do i need to enable all these three simultaneously.

anyway my network job is controlled by wicd-client, so is rc.inet1 needed anymore. shall i make it non executable ?

regards rkrishna
 
Old 10-29-2009, 01:01 PM   #7
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,033

Original Poster
Rep: Reputation: 754Reputation: 754Reputation: 754Reputation: 754Reputation: 754Reputation: 754Reputation: 754
Quote:
Originally Posted by Alien Bob View Post
What do you think your problem is? I see a wlan0 wireless interface, which by the way means, the kernel probably uses it's own atk5k driver instead of your madwifi driver (loading the madwifi driver results in a wireless interface named "ath0" usually).

You just need to configure the interface. Read "man rc.inet1.conf" and/or check out the information contained in http://alien.slackbook.org/dokuwiki/...eless_networks

If this is a laptop, it could be useful to install the wicd package from the /extra directory on your Slackware DVD. It simplifies the network configuration by providing a GUI.

Eric
Eric,

Thanks for the response and I'm sorry that I'm being dense...

I've uninstalled madwifi, rebooted, and iwconfig show me
Code:
wlan0     IEEE 802.11abgn  ESSID:""
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated
          Tx-Power=17 dBm
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
As you mentioned, no, I didn't configure rc.inet1.conf; I did read the information on your site and, again, I'm sorry for being dense, I think all I really need to do is these changes to only use the wireless on open points (like the local -- 20 miles away -- library)
Code:
## Example config information for wlan0.  Uncomment the lines you need and fill
## in your info.  (You may not need all of these for your wireless network)
IFNAME[4]="wlan0"
#IPADDR[4]=""
#NETMASK[4]=""
USE_DHCP[4]="yes"
#DHCP_HOSTNAME[4]="icculus-wireless"
DHCP_KEEPRESOLV[4]="yes"
DHCP_KEEPNTP[4]="yes"
#DHCP_KEEPGW[4]="yes"
#DHCP_IPADDR[4]=""
#WLAN_ESSID[4]=BARRIER05
#WLAN_MODE[4]=Managed
##WLAN_RATE[4]="54M auto"
##WLAN_CHANNEL[4]="auto"
##WLAN_KEY[4]="D5AD1F04ACF048EC2D0B1C80C7"
##WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=96389dc66eaf7e6efd5b5523ae43
c7925ff4df2f8b7099495192d44a774fda16"
#WLAN_WPA[4]="wpa_supplicant"
#WLAN_WPADRIVER[4]="ndiswrapper"
I do not want /etc/resolv.conf or /etc/ntp.conf overwritten (because this laptop is 99% on a hardwired network and I prefer fixed IP for my intranet). I do know that the library wants DHCOP for their wireless access and I'm not too sure about setting the address and netmask values (dense, dense, dense).

Is there anything else I need to uncomment?

Thanks for you help.

[EDIT] Forgot to mention that WICD was installed from the extras directory.

Last edited by tronayne; 10-29-2009 at 01:03 PM.
 
Old 10-30-2009, 12:12 AM   #8
rkrishna
Member
 
Registered: Mar 2005
Location: chennai(madras), India
Distribution: slackware ofcourse
Posts: 654

Rep: Reputation: 32
Quote:
Forgot to mention that WICD was installed from the extras directory.
dont edit rc.inet1.conf. instead run wicd-client (to run as user, user has to be in netdev group)
 
Old 10-31-2009, 01:21 PM   #9
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,033

Original Poster
Rep: Reputation: 754Reputation: 754Reputation: 754Reputation: 754Reputation: 754Reputation: 754Reputation: 754
What is the purpose of running wicd-client? Isn't that run by WICD when it starts?

I've been though every reference I can find (including AlienBob's), edited (and unedited) /etc/rc.d/rc.inet1.conf, /etc/rc.d/rc.wireless.conf, running wicd-client (with and without WICD installed) and no matter what, I cannot see any wireless networks -- at the library there are anywhere from 5 to 12 wireless networks that used to show up (on a different laptop and with previous Slackware releases) without ever having to fiddle with anything whatsoever. This is a new Dell Inspiron 17 that, before I wiped out Vista and did a clean install of Slackware 13 as the only OS on it, did access the wireless network in Vista (so I kinda figure that the transceiver actually does work). Lots of cussing and swearing involved along with wondering if I've bought a pig in a poke.

Sigh.

Anyway, looking at rc.wireless.conf section for Atheros base cards,
Code:
# Multiband Atheros based 802.11a/b/g universal NIC cards
00:05:4E:*)
    INFO="Multiband Atheros based 802.11a/b/g universal NIC"
    # ESSID (extended network name) : My Network, any
    ESSID=""
    # Operation mode : Ad-Hoc, Managed, Master, Repeater, Secondary, auto
    MODE="Managed"
    # Frequency or channel : 1, 2, 3 (channel) ; 2.422G, 2.46G (frequency)
    FREQ=""
    CHANNEL="7"
    # Bit rate : auto, 1M, 11M,54M
    RATE="auto"
    # Encryption key : 4567-89AB-CD, s:password
    # Example for 40-bit encryption:
    #KEY="883e-aa67-21 [1] key 5501-d0da-87 [2] key 91f5-3368-6b [3] key 2d73-31b7-96 [4]"
    # Example for 104-bit encryption (aka 128-bit WEP):
    #KEY="d5ad2f05abd048ecf10b1c80c7"
    KEY=""
    # Other iwconfig parameters : power off, ap 01:23:45:67:89:AB
    IWCONFIG=""
    # iwspy parameters : + 01:23:45:67:89:AB
    IWSPY=""
    # iwpriv parameters : set_port 2, set_histo 50 60
    IWPRIV=""
    ;;
And the output of iwconfig,
Code:
wlan0     IEEE 802.11abgn  ESSID:""
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated
          Tx-Power=17 dBm
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
It looks to me like the thing ought to just function if I uncomment the five lines in rc.wireless.conf but there is no joy there, commented or not. It also looks like if I uncomment lines in rc.inet1.conf that it ought to work, too. And, no joy there either.

I'm at loss, have no clue where or what to read to get this thing going and would appreciate a pointer in the right direction. I should note the the top part of rc.inet1.conf looks like this (because most of the time this machine is connected to an intranet)
Code:
# Config information for eth0:
IPADDR[0]="192.168.1.30"
NETMASK[0]="255.255.255.0"
USE_DHCP[0]=""
DHCP_HOSTNAME[0]=""

# Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""

# Config information for eth2:
IPADDR[2]=""
NETMASK[2]=""
USE_DHCP[2]=""
DHCP_HOSTNAME[2]=""

# Config information for eth3:
IPADDR[3]=""
NETMASK[3]=""
USE_DHCP[3]=""
DHCP_HOSTNAME[3]=""

# Default gateway IP address:
GATEWAY="192.168.1.1"
From now until about 15 December, though, that intranet is unavailable and I'm running on a dial-up if or until I can access an open wireless point.

Thanks.
 
Old 10-31-2009, 01:41 PM   #10
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
What I would do is compile madwifi myself as well as possibly wpa_supplicant if you need wpa support, then follow this guide:

http://madwifi-project.org/wiki/UserDocs/FirstTimeHowTo

If that doesn't work, post again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Atheros AR5007EG wireless network adapter not working in Fedora core 6 erjan Linux - Newbie 9 11-10-2008 01:54 AM
Small network problem with atheros ar5005g and madwifi driver. syntych Linux - Wireless Networking 4 10-13-2007 08:59 AM
fc5 madwifi atheros ar5005g wireless network mike_morley Linux - Wireless Networking 0 10-27-2006 04:08 PM
configuring Atheros AR5001X+ Wireless Network Adapter asilentmurmur Suse/Novell 0 03-04-2005 12:18 AM


All times are GMT -5. The time now is 07:37 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration