LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 04-13-2008, 02:17 PM   #1
/y0shi
Member
 
Registered: Jan 2006
Location: berlin, germany
Distribution: slackware 12.0
Posts: 58

Rep: Reputation: 15
atheros access point authmode wep problem


I have three Slackware 12.0 boxes, two with atheros pcmcia cards and one with a ipw220 mini-pci chip.

One of the atheros boxes is the access point, created with:
Code:
/usr/bin/wlanconfig ${INTERFACE} destroy
/usr/bin/wlanconfig ${INTERFACE} create wlandev wifi0 wlanmode ap
/sbin/ifconfig ${INTERFACE} ${IPADDR} broadcast ${BROADCAST} netmask ${NETMASK}
/sbin/iwconfig ${INTERFACE} essid ${ESSID} key ${KEY}
/sbin/iwpriv ${INTERFACE} authmode 1
/sbin/ifconfig ${INTERFACE} ${IPADDR} up
This works perfectly with the other atheros box as a client, but not with the ipw2200 box as a client. If I change the authmode from 1 to 2 it is working for the ipw2200 but not for the atheros box.

This should have been just a test in order to proceed with openvpn, but since even this is not working I'm confused. At least why is the atheros pcmcia card not working with authmode 2?

Does someone has experience with setting up access points on linux?
I appreciate any help - thanks in advance ...
 
Old 04-15-2008, 04:40 AM   #2
/y0shi
Member
 
Registered: Jan 2006
Location: berlin, germany
Distribution: slackware 12.0
Posts: 58

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by /y0shi View Post
At least why is the atheros pcmcia card not working with authmode 2?
Allright I allways tried to use the ipw2200 card with authmode 1 but it doesn't understand the command
Code:
# iwpriv authmode 1
But the atheros card does. So if I force the atheros card (as the client) to use authmode 2 it works. My /etc/rc.d/rc.wireless.conf looks like that now (on the atheros client):
PHP Code:
*)
        
INFO="connecting to Node"
        
ESSID="Node"
        
CHANNEL="1"
        
MODE="Managed"
        
RATE="auto"
        
KEY="<random>"
        
IWPRIV="authmode 2"
;; 
It looks the same on the ipw2200 client but without the IWPRIV option ...
 
  


Reply

Tags
access, atheros, point, wep


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No access point problem pwabrahams Linux - Wireless Networking 4 02-23-2008 04:14 PM
Problem connecting to access point in Suse 10.0 Flashpass Linux - Networking 3 03-01-2007 01:23 AM
Problem connecting to access point wes_jin Linux - Newbie 1 06-16-2006 07:04 PM
Linux WEP atheros cherdt Linux - Wireless Networking 4 10-11-2005 03:38 PM
Using an Atheros WLAN card as Access Point firebolt Linux - Hardware 0 03-27-2004 02:34 PM


All times are GMT -5. The time now is 11:47 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration