LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   ath9k 802.11n 300Mbps at low speed (http://www.linuxquestions.org/questions/slackware-14/ath9k-802-11n-300mbps-at-low-speed-4175493355/)

m1m 02-01-2014 08:50 AM

ath9k 802.11n 300Mbps at low speed
 
Hi
I'm testing my new home 802.11n network.

router - slax 7, kernel 3.8.2, AR9382 mini pci-e (sparklan WPEA-121N)
Code:

wlan0    IEEE 802.11abgn  ESSID:"xyz"
          Mode:Ad-Hoc  Frequency:2.412 GHz  Cell: 96:77:38:F7:80:C8
          Tx-Power=16 dBm
          Retry  long limit:7  RTS thr:off  Fragment thr:off
          Encryption key:off
          Power Management:on

desktop - slackware 14.1, kernel 3.10.17, AR9287 pci-e x1 (tp-link TL-WN881ND)
Code:

wlan0    IEEE 802.11bgn  ESSID:"xyz"
          Mode:Ad-Hoc  Frequency:2.412 GHz  Cell: 96:77:38:F7:80:C8
          Tx-Power=20 dBm
          Retry  long limit:7  RTS thr:off  Fragment thr:off
          Encryption key:off
          Power Management:off

laptop - windows 7, intel centrino advanced-n 6205

All computers are in the same place, standing next to each other, InSSIDer shows no interference with other networks, very good signal quality.
All wireless adapters can theoretically work in 802.11n 300Mbps speed.

I set up ad-hoc network with
Code:

iw wlan0 ibss join xyz 2412 HT40+
I'm testing speed with iperf. I can't get more than 3-4Mbps between any of my devices. When using 802.11g (NOHT option) I get 17-19Mbps between my desktop and server. Laptop still at 4Mbps.

Whats going on? Why I can't reach even 50% of 802.11g?

When doing
Code:

iwlist wlan0 scan
I never see available bitrates > 54Mb/s for my network.

jeremy 02-03-2014 10:27 AM

Please post your thread in only one forum. Posting a single thread in the most relevant forum will make it easier for members to help you and will keep the discussion in one place. This thread is being closed because it is a duplicate.

--jeremy


All times are GMT -5. The time now is 04:12 AM.