Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 06-27-2002, 12:48 PM   #1
Registered: Jun 2002
Location: Berlin / Germay
Distribution: gentoo linux, ubuntu
Posts: 40

Rep: Reputation: 17
Angry ata100.i - self compiled kernel doesn't recognize ATA100 controller... wtf?

hoooooow-deeee-hoooo fellas!

I have successfully downloaded slackware 8.0 quite a while ago, and installed it on my HD over a ATA100 Controller (Promise Ultra 100) using the ata100.i kernel... ok, everything was good so far...

Next I looked up the Slackware 8.0 ata100.i kernel config and modified it to my specific needs (NIC, SNDCARD, VIDCARD, and so on..), compiled it, and DID NOT WORK...

any ideas? - thanks in advance.
Old 06-28-2002, 03:57 AM   #2
Senior Member
Registered: Jan 2002
Location: Rome, Italy ; Novi Sad, Srbija; Brisbane, Australia
Distribution: Ubuntu / ITOS2008
Posts: 1,207

Rep: Reputation: 46
Yeah, i have one
You only use the kernel ata100.i but you did not copy .config file to /usr/src/linux (i dont think .config files are provided with dlackware pre compiled kernels) So when you 'modofied' your existing kernel you were actually modifying a clean kernel .config not that one of ata100.i kernel you are using, so ata100 support wasn't selected.
Now you might try to cd to /usr/src/linux and do a make oldconfig, then make menuconfig to see if make oldconfig made a .config file based on the ata100.i kernel (the one you are using)
If that doesn't work you'll have to go through a clean make menuconfig and find and enable ata100 support for yourself (together with all the other options you need) and then compile that, entirely your kernel.
Hope that helps


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
2.6.x compatible ide ata100 controller card radabasp Linux - Hardware 2 10-27-2004 10:27 AM
Slack on an ATA100/RAID controller BrandonJG Slackware 4 09-07-2002 07:51 PM
Installing redhat to ata100 drive on a SIIG controller. Infinity Linux - Software 2 02-25-2002 07:05 PM
Damn you LILO... RedHat + Abit/HPT370 ATA100 controller = "LI " neeyo Linux - Software 24 02-13-2002 11:32 PM
How do I get Linux to recognize my ATA100 disks Linux - General 5 09-04-2001 01:49 PM

All times are GMT -5. The time now is 07:20 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration