LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-03-2011, 03:25 PM   #1
DrTardis
LQ Newbie
 
Registered: Jul 2011
Distribution: Slackware
Posts: 17

Rep: Reputation: Disabled
Asus PCE-N13 Wireless only working in X


Hey everyone and thanks for taking the time to help me out.

I am attempting to setup wireless in Slackware 13.37 for the first time and while I found a lot of helpful guides I am still unable to connect to my router without starting X and using wicd. I'll post my rc.inet1.conf and rc.wireless.conf along with wireless-settings.conf from wicd.

wireless-settings.conf

Code:
[00:26:F3:22:33:7A]
automatic = False

[00:26:F3:22:33:79]
afterscript = None
dhcphostname = Doctor
bssid = 00:26:F3:22:33:79
postdisconnectscript = None
use_dhcphostname = 0
dns_domain = None
quality = 70
gateway = None
use_global_dns = False
strength = -62
encryption = True
bitrates = 300 Mb/s
ip = None
beforescript = None
hidden = False
channel = 3
mode = Managed
psk = 71a2f5695eabc86b6580df03137a58da19e4015f8e1a1b43b14f3fdca4684f29
has_profile = True
netmask = None
key = 47993EA2187C54D40B7889AA1B
predisconnectscript = None
enctype = wep-hex
dns3 = None
dns2 = None
dns1 = None
use_settings_globally = False
use_static_dns = False
encryption_method = WEP
essid = Reefa
automatic = True
search_domain = None

rc.inet1.conf

Code:
# /etc/rc.d/rc.inet1.conf
#
# This file contains the configuration settings for network interfaces.
# If USE_DHCP[interface] is set to "yes", this overrides any other settings.
# If you don't have an interface, leave the settings null ("").

# You can configure network interfaces other than eth0,eth1... by setting
# IFNAME[interface] to the interface's name. If IFNAME[interface] is unset
# or empty, it is assumed you're configuring eth<interface>.

# Several other parameters are available, the end of this file contains a
# comprehensive set of examples.

# =============================================================================

# Config information for eth0:
#IPADDR[0]=""
#NETMASK[0]=""
#USE_DHCP[0]=""
#DHCP_HOSTNAME[0]=""

# Config information for eth1:
#IPADDR[1]=""
#NETMASK[1]=""
#USE_DHCP[1]=""
#DHCP_HOSTNAME[1]=""

# Config information for eth2:
#IPADDR[2]=""
#NETMASK[2]=""
#USE_DHCP[2]=""
#DHCP_HOSTNAME[2]=""

# Config information for eth3:
#IPADDR[3]=""
#NETMASK[3]=""
#USE_DHCP[3]=""
#DHCP_HOSTNAME[3]=""

# Default gateway IP address:
#GATEWAY="192.168.0.1"

# Change this to "yes" for debugging output to stdout.  Unfortunately,
# /sbin/hotplug seems to disable stdout so you'll only see debugging output
# when rc.inet1 is called directly.
DEBUG_ETH_UP="no"

## Example config information for wlan0.  Uncomment the lines you need and fill
## in your info.  (You may not need all of these for your wireless network)

IFNAME[0]="wlan0"
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]="yes"
#DHCP_HOSTNAME[0]="Doctor"
#DHCP_KEEPRESOLV[0]="yes"
#DHCP_KEEPNTP[0]="yes"
#DHCP_KEEPGW[0]="yes"
#DHCP_IPADDR[0]="192.168.0.1"
WLAN_ESSID[0]=Reefa
WLAN_MODE[0]=Managed
#WLAN_RATE[0]="54M auto"
#WLAN_CHANNEL[0]="auto"
WLAN_KEY[0]="47993EA2187C54D40B7889AA1B"
#WLAN_IWPRIV[0]="set EncrypType=TKIP"
#WLAN_WPA[4]="wpa_supplicant"
#WLAN_WPADRIVER[4]="ndiswrapper"

## Some examples of additional network parameters that you can use.
## Config information for wlan0:
#IFNAME[4]="wlan0"              # Use a different interface name nstead of
                                # the default 'eth4'
#HWADDR[4]="00:01:23:45:67:89"  # Overrule the card's hardware MAC address
#MTU[4]=""                      # The default MTU is 1500, but you might need
                                # 1360 when you use NAT'ed IPSec traffic.
#DHCP_KEEPRESOLV[4]="yes"       # If you dont want /etc/resolv.conf overwritten
#DHCP_KEEPNTP[4]="yes"          # If you don't want ntp.conf overwritten
#DHCP_KEEPGW[4]="yes"           # If you don't want the DHCP server to change
                                # your default gateway
#DHCP_IPADDR[4]=""              # Request a specific IP address from the DHCP
                                # server
#WLAN_ESSID[4]=DARKSTAR         # Here, you can override _any_ parameter
                                # defined in rc.wireless.conf, by prepending
                                # 'WLAN_' to the parameter's name. Useful for
                                # those with multiple wireless interfaces.
#WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=thekey"
                                # Some drivers require a private ioctl to be
                                # set through the iwpriv command. If more than
                                # one is required, you can place them in the
                                # IWPRIV parameter (separated with the pipe (|)
                                # character, see the example).

rc.wireless.conf

Code:
VERBOSE=1
case "$HWADDR" in
# Generic example (decribe all possible settings)
*)
 #INFO="Fill with your own settings..."
 # ESSID (extended network name) : My Network, any
 #ESSID=""
 # NWID/Domain (cell identifier) : 89AB, 100, off
 #NWID=""
 # Operation mode : Ad-Hoc, Managed, Master, Repeater, Secondary, auto
 #MODE=""
 # Frequency or channel : 1, 2, 3 (channel) ; 2.422G, 2.46G (frequency)
 #FREQ=""
 #CHANNEL=""
 # Sensitivity (cell size + roaming speed) : 1, 2, 3 ; -70 (dBm)
 #SENS=""
 # Bit rate : auto, 1M, 11M
 #RATE=""
 # Encryption key : 4567-89AB-CD, s:password
 #KEY=""
 # RTS threshold : off, 500
 #RTS=""
 # Fragmentation threshold : off, 1000
 #FRAG=""
 # Other iwconfig parameters : power off, ap 01:23:45:67:89:AB
 #IWCONFIG=""
 # iwspy parameters : + 01:23:45:67:89:AB
 #IWSPY=""
 # iwpriv parameters : set_port 2, set_histo 50 60
 #IWPRIV=""
 ;;
esac
 
Old 07-03-2011, 07:43 PM   #2
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,517

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
If you can connect from wicd while in X, then you can use the ncurses version of wicd 'wicd-client' at the command line.
 
Old 07-03-2011, 07:49 PM   #3
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,650
Blog Entries: 2

Rep: Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095
Quote:
Originally Posted by allend View Post
If you can connect from wicd while in X, then you can use the ncurses version of wicd 'wicd-client' at the command line.
Isn't that wicd-curses, and not wicd-client?
 
Old 07-03-2011, 07:54 PM   #4
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,517

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
Quote:
Isn't that wicd-curses, and not wicd-client?
My bad. Of course. Thanks for picking that up!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Asus PCE-N13 can't see router DrTardis Slackware 5 07-02-2011 04:54 PM
Driver issues with Wireless card (Asus PCE-N13, ie ralink rt2860) in Fedora 12 cander49 Linux - Networking 2 10-28-2010 02:52 PM
Can't get wireless working in Slitaz (Asus Aspire ZG5, Atheros wifi) lostinpurdy Linux - Networking 4 09-18-2010 01:10 AM
Fedora 12, driver issues with Wireless card (Asus PCE-N13, ie ralink rt2860) cander49 Fedora 0 08-24-2010 05:52 PM
Ubuntu ASUS 1101HA wired and wireless not working groebe Linux - Wireless Networking 1 09-10-2009 01:13 PM


All times are GMT -5. The time now is 07:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration