LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-23-2004, 09:09 AM   #1
xushi
Senior Member
 
Registered: Jun 2003
Location: UK
Distribution: Gentoo
Posts: 1,288

Rep: Reputation: 45
Asus A7N8X Delux + Nvidia OpenGL + Surround sound fixed Guide.


UPDATE:
EDIT: 30-10-04 - All works now.
EDIT: 2-11-04 Quake 3 runs perfecly with 230fps on highest settings.

Oh man it was long.. Just a little update, i got an email from a LQ user asking about one thread i created regarding this matter.. and here's an update i replied to him. It should help anyone else who is getting problems setting up Nforce sound, video, and network drivers.

... It really turned out that i had 2 reasons why my computer kept freezing... ATI card and gay drivers... and my 250 gig sata hard drive was failing on me... It was too late when i noticed =/ and i lost everything..

But anyway, i got everything to work, except that the games have a slight delay between the audio, and the gameplay.. Nvidia claims that the latest nforce2 audio drivers that came out 3 days ago fixes that, but i haven't played a game to check yet. If anyone did, please tell me. Secondly, you can watch movies only and only on Totem player, and you can't skip through the movie or it will crash... (hey... better than nothing) EDIT: 30-10-04 Fixed. Read bottom of post.

im hoping you dont have ATI card, coz if you do, you're screwed.. they have the worst drivers, especially linux drivers... I spent days trying to get them to work.. Worked once, then i couldnt figure it out again.. What i did, is buy myself an nvidia geforce 6800 card, and it works perfectly. But there are a few things you should do first...

Firstly, keep hotplug installed, it installs essential drivers your motherboard needs. (like some which don't let your computer lag every 1 second)

but in the blacklist, make sure it includes
(/etc/hotplug/blacklist)

snd-pcm-oss
snd-mixer-oss
snd-intel8x0
snd-ac97-codec
gameport
snd-pcm
snd-timer
snd-page-alloc
snd-mpu401-uart
snd-rawmidi
snd-seq-device
snd-rawmidi
snd

fglrx
radeon
rivafb
forcedeth

fglrx, radeon, and rivafb only put there if you're on an nvidia card, and not an ati card, otherwise, omitt them.

keep forcedeth there, coz these are the linux default network drivers.. you're going to install nvidia's.

download the new nforce drivers and the latest nvidia video drivers (if you're using nvidia card) from their website.

Now reboot.. after you reboot, if you lsmod, you shouldn't see any alsa or oss drivers there.. good.. also, you shouldnt see forcedeth there, and you shouldnt have any network drivers installed.. this makes life easier...

chmod +x NFORCE-Linux-x86-1.0-0292-pkg1.run
chmod +x NVIDIA-Linux-x86-1.0-6111-pkg1.run

(if you have nvidia card, then)
./NVIDIA-Linux-x86-1.0-6111-pkg1.run
and install them. then read the documentation on what to edit in /etc/X11/xorg.conf
mainly as i remember, you have to set Driver to nvidia in
Section "Device"
Identifier "nvidiaCard"
Driver "nvidia"
#VideoRam 131072
# Insert Clocks lines here if appropriate
EndSection

And go to /etc/modules.conf and delete everything there but these three lines. If you can't see any of them, then just manually add them:

alias sound-slot-0 nvsound
alias eth0 nvnet
alias char-major-195 nvidia

First one sets the sound, second sets the network, third sets the gfx card (if you have nvidia card.)

next... install audio drivers from
./NFORCE-Linux-x86-1.0-0292-pkg1.run
Don't install the network drivers yet, unselect it.

When you finish installing audio drivers, don't bother running alsaconf, it wont detect any drivers there.. But once you reboot, the nvsound drivers should be installed and running.

make sure your ethernet cable is plugged in the Gigabit slot (the top one afaik).
then run
./NFORCE-Linux-x86-1.0-0292-pkg1.run
unselect the audio, and install the network drivers. (ignore all the warnings)

once finished, reboot, and if everything goes smoothly, the nvnet drivers should load, and during boot time, you should get a warning saying that might taint the kernel (ignore that.. if you get the message, it meens all is well).

enter kde through startx, you should see the nvidia sign before loading kde. this meens your gfx drivers are up and running.

open a console terminal, and type
nvmixer
Speaker -> set to 5.1 surround sound.
and under xmms, Totem, or anything else, use the OSS drivers there.
Sound should work.

ping an ip address and you should get a response, (that is, if you fixed your network before, using netconfig). If you still don't get a ping response, connect your ethernet cable to the 100Mb slot (bottom), and try again. but on mine, it works on the top one.

And that's that.


NOTES:
I disabled OSS from my kernel.. i doubt you have to do that, but just incase you do, just go to

cd /usr/src/linux
make xconfig

go to Sound, and disable OSS sound modules from there (n)

And to recompile the kernel, follow DaOne's post on "Kernel compiling guide for newbies"

Keep in mind, everytime you recompile the kernel, you have to reinstall all your drivers again (sound, graphics, and network).

Once you get the hang of it, it will take you 5 minuts tops to reinstall them.

Hope this helps, and if you're using ATI drivers, they might be the main reason why your computer is freezing in kde. I think it was the DRI problem.. I can't help you there..

EDIT: 30-10-04
To get mplayer or gmplayer to play normally without sound errors, delay, or crashes, read on Post #14 http://www.linuxquestions.org/questi...53#post1264753

Last edited by xushi; 11-02-2004 at 10:23 AM.
 
Old 10-25-2004, 03:08 PM   #2
buaku
Member
 
Registered: Sep 2004
Distribution: Slackware 10.2 (2.4.31)
Posts: 111

Rep: Reputation: 15
Coolness!! This is exactly the kind of thing I needed to figure out the nvsound module. Especially the part about not worrying about the alsa modules. I thought I still needed snd.

About all I tried was xmms using the OSS plugin and then loaded up mplayer and played an mp3 from each, and they both played together.

Then I left xmms running and loaded up UT2k4, and the sounds coexisted. I didn't notice and lag in the sounds from what I could tell. Only thing I noticed was a quick skip in the xmms sound when I started UT2k4.

I have an a7n8x-e deluxe. For me the network is a little different, my top one is the nvidia one, which isn't gigabit. The bottom NIC is gigabit and requires another driver.

Thanks again for the writeup!
 
Old 10-25-2004, 04:33 PM   #3
xushi
Senior Member
 
Registered: Jun 2003
Location: UK
Distribution: Gentoo
Posts: 1,288

Original Poster
Rep: Reputation: 45
Forgot to mention, this is my .asoundrc file in my home directory

Code:
### .asoundrc for nforce2 apu
pcm.nforce-hw {
type hw
card 0
}

pcm.!default {
type plug
slave.pcm "nforce"
}

pcm.nforce {
type dmix
ipc_key 1234
slave {
pcm "hw:0,0"
period_time 0
period_size 1024
buffer_size 4096
rate 44100
}
}

ctl.nforce-hw {
type hw
card 0
}
I'm not sure if i must have it or not, but its there =)

Buaku, can you play movie files properly? or do you have the same problems i have? with the no skipping etc... ?
 
Old 10-25-2004, 11:04 PM   #4
buaku
Member
 
Registered: Sep 2004
Distribution: Slackware 10.2 (2.4.31)
Posts: 111

Rep: Reputation: 15
Well i just tried a dvd in mplayer
mplayer -dvd-device /dev/cdrom dvd://2

and that was a mess, lol. The video and audio were really lagged, it was un watchable. I could skip through it ok and mplayer dind't crash, but totally unwatchable. I dont have any mpg's on that system to try.

I'll try that other player too when i have some more time.
And I'll try a normal mpeg with mplayer and see what happens.

I'll post back with my results.
 
Old 10-27-2004, 08:20 PM   #5
buaku
Member
 
Registered: Sep 2004
Distribution: Slackware 10.2 (2.4.31)
Posts: 111

Rep: Reputation: 15
Ok I tried totem today, video and sound played well only when i ran it and the display was through a remote cygwin X server displaying on my windows machine.

When i physically logged into my linux machine all i got was a blue screen for the video...the sound played fine though.

I then took whollychao's suggestion for mplayer from this other thread of yours.... http://www.linuxquestions.org/questi...97#post1253997

and the "-ao sdl" option worked great!

So you might wanna give that a shot with mplayer.

I have no idea what was up with my version of totem...it was installed with slackware 10. I need to upgrade a lot of stuff to try the latest totem it seems.
 
Old 10-27-2004, 11:47 PM   #6
buaku
Member
 
Registered: Sep 2004
Distribution: Slackware 10.2 (2.4.31)
Posts: 111

Rep: Reputation: 15
Ok I did some pokin around about totem problems here and found :
http://www.linuxquestions.org/questi...55#post1244755

I guess I'll be sticking with mplayer for now.
 
Old 10-28-2004, 06:47 PM   #7
xushi
Senior Member
 
Registered: Jun 2003
Location: UK
Distribution: Gentoo
Posts: 1,288

Original Poster
Rep: Reputation: 45
buaku, i bow down to you =) i wouldn't have noticed the reply there if you didn't link to it.
 
Old 10-28-2004, 08:33 PM   #8
buaku
Member
 
Registered: Sep 2004
Distribution: Slackware 10.2 (2.4.31)
Posts: 111

Rep: Reputation: 15
hehe sweet.
One thread i have doesn't seem to email me a notice when it gets a reply.

yet all the ones i jumped in in the middle have.

that was definantly a handy tip!
something soo simple fixes sooo many problems, lol
 
Old 10-28-2004, 09:45 PM   #9
xushi
Senior Member
 
Registered: Jun 2003
Location: UK
Distribution: Gentoo
Posts: 1,288

Original Poster
Rep: Reputation: 45
Do you know how to make life easier and let it automatically open mplayer with these parameters everytime you double click on a movie file?
 
Old 10-28-2004, 10:14 PM   #10
buaku
Member
 
Registered: Sep 2004
Distribution: Slackware 10.2 (2.4.31)
Posts: 111

Rep: Reputation: 15
That I dont know. I've mainly been using fluxbox and no form of file manager. So I'm just used to starting it all from the command line.
 
Old 10-30-2004, 06:41 AM   #11
xushi
Senior Member
 
Registered: Jun 2003
Location: UK
Distribution: Gentoo
Posts: 1,288

Original Poster
Rep: Reputation: 45
Sorry, was too tired to notice...

Just add
ao sdl
to ~/.mplayer/config.
right click on a movie file (mpg, avi....) --> open with --> Other
and choose
/usr/bin/mplayer (not gmplayer)
Tick the box next to "Remember application"

And that should do it... Sacrefice the control bar, but gain synchronisation, skipping, and a movie to watch =)
 
Old 10-30-2004, 06:47 AM   #12
Cedrik
Senior Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 2,140

Rep: Reputation: 242Reputation: 242Reputation: 242
You could change your X icon/menu settings so it starts 'gmplayer -ao sdl' instead of just start
'gmplayer'
 
Old 10-30-2004, 06:50 AM   #13
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Actually, putting what xushi said and running gmplayer would have the same effect as running mplayer, so choose the one you like more
 
Old 10-30-2004, 07:05 AM   #14
xushi
Senior Member
 
Registered: Jun 2003
Location: UK
Distribution: Gentoo
Posts: 1,288

Original Poster
Rep: Reputation: 45
Fixed (finally....)

I'll be posting this on both threads since they're both related.

copy /etc/mplayer/codecs.conf to your
~/.mplayer/
directory.

if you open gmplayer from command prompt, you'll notice it says
Code:
SDL: Samplerate: 48000Hz Channels: Stereo Format Signed 16-bit (Little-Endian)
SDL: using oss audio driver
SDL: Unable to open audio: No available audio device
Could not open/initialize audio device -> no sound.
Audio: no sound
Starting playback...
so,
pico ~/.mplayer/mplayer.conf
add a line there: ao=sdl
pico /etc/mplayer/mplayer.conf
add a line there: ao=sdl
set framedrop = no
and finally remove the very last "i didnt read RTFM" line

open gmplayer, go to audio settings,
choose SDL, and click configure.
Make sure you do not select any codecs in there. just select the blank field.

Save, exit, and start gmplayer with a movie again. It should display the same output as what you get in mplayer

Code:
SDL: Samplerate: 48000Hz Channels: Stereo Format Signed 16-bit (Little-Endian)
AO: [plugin] 48000Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
Building audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
Starting playback...
And everything finally works =)

go to any movie file you have, and switch its default player from mplayer, back to gmplayer again.
right click --> open with --> other
use
/usr/bin/gmplayer

Thanks alot whollychao, Cedrik, gbonvehi buaku.. I've been a pain for 2 months =)
 
Old 11-09-2004, 03:28 AM   #15
spockpv
LQ Newbie
 
Registered: Nov 2004
Posts: 4

Rep: Reputation: 0
Quote:
Originally posted by xushi
Fixed (finally....)

I'll be posting this on both threads since they're both related.

copy /etc/mplayer/codecs.conf to your
~/.mplayer/
directory.

if you open gmplayer from command prompt, you'll notice it says
Code:
SDL: Samplerate: 48000Hz Channels: Stereo Format Signed 16-bit (Little-Endian)
SDL: using oss audio driver
SDL: Unable to open audio: No available audio device
Could not open/initialize audio device -> no sound.
Audio: no sound
Starting playback...
so,
pico ~/.mplayer/mplayer.conf
add a line there: ao=sdl
pico /etc/mplayer/mplayer.conf
add a line there: ao=sdl
set framedrop = no
and finally remove the very last "i didnt read RTFM" line

open gmplayer, go to audio settings,
choose SDL, and click configure.
Make sure you do not select any codecs in there. just select the blank field.

Save, exit, and start gmplayer with a movie again. It should display the same output as what you get in mplayer

Code:
SDL: Samplerate: 48000Hz Channels: Stereo Format Signed 16-bit (Little-Endian)
AO: [plugin] 48000Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
Building audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
Starting playback...
And everything finally works =)

go to any movie file you have, and switch its default player from mplayer, back to gmplayer again.
right click --> open with --> other
use
/usr/bin/gmplayer

Thanks alot whollychao, Cedrik, gbonvehi buaku.. I've been a pain for 2 months =)


Thanks xushi, everything works smoothly, at last with hardware mixing!
One little problem with mplayer:

Code:
mplayer -ao sdl -channels 6 movie.avi 
...
...
...
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
AC3: 5.1 (3f+2r+lfe)  48000 Hz  448.0 kbit/s
Using MMX optimized resampler
AUDIO: 48000 Hz, 6 ch, 16 bit (0x10), ratio: 56000->576000 (448.0 kbit)
Selected audio codec: [a52] afm:liba52 (AC3-liba52)
...
...
...
Checking audio filter chain for 48000Hz/6ch/16bit -> 48000Hz/6ch/16bit...
AF_pre: af format: 2 bps, 6 ch, 48000 hz, little endian signed int
AF_pre: 48000Hz 6ch Signed 16-bit (Little-Endian)
SDL: Samplerate: 48000Hz Channels: Stereo Format Signed 16-bit (Little-Endian)
SDL: Unable to open audio: 1 (mono) and 2 (stereo) channels supported
Could not open/initialize audio device -> no sound.
Audio: no sound
However, without -channels 6, it works ok but without 5.1 surround...
Any ideas?
Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound - Asus A7N8x Slackware Kane2002 Linux - Hardware 5 01-21-2005 09:51 AM
sound with ASUS A7N8X-X KhalidB Linux - Hardware 2 01-17-2005 06:11 PM
No sound on A7N8X delux - mandrake 10 apbrpg Linux - Newbie 1 05-07-2004 06:21 PM
how to install the drivers for my Fedora Core 1 system on a asus a7n8x delux-e mobord thematrimix Linux - Hardware 2 04-11-2004 07:08 PM
ASUS A7N8X Delux in Slackware 9.1 b2000 Linux - Hardware 1 02-23-2004 12:29 PM


All times are GMT -5. The time now is 05:01 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration