LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 12-15-2008, 09:09 AM   #1
Slacker Steve
Member
 
Registered: Nov 2008
Posts: 85

Rep: Reputation: 16
Applications from all workspaces show up in taskbar (compiz-fusion & KDE 3.5.10)


Any idea how I can make the taskbar only show applications from the current workspace?

Thanks in advance
 
Old 12-15-2008, 09:32 AM   #2
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Rep: Reputation: 227Reputation: 227Reputation: 227
Are you talking about KDE and by workspace do you mean desktop ?

If the answer to both these is yes then do the following -

Code:
right click on the panel
select configure panel
select taskbar
uncheck "show windows from all desktops"
Now each desktop should only show it's own applications in the taskbar.
 
Old 12-15-2008, 10:10 AM   #3
Slacker Steve
Member
 
Registered: Nov 2008
Posts: 85

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by bgeddy View Post
Are you talking about KDE and by workspace do you mean desktop ?

If the answer to both these is yes then do the following -

Code:
right click on the panel
select configure panel
select taskbar
uncheck "show windows from all desktops"
Now each desktop should only show it's own applications in the taskbar.
Yes and yes.

But I can't seem to find the "show windows from all desktops" you mentioned.

Screenshot:
http://www.vulomedia.com/images/78817snapshot3.png

Last edited by Slacker Steve; 12-15-2008 at 10:11 AM.
 
Old 12-15-2008, 10:17 AM   #4
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Rep: Reputation: 227Reputation: 227Reputation: 227
Look at the "Configure - KDE panel" window which has the top section titled "Configure the panel taskbar" where a checkbox is right at the top for "Show windows from all desktops",

Here's another way :
Code:
from Kicker menu - Control Centre,Desktop,Taskbar,Show windows from all desktops.
Sorry - I've just looked at you screen shot and the checkbox appears to be missing - don't know why. Are you sure you have multiple desktops setup ?
Check Control Centre,Desktop,Multiple deskktop. The only time I can get this button to disappear,(Show windows from all desktops), is when my multiple desktops is set to 1.

Yet more apologies - I've just reread the title and noticed you are using Compiz-fusion. Maybe this is the difference ? I'll have to look at thread titles more carefully in future !

Last edited by bgeddy; 12-15-2008 at 10:26 AM.
 
Old 12-15-2008, 10:35 AM   #5
Slacker Steve
Member
 
Registered: Nov 2008
Posts: 85

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by bgeddy View Post
Sorry - I've just looked at you screen shot and the checkbox appears to be missing - don't know why. Are you sure you have multiple desktops setup ?
Check Control Centre,Desktop,Multiple deskktop. The only time I can get this button to disappear,(Show windows from all desktops), is when my multiple desktops is set to 1.

Yet more apologies - I've just reread the title and noticed you are using Compiz-fusion. Maybe this is the difference ? I'll have to look at thread titles more carefully in future !
Yep, that was my problem.

I set multiple desktops to 4 and successfully unchecked "show windows from all desktops," but it didn't work. I guess this is something to do with Compiz, you advice works perfectly with Kwin.

Thanks for the helps so far
 
Old 12-15-2008, 10:24 PM   #6
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,298

Rep: Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722
Compiz was very strange when it comes to KDE. I haven't tried it recently, so I don't know if it has improved in this regard. Compiz insists on using 'viewports' instead of just assigning each virtual desktop to each face of the cube. Unfortunately, if you set up up four desktops, you will get 4 sides of the cube for EACH desktop instead of just four sides period. Also, I think the "To Desktop" button may disappear in the window's context menu (but I may be wrong there...even if it is there though, it will send it to the next desktop, which still has four sides of the cube). Again, this may have changed dramatically since I last used compiz. However, to use compiz optimally you should really use Gnome (or maybe XFCE) instead of KDE (of course, you can always use compiz suboptimally). Stuff like this is why I stopped using compiz. Search for "compiz KDE pager" or some such thing for more information. Maybe someone can correct me and tell me my information is out-dated?
 
Old 12-16-2008, 12:16 AM   #7
Slacker Steve
Member
 
Registered: Nov 2008
Posts: 85

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by T3slider View Post
Compiz was very strange when it comes to KDE. I haven't tried it recently, so I don't know if it has improved in this regard. Compiz insists on using 'viewports' instead of just assigning each virtual desktop to each face of the cube. Unfortunately, if you set up up four desktops, you will get 4 sides of the cube for EACH desktop instead of just four sides period. Also, I think the "To Desktop" button may disappear in the window's context menu (but I may be wrong there...even if it is there though, it will send it to the next desktop, which still has four sides of the cube). Again, this may have changed dramatically since I last used compiz. However, to use compiz optimally you should really use Gnome (or maybe XFCE) instead of KDE (of course, you can always use compiz suboptimally). Stuff like this is why I stopped using compiz. Search for "compiz KDE pager" or some such thing for more information. Maybe someone can correct me and tell me my information is out-dated?
Yeah I noticed that as well.

I also have XFCE installed and it seems to work alright with that. I think I'll just use kwin with KDE
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Adding Compiz (fusion-icon) to KDE startup ZeroDaHero Linux - Software 1 08-17-2008 07:49 PM
Compiz Fusion crashes whole system if started with KDE - openSUSE 10.3 Ian_Hawdon Linux - Software 1 04-07-2008 10:02 AM
compiz-fusion works better in Gnome or Kde?? LinuxNewbie999 Linux - Newbie 2 02-27-2008 11:16 AM
Compiz-fusion & emerald - window decoration not loading kanoner Mandriva 1 12-25-2007 06:10 PM
ATI + Compiz Fusion + Suse 10.3 + KDE = not working trademarka Linux - Software 3 10-22-2007 10:54 AM


All times are GMT -5. The time now is 10:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration