Go Job Hunting at the LQ Job Marketplace
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 03-31-2004, 02:46 PM   #1
Registered: Feb 2004
Distribution: Slackware
Posts: 202

Rep: Reputation: 22
Question Apm problems

Hi guys,

I have problems loading APM module. When i type "halt" i still have to push the power button to turn it off. I began to search a thread when i look it up it on that i have to load apm typing, modprobe apm or modprobe acpi. Modprobe acpi, displays that acpi module can't be found.

When i typed modprobe apm it says that can't load the apm module that i have to look at syslog or take a look with dmesg. Ok, when i type dmesg to see the messages at start up. I found that the apm loads, but then it shutdown automatically because it is not safe to have APM with SMP.

Wonder why not ? SMP (i think it is simmetric multiprocessor, well i have a workstation with 2 processors) and APM worked fine with Redhat and Mandrake, they shutdown the computer and never have to push down the power button.

Any comments ? I will continue to find the way how to make apm working.
Old 03-31-2004, 04:13 PM   #2
Registered: Oct 2003
Location: Florida
Distribution: Slackware
Posts: 273

Rep: Reputation: 30
Are you using the default precompiled kernel? if you are, then you have to compile a new one. If you are not, then you just need to play with the APM and ACPI settings under make menuconfig.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
APM problems Ishkabibble Linux - Laptop and Netbook 3 11-26-2005 10:50 PM
apm vs. acpi ? (modprobe: FATAL: Error inserting apm) OneManArmy Linux - Laptop and Netbook 0 05-12-2004 04:39 PM
Problems with apm and acpi xflow7 Linux - General 1 05-08-2004 03:59 PM
Xfree having problems wiht fglrx and apm arkamir Linux - Hardware 6 04-08-2004 11:21 PM
apm problems JROCK1980 Linux - Newbie 0 08-30-2003 07:11 PM

All times are GMT -5. The time now is 12:23 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration