LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Anyone installed Slack 11 on Asus P5B with Core 2 Duo? (http://www.linuxquestions.org/questions/slackware-14/anyone-installed-slack-11-on-asus-p5b-with-core-2-duo-498927/)

chess 11-05-2006 05:48 PM

Anyone installed Slack 11 on Asus P5B with Core 2 Duo?
 
I am considering buying this board and was wondering if anyone has put Slack 11 on it. It seems there were some controller issues that were apparently fixed in kernel 2.6.18 but other than that, info is pretty scant.

Thanks.

phe 12-10-2006 01:12 PM

I installed slack 11.0 on a P5B AI lifestyle.

I booted from a dvd plugged into the jmicron ide port, booting with the following parameters, "huge26.s all-generic-ide irqpoll". Afaics it's the only way to install a slack 11.0 on an ASUS p5b. In BIOS you need to put sata in AHCI mode NOT in IDE and jmicron controler in IDE mode. I got also some trouble with a logitech mouse which can't be plugged in psaux through a mode changer (english wording ?) but must be plugged directly in an USB port.

Don't forget to setup correctly the boot device in BIOS, it took me a few hours to understand there was a specific BIOS options to boot from dvd rather from cdrom...

After that I suggest you build a 2.6.18.5 from the huge.s .config file, allowing you to avoid the "all-generic-ide irqpoll" trick.

Beside the thee days I needed to install it, it's now a nice box :)

drkstr 12-10-2006 03:13 PM

As suggested by phe, you will need to do a little leg work to find out what technology your motherboard uses so you can configure everything correctly (to new to autodetect). FYI, I had better luck with Gentoo because it's package management system builds everything from source, so you can easliy rebuild the entire distro to be optomized for intel's 64 bit arch (which is not nativly supported by any distro last time I checked). You can of course do this in Slackware, but it takes a lot of work.

good luck!
...drkstr

smaghe 01-25-2007 02:02 PM

P5B config.
 
Hello,
I did everything Phe wrote,in order to install Slackware 11 on my P5B,
but as booting starts,after Lilo I have:
"Kernel panic:unable to mount root fs on 03:01"
Do you have any idea?
Thank you.

H_TeXMeX_H 01-25-2007 04:44 PM

What filesystem are you using for your partitions (especially root in this case) ? Does your kernel have built-in support for it ?

smaghe 01-26-2007 01:29 AM

I have: boot primary ext 2
primary ext 2
primary ext 2
Primary Swap

And now a complete black screen after Lilo.

phe 01-26-2007 02:07 AM

I see a few possible problem:

First perhaps your lilo entry is setup as if the used kernel can work as it but it can't, my lilo entry for the kernel installed by slackware.

image = /boot/vmlinuz
root = /dev/sda1
append = "all-generic-ide irqpoll nohotplug" # neeeded until you rebuild your own >= 2.6.18.3 kernel
label = linux-2.6.17.13 # that's the huge26.s kernel
read-only

Second, I got some trouble with lilo, I needed to do the first install on the mbr with a $ lilo -M /dev...

I get also trouble with /dev/sda vs. /dev/hda, depending on your BIOS setup it's possible your SATA disk appears as a PATA disk, fix the bios setup so the IDE layer will not see it as a PATA disk, if your lilo entry use /dev/hda? fix it. I suspect something is wrong there since the boot device should be 0801 not 0301. BTW, if you installed on a SATA disk seen as PATA once, didn't you get horrible performance during setup ?

All of this can be done by booting with the install CD, if your SATA disk is not seen as a SATA disk something is wrong.

smaghe 01-27-2007 04:44 AM

Still troubles!
 
Hi,
First I changed many settings of the setup in order to do it correctly:
-In Bios: SATA in AHCI & JMICRON in IDE.
-I booted the installation disc with : "huge26.s all-generic-ide irqpoll"
-At the end, I chose the basic vmlinuz kernel
-Then Lilo has been configured to boot with :"all-generic-ide irqpoll nohotplug"
>>>>>>>>>>This time I have "Kernel panic unable to mount root fs on 08:01 !

Second,I'd like to thank you for all the help you're providing me.

phe 01-28-2007 12:02 PM

-In Bios: SATA in AHCI & JMICRON in IDE.
Ok
-I booted the installation disc with : "huge26.s all-generic-ide irqpoll"
Ok
-At the end, I chose the basic vmlinuz kernel
hmm, double check you're trying to boot with huge26.s, at boot the first line give the kernel version (2.6.17.13 iirc)
-Then Lilo has been configured to boot with :"all-generic-ide irqpoll nohotplug"
did you install the boot on the mbr with a $ lilo -M /dev/sda ?
>>>>>>>>>>This time I have "Kernel panic unable to mount root fs on 08:01 !

H_TeXMeX_H 01-28-2007 01:00 PM

Do you have any important data on the disk ? If not, try making new partitions and reinstalling.

KleB 01-28-2007 01:45 PM

2.6.19 kernel has better support for sata controllers. I managed to install slack on a similar Asus board, but didn't manage to set up Jmicron controller...

This is the thread I started when I had the issue:
http://www.linuxquestions.org/questi...d.php?t=514606

KleB 01-28-2007 02:45 PM

As to resolve your current issue, I suggest you prepare on a separate computer an appropriate 2.6.19.x kernel image, then boot the comp with knoppix, copy the kernel image into slackware's /boot, then install lilo (with accordingly revised lilo.conf).

Oh, and don't forget the modules dir (/lib/modules/2.6.19.x/)!


All times are GMT -5. The time now is 09:41 PM.