LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   anyone got OpenShot SBo slackbuild to work? (http://www.linuxquestions.org/questions/slackware-14/anyone-got-openshot-sbo-slackbuild-to-work-790383/)

metageek 02-20-2010 09:13 AM

anyone got OpenShot SBo slackbuild to work?
 
I'm trying to install OpenShot for the second time. I was originally trying to make a slackbuild for this, when a new one appeared in SBo. It does not work for me, however. It seems that it has to run a python install script and this fails. The package then complains that it cannot find the mlt python bindings.

Anyway, I've spent far too long with this, just wondering if someone else got this to work?

titopoquito 02-20-2010 10:10 AM

Did you check the README file of the mentioned SlackBuild? It mentions mlt, frei0r and pygoocanvas as dependencies, so your question should be answered I think. All of these should be available on slackbuilds.org, too.

gapan 02-20-2010 10:23 AM

You can find links to an i486 package and most dependencies in this thread at the salix forums if you're interested: http://www.salixos.org/forum/viewtopic.php?f=21&t=528

metageek 02-20-2010 11:49 AM

Quote:

Originally Posted by titopoquito (Post 3870502)
Did you check the README file of the mentioned SlackBuild? It mentions mlt, frei0r and pygoocanvas as dependencies, so your question should be answered I think. All of these should be available on slackbuilds.org, too.

Yes, I said I was even building my own slackbuild... I have all the dependencies installed. The error is in the python install script of OpenShot itself.

metageek 02-20-2010 12:04 PM

Quote:

Originally Posted by gapan (Post 3870512)
You can find links to an i486 package and most dependencies in this thread at the salix forums if you're interested: http://www.salixos.org/forum/viewtopic.php?f=21&t=528

I checked that thread and even downloaded the package that is mentioned there. Also, someone mentioned that PyXDG was also a dependency (though it is not mentioned in the readme files) and I installed that too. Still I get the following error:

Code:

Added /usr/lib/python2.6/site-packages/openshot to system path
--------------------------------
  OpenShot (version 1.0.0)
--------------------------------
*** ERROR: MLT Python bindings failed to import ***
*** ERROR: MLT Python bindings failed to import ***
Exception in thread Thread-1:
Traceback (most recent call last):
  File "/usr/lib/python2.6/threading.py", line 525, in __bootstrap_inner
    self.run()
  File "/usr/lib/python2.6/site-packages/openshot/classes/thumbnail.py", line 174, in run
    mlt.Factory().init()
NameError: global name 'mlt' is not defined

-------------------------------------------------------
Error:  OpenShot has not been installed in the Python path.
(Both the site-packages and /usr/share/openshot folders were checked)

Use the following command to install OpenShot:
  $ sudo python setup.py install

I'll stay with kdenlive, at least it was easy to install!

gapan 02-20-2010 12:23 PM

Did you also install mlt and all other dependencies? Seems like mlt is not installed.

metageek 02-20-2010 12:31 PM

Quote:

Originally Posted by gapan (Post 3870623)
Did you also install mlt and all other dependencies? Seems like mlt is not installed.

mlt is installed and I have kdenlive working well (also uses mlt). It seems that it is the python bindings for mlt that are a problem... I suspect these are installed by openshot's setup.py file that comes in openshot and which does not work properly in the slackbuild. I tried finding if there is some mlt-python package but this is not available anywhere (and also is not mentioned in SBo).

I would like to hear from anyone who *has* managed to install openshot using the slackbuild in SlackBuilds.org .

knudfl 02-20-2010 05:04 PM

Quote:

*** ERROR: MLT Python bindings failed to import ***
The idea is to build 'mlt' with the python bindings.
This seems not to happen.

> > Please have a look in this mlt.SlackBuild :
http://repository.slacky.eu/slackwar...mlt.SlackBuild
Quote:

mkdir -p $PKG/$PYTHONSITEPKG
cd src/swig/python
./build
install -m755 mlt.py $PKG/$PYTHONSITEPKG
install -m755 _mlt.so $PKG/$PYTHONSITEPKG
install -m755 mlt_wrap.o $PKG/$PYTHONSITEPKG )
Can also be done manually :
cd mlt-0.4.10
./configure --prefix=/usr/ --swig-languages=python
etc. etc.

.. And copying the python files ..
cd mlt-0.4.10/src/swig/python/
# cp mlt.py /usr/lib/python2.6/site-packages/
# cp _mlt.so /usr/lib/python2.6/site-packages/
# cp mlt_wrap.o /usr/lib/python2.6/site-packages/

Then the ""ERROR: MLT Python bindings failed to import"" disappears.
But I did not get openshot to work, may be you have more luck ! .. :)
.....

( I also installed 'libdv' (slacky.eu) as one of the dependencies.)
.....

P.S.: 'openshot' OK on other Linux, e.g. PCLinuxOS. ( python 2.5 ).
Also tried with python 2.5 on Slackware 13. No luck.
.....

BrZ 02-20-2010 08:56 PM

Try installing pyXDG...

knudfl 02-21-2010 04:51 AM

$ ls -tl /var/log/packages/ | head -30 > last-30--210210
$ < last-30--210210 cut -c 31- > last-30--210210-cut
Code:

2010-02-20 21:46 pyxdg-0.18-i486-1_SBo
 2010-02-20 21:28 (( python-2.5.2-i486-4 ))
 2010-02-20 20:31 requiredbuilder-0.16.4-noarch-1stb
 2010-02-20 20:20 mlt-0.4.10-i486-3_SBo
 2010-02-20 19:57 libdv-1.0.0-i486-3sl
 2010-02-20 19:33 mlt-0.4.0-i486-1as
 2010-02-20 19:24 openshot-1.0.0-i486-1_SBo
 2010-02-20 19:16 frei0r-20090913-i486-1as
 2010-02-20 19:12 opencv-2.0.0-i486-1ms
 2010-02-20 19:12 gavl-1.1.1-i486-1jm
 2010-02-20 19:04 goocanvas-0.15-i486-1as
 2010-02-20 19:04 pygoocanvas-0.14.1-i486-1as


metageek 02-21-2010 05:12 AM

Quote:

Originally Posted by knudfl (Post 3870863)
The idea is to build 'mlt' with the python bindings.
This seems not to happen.

Yes, this is the problem. I contacted the creator of the OpenShot slackbuild in SBo and he confirmed that the problem is in the mlt package in SBo which fails to build the python bindings. Apparently there is an update of the mlt slackbuild so as soon as this is approved everything should work.

Thanks everyone

knudfl 02-21-2010 06:18 AM

Back to python 2.6, rebuild mlt with alien.slack ffmpeg,
version 0.5 not working.
Rebuild openshot, with other found dependencies, ref. PCLinuxOS, etc. >
> libquicktime libsamplerate kdenlive libgsm wavpack

2010-02-21 10:45 openshot-1.0.0-i486-1_SBo
2010-02-21 10:31 libquicktime-1.1.3-i486-2sl
2010-02-21 10:30 libsamplerate-0.1.7-i486-2sl
2010-02-21 10:27 kdenlive-0.7.7-i486-1as
2010-02-21 10:18 ffmpeg-r20056-i486-1alien
2010-02-21 10:13 libgsm-1.0.13-i686-2as
2010-02-21 10:11 wavpack-4.41.0-i486-1

But still this error (only) :
""Error: OpenShot has not been installed in the Python path.
(Both the site-packages and /usr/share/openshot folders were checked)""
.....

BrZ 02-21-2010 10:11 AM

It is working here. Yesterday I went to upgrade kdenlive and the new mlt (0.5). Mlt was built with:

Quote:

CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--disable-debug \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--qimage-libdir=${QT4DIR}/qt/lib \
--qimage-includedir=${QT4DIR}/qt/include \
--enable-gpl \
--avformat-swscale \
--luma-compress \
--enable-motion-est \
--disable-mmx \
--avformat-ldextra="-lmp3lame -lfaad -lfaac -lxvidcore -lx264 -lvorbis -ltheora -lvorbisenc -logg -lbz2" \
--swig-languages=python \
--build=$ARCH-slackware-linux
and

Quote:

# Installing MLT Python bindings.
( PYTHONSITEPKG=$(python -c "import sys, os; print os.path.join('/usr/lib${LIBDIRSUFFIX}', 'python%s' % sys.version[:3], 'site-packages')")
mkdir -p $PKG/$PYTHONSITEPKG
cd src/swig/python
./build
install -m755 mlt.py $PKG/$PYTHONSITEPKG
install -m755 _mlt.so $PKG/$PYTHONSITEPKG
install -m755 mlt_wrap.o $PKG/$PYTHONSITEPKG )
When I went to '/usr/lib64/python2.6/site-packages/openshot' and executed 'python openshot.py' it blamed about xdg. When I installed the pyxdg libs it worked.

ps: Note that I have lame, faac, xvidcore, x264, vorbis and ogg. This settings (avformat-ldextra) came from http://www.mltframework.org/twiki/bi.../MLT/BuildTips for 64-bit.

Rod3775 01-01-2011 06:20 PM

As of 1/1/11, I ran into the following issues with this SlackBuild, and friends. The dependencies must be built with frei0r and possibly frei0r-plugins (for which there is no SlackBuild) before MLT. MLT will build without frei0r, but then openshot will complain about no frei0r effects. On my 486-based 13.1 distribution, the MLT SlackBuild required 'LDFLAGS='-lm -lz -lbz2 -lasound'" to work. The OpenShot Slackbuild puts "openshot" in /usr/bin, but openshot then can't find the python code since it's looking in for /usr/openshot, but the build places things in /usr/lib/python2.6/site-packages. The error message claims it looked there, but it's a lie. I added "parent-folder_path='/usr/lib/python2.6/site-packages'" after line 28 to replace the bogus search path. I also changed the error message after import failure near the end of the openshot script, since it is too specific. Failing to have goocanvas, MLT, pygoocanvas, etc will also cause this same error.


All times are GMT -5. The time now is 07:14 AM.