LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-04-2012, 10:35 PM   #1
padeen
Member
 
Registered: Sep 2009
Location: Perth, W.A.
Distribution: Slackware 14, Debian 7, FreeBSD, OpenBSD
Posts: 179

Rep: Reputation: 35
Anyone got kismet's ui working


I just installed kismet using the Slackbuilds script via sbopkg.

The display (ncurses) is completely unusable. Most of the screen is blank, but something is trying to display because hitting Tab highlights some fields which then disappear when I tab somewhere else.

I can't enter anything because kismet doesn't respond to Esc, or ~ or `.

I have to exit by Ctrl-C.

According to kismet's (minimal) docs, kismet should just build. mc (midnight commander) is working fine, so I'm pretty sure I've got a working ncurses library.

Anyone got kismet working on 13.37?
 
Old 03-05-2012, 12:49 AM   #2
coralfang
Member
 
Registered: Nov 2010
Location: Bristol, UK
Distribution: Slackware, FreeBSD
Posts: 289

Rep: Reputation: 77
Which terminal emulator are you using? (if running kismet through Xorg).

In some cases you need to do something like this:
Code:
TERM=xterm kismet
I had this problem using rvxt-unicode, passing TERM=xterm seems to fix it for me.
 
1 members found this post helpful.
Old 03-05-2012, 01:58 AM   #3
padeen
Member
 
Registered: Sep 2009
Location: Perth, W.A.
Distribution: Slackware 14, Debian 7, FreeBSD, OpenBSD
Posts: 179

Original Poster
Rep: Reputation: 35
Thank you. I am using xterm, but TERM is set to xterm-256color, so changing it to xterm fixed the problem.
 
  


Reply

Tags
13.37, kismet


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ubuntu 8.04 problem - kismet and/or aircrack not working on my hp 6830s neverone Linux - Software 0 01-15-2009 07:03 PM
kismet not working true_atlantis Linux - Software 1 05-30-2006 02:26 AM
Kismet not working correctly on Zaurus 5000D r0cky Linux - Wireless Networking 3 05-22-2005 01:04 PM
kismet not working merlin23 Linux - Wireless Networking 1 12-10-2004 01:00 PM
Kismet Problems :need help with kismet.conf source qbann Linux - Wireless Networking 6 04-26-2004 05:12 PM


All times are GMT -5. The time now is 07:17 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration