LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Anyone got Gwhere working on Slackware 14? (http://www.linuxquestions.org/questions/slackware-14/anyone-got-gwhere-working-on-slackware-14-a-4175433207/)

clifford227 10-20-2012 08:00 AM

Anyone got Gwhere working on Slackware 14?
 
Has anyone had success in building Gwhere 0.2.3 on Slack 14?

I get make errors.

disturbed1 10-20-2012 08:58 AM

Nasty, ugly hack
Code:

--- intl/Makefile.in.orig        2004-03-08 18:44:17.000000000 -0500
+++ intl/Makefile.in        2011-04-15 04:07:37.536000105 -0400
@@ -202,12 +202,6 @@
 # The dependency for intlh.inst is different in gettext and all other
 # packages.  Because we cannot you GNU make features we have to solve
 # the problem while rewriting Makefile.in.
-@GT_YES@intlh.inst: intlh.inst.in ../config.status
-@GT_YES@        cd .. \
-@GT_YES@        && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= \
-@GT_YES@          $(SHELL) ./config.status
-@GT_NO@.PHONY: intlh.inst
-@GT_NO@intlh.inst:

 # Tell versions [3.59,3.63) of GNU make not to export all variables.
 # Otherwise a system limit (for SysV at least) may be exceeded.

Be sure to use the --enable-gtk20 configure option, unless you wanted the GTK 1 interface.

clifford227 10-20-2012 10:25 AM

Quote:

Originally Posted by disturbed1 (Post 4810692)
Nasty, ugly hack
Code:

--- intl/Makefile.in.orig        2004-03-08 18:44:17.000000000 -0500
+++ intl/Makefile.in        2011-04-15 04:07:37.536000105 -0400
@@ -202,12 +202,6 @@
 # The dependency for intlh.inst is different in gettext and all other
 # packages.  Because we cannot you GNU make features we have to solve
 # the problem while rewriting Makefile.in.
-@GT_YES@intlh.inst: intlh.inst.in ../config.status
-@GT_YES@        cd .. \
-@GT_YES@        && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= \
-@GT_YES@          $(SHELL) ./config.status
-@GT_NO@.PHONY: intlh.inst
-@GT_NO@intlh.inst:

 # Tell versions [3.59,3.63) of GNU make not to export all variables.
 # Otherwise a system limit (for SysV at least) may be exceeded.


disturbed1,

Do you mean the hack is already in the code? I see this portion of code at the end of the gwhere/intl/Makefile.ini.

disturbed1 10-20-2012 10:41 AM

That's a patch that can be applied. It removes the offending code.

clifford227 10-20-2012 11:10 AM

disturbed1,

excuse my ignorance, but how do I apply the patch?


All times are GMT -5. The time now is 09:43 PM.