LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 03-10-2007, 02:12 AM   #1
bioe007
Member
 
Registered: Apr 2006
Location: lynnwood, wa - usa
Distribution: archlinux
Posts: 654

Rep: Reputation: 30
another wireless thread: Broadcom & Dell


Hi,

I have finally hunkered down and tried to configure the wireless card on my laptop (#1 in sig). I am running 2.6.20 on this machine and have lsmod:

Code:
Module                  Size  Used by
radeon                113824  1 
drm                    74524  2 radeon
snd_seq_dummy           4108  0 
snd_seq_oss            30336  0 
snd_seq_midi_event      7040  1 snd_seq_oss
snd_seq                46320  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          7820  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            39360  0 
snd_mixer_oss          16256  1 snd_pcm_oss
ipv6                  228448  14 
arc4                    2176  2 
ecb                     3712  2 
ieee80211_crypt_wep     5376  1 
af_packet              20488  2 
pcmcia                 35736  0 
snd_intel8x0           32064  0 
snd_ac97_codec         87460  1 snd_intel8x0
ac97_bus                2432  1 snd_ac97_codec
snd_pcm                67984  3 snd_pcm_oss,snd_intel8x0,snd_ac97_codec
snd_timer              22152  2 snd_seq,snd_pcm
snd                    48996  9 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer
bcm43xx               416576  0 
ieee80211softmac       28544  1 bcm43xx
b44                    25232  0 
snd_page_alloc          9864  2 snd_intel8x0,snd_pcm
ohci1394               33716  0 
serio_raw               7044  0 
ieee80211              31560  2 bcm43xx,ieee80211softmac
ieee1394               91868  1 ohci1394
ieee80211_crypt         6144  2 ieee80211_crypt_wep,ieee80211
I have tried edititing rc.wireless.conf:

Code:
# Generic example (decribe all possible settings)
*)
    INFO="Broadcom"
    # ESSID (extended network name) : My Network, any
    ESSID="Any"
    # NWID/Domain (cell identifier) : 89AB, 100, off
    NWID=""
    # Operation mode : Ad-Hoc, Managed, Master, Repeater, Secondary, auto
    MODE=""
    # Frequency or channel : 1, 2, 3 (channel) ; 2.422G, 2.46G (frequency)
    FREQ=""
    CHANNEL=""
    # Sensitivity (cell size + roaming speed) : 1, 2, 3 ; -70 (dBm)
    SENS=""
    # Bit rate : auto, 1M, 11M
    RATE="auto"
    # Encryption key : 4567-89AB-CD, s:password
    KEY="696c6f76656d696368656c6c65"        #not really my key, but if deciphered shows my true love :)
    # RTS threshold : off, 500
    RTS=""
    # Fragmentation threshold : off, 1000
    FRAG=""
    # Other iwconfig parameters : power off, ap 01:23:45:67:89:AB
    IWCONFIG=""
    # iwspy parameters : + 01:23:45:67:89:AB
    IWSPY=""
    # iwpriv parameters : set_port 2, set_histo 50 60
    IWPRIV=""
    ;;
esac
then I tried editing rc.inet1.conf:

Code:
## Example config information for wlan0.  Uncomment the lines you need and fill
## in your info.  (You may not need all of these for your wireless network)
IFNAME[4]="wlan0"
#IPADDR[4]=""
#NETMASK[4]=""
USE_DHCP[4]="yes"
#DHCP_HOSTNAME[4]="icculus-wireless"
#DHCP_KEEPRESOLV[4]="yes"
#DHCP_KEEPNTP[4]="yes"
#DHCP_KEEPGW[4]="yes"
#DHCP_IPADDR[4]=""
WLAN_ESSID[4]=LNXRLZ
#WLAN_MODE[4]=Managed
WLAN_RATE[4]="11M auto"
##WLAN_CHANNEL[4]="auto"
WLAN_KEY[4]="696c6f76656d696368656c6c65"                #not really my key, but if deciphered shows my true love :)
##WLAN_IWPRIV[4]="AuthMode=WPAPSK EncrypType=TKIP WPAPSK=7B1ABEEB5D197741923ED26727569C365E31212096A0EAFAD563B268BAD01CAF TxRate=0"
#WLAN_WPA[4]="wpa_supplicant"
#WLAN_WPADRIVER[4]="ndiswrapper"
I also d/l and install ndiswrapper 1.38 from source. Then copied bcmwl5.inf/.sys from winblow$ partition and run ndiswrapper -i bcmwl5.inf , then modprobe ndiswrapper, also checked with ndiswrapper -l.

All that seemed to go by the book.

Still I can not seem to get my wireless 'up'

Code:
root@hrgrv:/home/perry# ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:0B:DB:94:9F:F6  
          inet addr:192.168.2.2  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::20b:dbff:fe94:9ff6/64 Scope:Link
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2458 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2580 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2533087 (2.4 MiB)  TX bytes:462209 (451.3 KiB)
          Interrupt:11 

eth1      Link encap:Ethernet  HWaddr 00:90:4B:24:6E:5B  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:11 Base address:0xc000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:11 errors:0 dropped:0 overruns:0 frame:0
          TX packets:11 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:943 (943.0 b)  TX bytes:943 (943.0 b)
I am pretty much clueless, I tried following what I thought were pretty good guides: Wireless , more wireless.

I think I may be misunderstanding the basic ethernet utilities.

please help!

lspci (for broadcom controller)
Code:
02:03.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 02)
        Subsystem: Dell TrueMobile 1300 WLAN Mini-PCI Card
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 32
        Interrupt: pin A routed to IRQ 5
        Region 0: Memory at faff6000 (32-bit, non-prefetchable) [size=8K]
        Capabilities: [40] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=375mA PME(D0+,D1+,D2+,D3hot+,D3cold+)
                Status: D0 PME-Enable- DSel=0 DScale=2 PME-
?something useful from dmesg:
Code:
ACPI: PCI Interrupt 0000:02:00.0[A] -> Link [LNKC] -> GSI 11 (level, low) -> IRQ 11
eth0: Broadcom 4400 10/100BaseT Ethernet 00:0b:db:94:9f:f6
bcm43xx driver
ACPI: PCI Interrupt 0000:02:03.0[A] -> Link [LNKB] -> GSI 5 (level, low) -> IRQ 5
bcm43xx: Chip ID 0x4306, rev 0x2
bcm43xx: Number of cores: 6
bcm43xx: Core 0: ID 0x800, rev 0x2, vendor 0x4243
bcm43xx: Core 1: ID 0x812, rev 0x4, vendor 0x4243
bcm43xx: Core 2: ID 0x80d, rev 0x1, vendor 0x4243
bcm43xx: Core 3: ID 0x807, rev 0x1, vendor 0x4243
bcm43xx: Core 4: ID 0x804, rev 0x7, vendor 0x4243
bcm43xx: Core 5: ID 0x812, rev 0x4, vendor 0x4243
bcm43xx: Ignoring additional 802.11 core.
bcm43xx: PHY connected
bcm43xx: Detected PHY: Version: 1, Type 2, Revision 1
bcm43xx: Detected Radio: ID: 2205017f (Manuf: 17f Ver: 2050 Rev: 2)
bcm43xx: Radio turned off
bcm43xx: Radio turned off
yes, i did try hitting the 'fn+wireless' keys
 
Old 03-10-2007, 07:57 AM   #2
masonm
Senior Member
 
Registered: Mar 2003
Location: Following the white rabbit
Distribution: Slackware64 13.37 Android 4.0
Posts: 2,248

Rep: Reputation: 46
What is the output of iwconfig?

One thing to note, if you're going to use ndiswrapper you need to blacklist the bcm43xx module so that it doesn't load. This will avoid conflicts. I had to do that in order to get mine to work.

Last edited by masonm; 03-10-2007 at 07:58 AM.
 
Old 03-10-2007, 08:06 AM   #3
bioe007
Member
 
Registered: Apr 2006
Location: lynnwood, wa - usa
Distribution: archlinux
Posts: 654

Original Poster
Rep: Reputation: 30
After all that, there had to be something I left out

Code:
root@hrgrv:/home/perry# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      IEEE 802.11b/g  ESSID:""  Nickname:"hrgrv"
          Mode:Managed  Frequency=2.437 GHz  Access Point: Invalid   
          Bit Rate=1 Mb/s   
          RTS thr:off   Fragment thr:off
          Encryption key:XXXX-XXXX-XXXX-XXXX-XXXX-XX   Security mode:restricted
          Link Quality=0/100  Signal level=-256 dBm  Noise level=-256 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
Quote:
Originally Posted by masonm
going to use ndiswrapper you need to blacklist the bcm43xx module
well, I havent blacklisted it yet, but i did:
Code:
# rmmod bcm43xx
# modprobe ndiswrapper
# sh /etc/rc.d/rc.inet1
/etc/rc.d/rc.inet1:  wlan0 is 'Broadcom'
dhcpcd: MAC address = 00:90:4b:24:6e:5b

#iwconfig
root@hrgrv:/home/perry# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11g  ESSID:off/any  Nickname:"hrgr"
          Mode:Managed  Frequency:2.462 GHz  Access Point: Not-Associated   
          Bit Rate=54 Mb/s   Tx-Power:32 dBm   
          RTS thr=2347 B   Fragment thr=2346 B   
          Encryption key:696C-6F76-656D-6963-6865-6C6C-65   Security mode:restricted
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
btw- Does it matter that both the eth0 & eth1/wlan0 share IRQ11 ?

I see in this thread there was some mention about IRQ conflicts (but I don't see that, other than they are sharing one). A total n00b question generated from that thread is I see the wlan module - but I don't have any wlan module.

Should I bring eth0 down & wlan0 up? (read: how do I take one down and the other up?)

many thanks!

Last edited by bioe007; 03-10-2007 at 08:32 AM.
 
Old 03-10-2007, 08:13 AM   #4
XGizzmo
Member
 
Registered: Mar 2007
Distribution: Slackware
Posts: 264

Rep: Reputation: 68
I would turn off wep and wpa to start off with. get your card working then turn them on one at a time.
iwconfig is what is used to set up wireless cards, also make sure /etc/rc.d/rc.wireless is executable.
With wep and wpa off then "iwconfig wlan0 essid <your essid> && dhcpcd wlan0" should get you up.
Once you get going without wep and wpa I would then get wep working and finally get wpa going.
Basicly work one problem at a time.

Last edited by XGizzmo; 03-10-2007 at 08:21 AM.
 
Old 03-10-2007, 08:15 AM   #5
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
From the looks of your lsmod, you're using the bcm43xx driver (by the way mansonm is very right about conflicts between bcm43xx and ndiswrapper, you can't have both loaded at the same time). Did you install firmware for the bcm43xx driver? To do that you need a program called fwcutter and a Windows driver, preferably wl_apsta.o. I've got instructions on how to install firmware on my help site (link in sig).
 
Old 03-10-2007, 08:53 AM   #6
bioe007
Member
 
Registered: Apr 2006
Location: lynnwood, wa - usa
Distribution: archlinux
Posts: 654

Original Poster
Rep: Reputation: 30
Quote:
the way mansonm is very right about conflicts between bcm43xx and ndiswrapper
aye... I have rmmod bcm43xx followed by modprobe ndiswrapper.

Quote:
Did you install firmware for the bcm43xx driver?
i did not.

the driver I used (for ndiswrapper) was bcmwl5.inf/.sys

Quote:
turn off wep and wpa
I just did that. Then I commented out the 'KEY="...' lines in rc.wireless.conf and rc.inet1.conf

what my current lsmod is:
Code:
Module                  Size  Used by
ndiswrapper           172584  0 
radeon                113824  1 
drm                    74524  2 radeon
snd_seq_dummy           4108  0 
snd_seq_oss            30336  0 
snd_seq_midi_event      7040  1 snd_seq_oss
snd_seq                46320  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          7820  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            39360  0 
snd_mixer_oss          16256  1 snd_pcm_oss
ipv6                  228448  14 
arc4                    2176  0 
ecb                     3712  0 
ieee80211_crypt_wep     5376  0 
af_packet              20488  2 
pcmcia                 35736  0 
snd_intel8x0           32064  0 
snd_ac97_codec         87460  1 snd_intel8x0
ac97_bus                2432  1 snd_ac97_codec
snd_pcm                67984  3 snd_pcm_oss,snd_intel8x0,snd_ac97_codec
snd_timer              22152  2 snd_seq,snd_pcm
snd                    48996  9 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer
ieee80211softmac       28544  0 
b44                    25232  0 
snd_page_alloc          9864  2 snd_intel8x0,snd_pcm
ohci1394               33716  0 
serio_raw               7044  0 
ieee80211              31560  1 ieee80211softmac
ieee1394               91868  1 ohci1394
ieee80211_crypt         6144  2 ieee80211_crypt_wep,ieee80211

Last edited by bioe007; 03-10-2007 at 08:55 AM.
 
Old 03-10-2007, 08:59 AM   #7
bioe007
Member
 
Registered: Apr 2006
Location: lynnwood, wa - usa
Distribution: archlinux
Posts: 654

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by XGizzmo
iwconfig wlan0 essid <your essid> && dhcpcd wlan0
I tried that...
Code:
root@hrgrv:/home/perry# iwconfig wlan0 essid LNXRLZ && dhcpd wlan0
Internet Systems Consortium DHCP Server V3.0.5rc2
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

** You must add a global ddns-update-style statement to /etc/dhcpd.conf.
   To get the same behaviour as in 3.0b2pl11 and previous
   versions, add a line that says "ddns-update-style ad-hoc;"
   Please read the dhcpd.conf manual page for more information. **
exiting.

Last edited by bioe007; 03-10-2007 at 01:22 PM.
 
Old 03-10-2007, 09:25 AM   #8
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Quote:
dhcpd wlan0
You've got a syntax error there. The command you have (dhcpd) is a DHCP server. You want to be running a DHCP client (dhcpcd). Note that extra c between the p and the d, its is VERY important.

I would also run these as two steps for now. First verify that iwconfig is in fact setting the SSID correctly and that you are associated with your access point. Then request the IP address.
 
Old 03-10-2007, 01:28 PM   #9
bioe007
Member
 
Registered: Apr 2006
Location: lynnwood, wa - usa
Distribution: archlinux
Posts: 654

Original Poster
Rep: Reputation: 30
thanks for fixing my syntax. I'm not exactly sure what to check, but heres what I'm doing now:

Code:
root@hrgrv:/home/perry# sh /etc/rc.d/rc.inet1
/etc/rc.d/rc.inet1:  wlan0 is 'Broadcom'
dhcpcd: MAC address = 00:90:4b:24:6e:5b
root@hrgrv:/home/perry# iwconfig wlan0 essid LNXRLZ
root@hrgrv:/home/perry# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11g  ESSID:off/any  Nickname:"hrgr"
          Mode:Managed  Frequency:2.462 GHz  Access Point: Not-Associated   
          Bit Rate=54 Mb/s   Tx-Power:32 dBm   
          RTS thr=2347 B   Fragment thr=2346 B   
          Encryption key:696C-6F76-656D-6963-6865-6C6C-65   Security mode:restricted
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

root@hrgrv:/home/perry#
which is a bit weird, because as above - I had thought I'd turned off the key option. Also 54MBits I've never seen out of the dell truemobile 1300 (max is like 11M) && you're right its not setting the ssid correctly. ???

*ed* I just verified all the 'KEY=' lines in rc.inet1.conf and rc.wireless.conf are commented out. And my router's wep is turned off.

+Q: not to belabor the point, but do I need the wlan module? I just tried /wlan in my .config and did not find it.

Last edited by bioe007; 03-10-2007 at 01:40 PM.
 
Old 03-10-2007, 02:14 PM   #10
bioe007
Member
 
Registered: Apr 2006
Location: lynnwood, wa - usa
Distribution: archlinux
Posts: 654

Original Poster
Rep: Reputation: 30
update:

Code:
root@hrgrv:/home/perry# ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:0B:DB:94:9F:F6  
          inet addr:192.168.2.2  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::20b:dbff:fe94:9ff6/64 Scope:Link
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1351 errors:1 dropped:1 overruns:0 frame:0
          TX packets:1223 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1492812 (1.4 MiB)  TX bytes:212467 (207.4 KiB)
          Interrupt:11 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:65 errors:0 dropped:0 overruns:0 frame:0
          TX packets:65 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:6107 (5.9 KiB)  TX bytes:6107 (5.9 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:90:4B:24:6E:5B  
          inet addr:192.168.2.3  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::290:4bff:fe24:6e5b/64 Scope:Link
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:7 errors:0 dropped:0 overruns:0 frame:0
          TX packets:27 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:914 (914.0 b)  TX bytes:7164 (6.9 KiB)
          Interrupt:5 Memory:faff6000-faff8000 

root@hrgrv:/home/perry#
so in summary:

1.installed ndiswrapper
2.copied bcmwl5.inf and bcmwl5.sys to /usr/src/broadcom
3.ndiswrapper -i bcmwl5.inf
4.blacklisted bcm43xx in /etc/modprobe.d/blacklist
5.reboot
6.modprobe ndiswrapper
7.iwconfig wlan0 essid LNXRLZ
8. dhcpcd wlan0

the above is as much for my own documentation purposes (don't have my 'nix diary right here) but also I hope it helps someone else in the future.

greatly appreciate everyone's help.

I will do some more reading about WEP and WPA. I'm not sure how to tell if my router even supports WPA though, it is pretty old.

A quickie- I can't remember where to put 'modprobe ndiswrapper' to load it on startup. I checked /etc/rc.d/rc.modules - most of mine is commented out. Should I just add it there?

thanks again. this is why i like linux and _LOVE_ slackware.
 
Old 03-10-2007, 02:32 PM   #11
masonm
Senior Member
 
Registered: Mar 2003
Location: Following the white rabbit
Distribution: Slackware64 13.37 Android 4.0
Posts: 2,248

Rep: Reputation: 46
Yes, listing it in rc.modules will ensure it's loaded at boot.

Also, do a ndiswrapper -m if you haven't already.
 
Old 03-10-2007, 02:56 PM   #12
bioe007
Member
 
Registered: Apr 2006
Location: lynnwood, wa - usa
Distribution: archlinux
Posts: 654

Original Poster
Rep: Reputation: 30
Quote:
do a ndiswrapper -m
thanks! I didn't know about that option.

it is working on bootup now
 
Old 03-11-2007, 04:16 AM   #13
bioe007
Member
 
Registered: Apr 2006
Location: lynnwood, wa - usa
Distribution: archlinux
Posts: 654

Original Poster
Rep: Reputation: 30
another update && question:

just for s&g's I decided to go back and try the bcm43xx module. since I now know the proper way to bring up wlan0.

all i did was rmmod ndiswrapper and modprobe bcm43xx and wlan0 went down/up. (i.e. its up and working now with bcm43xx)

is there any reason for me to be using ndiswrapper? I'd rather not taint my slackware with windows stuff if not needed.

thanks!
 
Old 03-11-2007, 09:06 AM   #14
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Quote:
is there any reason for me to be using ndiswrapper? I'd rather not taint my slackware with windows stuff if not needed.
In my experience, bcm43xx has been a tad too buggy for me to rely on for sole use. At least on my laptop, it has a tendency to lock up under heavy loads (like when I'm using rsync to back up directories). It is also limited to 802.11b speeds (11M), so if you need faster, bcm43xx isn't an option.

Now that said, for light duty work (surfing/email) it seems to work just fine and the 4306 chipset is better supported than most. Considering that the bmc43xx is reverse engineering this beasty without even the slightest hint of help from Broadcom, it is mighty impressive work.
 
Old 03-13-2007, 05:02 PM   #15
Blackmeth
LQ Newbie
 
Registered: Dec 2006
Posts: 13

Rep: Reputation: 0
im getting a

root@darkstar:/usr/src/ndiswrapper-1.38# ndiswrapper -l
bcmwl5 : invalid driver!
bcmwl5.sys : invalid driver!

im using the same drivers that i got to work on fedora 6 so i know there right...

any ideas?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dell Wireless 1500 / Broadcom 4328...almost there spaceballs Linux - Wireless Networking 8 05-12-2007 05:32 PM
Another thread about Dell Wireless not working Lunch_Box1973 Linux - Wireless Networking 1 02-22-2007 05:20 PM
WPA with Dell Wireless 1500 (Broadcom 4328) semtex Linux - Wireless Networking 13 02-13-2007 08:06 AM
WPA with Dell Wireless 1500 (Broadcom 4328) semtex Linux - Wireless Networking 2 01-09-2007 04:24 PM
Broadcom 1400 Wireless G NIC in Dell 8500 jgrover Linux - Wireless Networking 3 03-01-2004 02:29 PM


All times are GMT -5. The time now is 02:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration