LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 10-05-2006, 03:28 AM   #1
snakle
LQ Newbie
 
Registered: Oct 2006
Posts: 14

Rep: Reputation: 0
Another Slackware network prob


Sorry for making another post about this but after searching/reading I still can't get it to work.
It didn't work out of the install, so in the console I first tried "netconfig"

I went through that... didn't work(tried setting domain to router's ip, also always set it to dhcp)

next I ran these two commands
ifconfig eth0 up
dhcpcd eth0
after running ifconfig eth0 up eth0 showed up in ifconfig rather than just ifconfig -a
but when i ran dhcpcd eth0 it stalled

next I went into rc.inet1.conf and tried changing the gateway to my router's ip... lol still didnt work

umm I guess I don't know what to do now, I'm pretty new at Slackware tbh, I'm using the ethernet port from my nf4 dfi lanparty ultra-d. Anyway, I wanted something more challenging than Kubuntu, guess I found it, heh. Anyway's thanks in advance for the help.
 
Old 10-05-2006, 08:45 AM   #2
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Rep: Reputation: 62
hiya

I have to go to bed, but your post leaves me with a few questions about your issue, that hopefully the info you give me here will help me or others get you going

what version of slackware did you install?

what kernel are you using?

does that motherboard have one or more network cards?

does your router assign IP addresses, aka dhcp server, or do you have to manually assign IP addresses to the pc's normally?

As a side note: sometimes router's crash. It may not be a bad idea to power off the router and let it sit off for about a minute or two then power it back on. not sure if you have cable or dsl, and if they go off before the router or after, that depends on what you have, just thought I'd throw that out there.
 
Old 10-05-2006, 09:36 AM   #3
hosler
Member
 
Registered: Mar 2005
Distribution: Gentoo
Posts: 181

Rep: Reputation: 30
Set eth0 to use DHCP in rc.inet1.conf. Then run this command:
/etc/rc.d/rc.inet1 restart
 
Old 10-05-2006, 11:26 AM   #4
snakle
LQ Newbie
 
Registered: Oct 2006
Posts: 14

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by hosler
Set eth0 to use DHCP in rc.inet1.conf. Then run this command:
/etc/rc.d/rc.inet1 restart
I just tried that... dhcp was already set to "yes" and when I run the command it basically just stalls after it prints the mac address...

to answer old_fogie:
I did a full install of slackware 11
the default one I guess? (I don't think there was an option to install 2.6 on this install so I guess I'm using 2.4)

The motherboard has two ethernet ports, but like only one is used for the internet
# Dual Gigabit LAN - Vitesse VSC8201 Gigabit Phy and Marvell 88E8001 Gigabit PCI
# Fully compliant to IEEE 802.3 (10BASE-T), 802.3u (100BASE-TX) and 802.3ab (1000BASE-T) standards
is what it says on the motherboard website for LAN

yes the router is DHCP
and not sure about the whole router crashing as I've been rebooting switching back and forth from linux to windows a bunch and I can still connect on Windows
 
Old 10-05-2006, 11:45 AM   #5
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,397

Rep: Reputation: Disabled
If you have two ethernet cards, are you sure you're plugged the cable into eth0 and not eth1?

Edit the file
Code:
/etc/udev/rules.d/network-devices.rules
and remove the comment characters '#' from the start of the lines there. Then check that the name "eth0" correlates with the MAC address of the network interface you're using. If needed, swap the names eth0 and eth1 there and save the file. Then reboot. Afterwards, eth0 will always be assigned to the proper interface.

Eric
 
Old 10-05-2006, 11:51 AM   #6
snakle
LQ Newbie
 
Registered: Oct 2006
Posts: 14

Original Poster
Rep: Reputation: 0
Does it matter that when I run "ifconfig -a" eth0 shows up? wouldnt that mean that it's in the right one? When I run "ifconfig" only lo shows up though... unless I run it like right after "ifconfig eth0 up" but it normally doesn't stay like that after trying "/etc/rc.d/rc.inet1 restart" or whatever

also, what's the easiest way to find out the mac address? other than failing to run the command "dhcpcd eth0"?
 
Old 10-05-2006, 01:18 PM   #7
snakle
LQ Newbie
 
Registered: Oct 2006
Posts: 14

Original Poster
Rep: Reputation: 0
haha umm.... there is no
/etc/udef/rules.d/network-devices.rules for me...

during the installation of slackware I selected "no modem" (modem is only for 56k right?)
either way I still duno where to go from here, cuz netconfig hasn't helped, dhcpcd eth0 stalls every time and I can't find that file alien bob told me to find
 
Old 10-05-2006, 02:11 PM   #8
hosler
Member
 
Registered: Mar 2005
Distribution: Gentoo
Posts: 181

Rep: Reputation: 30
I would go ahead and try to setup a static address for your system. Sounds to me like you are just having dhcp problems.
 
Old 10-05-2006, 03:04 PM   #9
snakle
LQ Newbie
 
Registered: Oct 2006
Posts: 14

Original Poster
Rep: Reputation: 0
the dhcp works in windows... I guess that's no excuse, but I still duno why it wouldn't work

edit: I probably did something wrong on the install, but I don't think it asked me to probe for a network device. I think that's why I don't have a rc.netdevices or network-devices.rules

is that what's wrong? should I
a. re-install slackware
b. (i have no idea)
c. if it requires recompiling the kernel, I've never done that before, but I could try.

Last edited by snakle; 10-05-2006 at 03:52 PM.
 
Old 10-05-2006, 04:14 PM   #10
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Rep: Reputation: 62
Hi all,

Sorry to see you're still battling this. My post is long here as I give you some extra info, sorry just trying to really explain is all, if anything much of it should confirm some things for you. I know trouble shooting can be a pain.

I went over to tigerdirect to look at your motherboard a little more, so you have (2) physical nic's according to this page here (it's a shopping site, but they've always been good to me :X) and they have really good picture's, better than dfi's site for your board. A pic is worth a thousand words right...:

http://www.tigerdirect.com/applicati...&sku=D452-2030

Now I have not had a chance to do a 2.4.33 install of slack11 yet, and try the internet out. However, I too have (2) network cards built into my motherboard.

Now, from slackware's site:
Quote:
As an alternate choice, Slackware 11.0 includes Linux 2.6.17.13
and 2.6.18 kernel source, kernel modules, and binary packages,
along with the mkinitrd tool and instructions on using it to
install the new kernel (see /boot/README.initrd). When running a
2.6 kernel, Slackware supports udev. This is a system for
creating devices in /dev dynamically, greatly reducing device
clutter and making it easy to see what devices are actually
present in the system. Udev probes for and enables hardware on
the system, much like the hotplug system does for a 2.4 kernel.


Now I'm not sure of this, but I think the part of Alien Bob's post there that you look for the udev rule, does NOT apply? As you're using a 2.4 kernel, so if 2.4 then no UDEV? Can someone confirm this. I do know that what Alien Bob said is exactly what I had to do to get my motherboard to work w/huge 2.6. Ironically I had no problem for about 10 reboots, then all of the sudden my network just dropped out and I had to do that.

However, I did not see if you tried the other part of Alien Bob's post there which is are you sure you plugged into eth0 or eth1. In case you missed that I think what he's saying, is to plug it into one port boot up, run 'ifconfig' to see which ethX is running, and then try the internet out. If that doesn't work trying the other port and seeing how that goes following same manner.

Basically, your /etc/rc.d/rc.inet1.conf file store's all of your settings that you input into netconfig. There is also /etc/resolv.conf and that store's the 'nameserver' which is your router's IP address. Then there is 'hostname'which is the pc's name.

You were fine to use 'no modem' if you do not choose to use a modem for your internet BTW.

I can tell you that I too think that if you're using a router, you probably are better off to use a static IP address, slightly faster boot process and if you have a lan, everything works a little cleaner, well that's an opinion I know but you get my drift.

If you're not sure of your router's IP address, in windows xp you just type at the run command in start menu, 'cmd' that brings up a terminal window in Windows, then type 'ipconfig' that will list all of your network cards info. The "Default Gateway ....192.168.x.x" is your router's IP address. That is the number you put into 'netconfig' of linux as your 'gateway' and your 'nameserver (a.k.a. DNS server)'. Many router's let you manually key in an IP address into a PC, even tho the router is setup for DHCP (that is assigns IP addresses to the computer). Just be sure to pick an IP address out when you run 'netconfig' in linux that you do NOT pick a number of a pc that is currently in use. You actually might like to use this forced IP so you can forward incoming network traffic to the pc easily, set it up once and forget it. It helps for bittorrent to seed slack 11 to others , gaming, instant messaging, etc. DHCP is crude IMO and leads to chaos. It's nice for when you have a friend run over and plug-in, but for the usual pc's plugged in go with manual.

Now that motherboard is an nforce 4 motherboard. I suspect that maybe you would be better off to install slackware with a 2.6 kernel.

See,..nvidia has released a lot of info out to the kernel team for that motherboard, it's a recent chipset, so coding for it would be in the 2.6.X series kernels and not 2.4X

Now that may not be needed for this issue of your lan, but you're agp, all the other feature's for sure, I think you really need that 2.6 kernel to be honest.

Now before you just run out and install 2.6 kernel (which is Ultimately what I think you need to do here) what file system type did you use to install slack 11? Ext3? Reiser? Please advise as you may or may not need to make an initrd to use 2.6 kernel.

if you want you can mail me that board and let me run it or a few weeks and I'll test it I'm jealous that's a nice board.

To clarify, when you run 'ifconfig' that just shows you what adapter's are up at the time.

Also, if you run 'lspci' and 'lsmod' that tells you alot of information about what devices are seen, and what modules are running at the time. Or if you still have kubuntu installed you can boot up there and run those commands using sudo and see what you get.

lastly, I think every slacker should have a slax cd in their arsenal. it really helps out alot, you can run that cd and use those commands there too, slax runs a 2.6x kernel and is based on a snapshot of slack 10.2's current now known as 11 if i'm not mistaken.
 
Old 10-05-2006, 04:21 PM   #11
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Rep: Reputation: 62
One last point of mention about /etc/resolv.conf

let's say you make your pc name 'snaklesPC' and the domain 'myhouse'

I've noticed in slack 10.2 and 11 that in the /etc/resolv.conf there would be something like this:
search myhouse
192.168.xxx.xxx

I found that commenting out the line that has 'search...' and then rebooting takes care of DHP issues FWIW.

The fact that your DHCP hangs tells me either modules are not loaded (wrong kernel), you plugged into the wrong ethernet port, or that search line.
 
Old 10-05-2006, 04:32 PM   #12
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,397

Rep: Reputation: Disabled
If you have multiple network interfaces, say eth0 and eth1, try running
Code:
ethtool eth0
ethtool eth1
and look at which of the two commands produces "link detected" in it's output. If eth1 reports "link detected", then either plug the network cable into the other port, or edit the configfile /etc/rc.d/rc.inet1.conf and transfer all values for eth0 (the XXXXX[0]="yyy" variables) to those for eth1 (the empty XXXXX[1]="" variables).

Then run
Code:
/etc/rc.d/rc.inet1 restart
Eric
 
Old 10-05-2006, 07:34 PM   #13
Shade
Senior Member
 
Registered: Mar 2003
Location: Burke, VA
Distribution: RHEL, Slackware, Ubuntu, Fedora
Posts: 1,418
Blog Entries: 1

Rep: Reputation: 46
As a side note, you've tried just plugging the network cable into the other port, right?
 
Old 10-05-2006, 07:42 PM   #14
snakle
LQ Newbie
 
Registered: Oct 2006
Posts: 14

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Shade
As a side note, you've tried just plugging the network cable into the other port, right?
ha...ha... I actually was trying that as you wrote this. i ran "ethtool eth0" and it said link not detected and then I ran "ethtool eth1" and it gave me some weird errors. I plugged the ethernet cord into the other port and viola. I'm typing this on slackware right now lol...

I guess I figured that I had to use the other port cause windows doesn't recognize this port (I think that may be because they are 2 seperate cards on the same mobo or something like that and I have 1 driver for it.)

I'm really sorry that I didn't try that before, I guess I did but I never actually rebooted. Anyway I think I'll try upgrading the kernel to 2.6 soon. I'm using ext2 I think(the standard linux one)
 
Old 10-06-2006, 12:42 AM   #15
anakin
LQ Newbie
 
Registered: Feb 2006
Location: Tirnaveni, Romania
Distribution: Slackware 12.2 (current)
Posts: 24

Rep: Reputation: 15
Hey ! Can anyone help me with the problem I'm experiencing ??? It's weird...
I have 2 ethernet cards, they were detected as eth0 and eth1, so far no problem.But it happenes that every 3-4 boots they're reversed...I mean eth0 becomes eth1 and vice-versa...and I don't know what the hell is that I haven't got that problem so far...only in slack 11. When eth0 becomes eth1, I have to edit my /etc/rc.d/rc.inet1.conf and after that it works well for 3-4 boot times and then again.Can anyone tell me what's wrong with it ?Is it a bug or what ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
network prob. saosurya Red Hat 1 08-03-2005 10:37 AM
network prob enrique_arong Linux - Networking 7 03-07-2005 03:42 PM
Slackware Network prob...Close to solving TCasp77 Slackware 12 02-27-2004 10:37 PM
network prob vhs Linux - Networking 1 11-21-2002 01:20 AM
Network prob. Druaga Slackware 3 09-23-2002 03:24 PM


All times are GMT -5. The time now is 06:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration