LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-18-2011, 12:40 AM   #1
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,060

Rep: Reputation: 45
amixer: Mixer attach hw:0 error: No such device.


Kernel 2.4.22, slackware 9.1

Hi:
With slack 9.1 just installed, I ran

/usr/bin/amixer -c 0 sset PCM,0 100%,100% unmute nocap

and I got

amixer: Mixer attach hw:0 error: No such device.

Quite a pity cause the installer (or whatever it was) put the volume very low. Alsamixer there is not, and I do not need it if I can use amixer. The absent device is hw? I know of plughw... Well, I know nothing. Im only asking what is the matter?
 
Old 09-20-2011, 09:38 AM   #2
cladisch
Member
 
Registered: Oct 2008
Location: Earth
Distribution: Slackware
Posts: 227

Rep: Reputation: 54
Check in /proc/asound/cards if the driver is loaded and if the card is at index 0.
 
Old 09-21-2011, 11:36 AM   #3
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,060

Original Poster
Rep: Reputation: 45
Thanks for your post. After much messing around, I now know kernel 2.4.22 (slack 9.1) has no ALSA support built in the kernel. What I did, rereading a recent thread created by me, was to run alsaconfig. But this is because I now have used to the idea of using ALSA instead of OSS. However, the ease with which alsaconf settled things surprised me. And I can now use amixer, arecord and aplay, basic level as I like.

The prefix 'a' in 'amixer' gave me the key to understand it is an ALSA application and could not proporly run under OSS. Regards.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
amixer attach default error - no such file or directory kite10linux Linux - Software 5 11-24-2009 10:16 PM
Sound Blaster Audigy LS Problem - "Mixer attach default error: Invalid argument" corporal79 Linux - Hardware 3 03-27-2007 01:09 AM
amixer: Mixer attach default error: No such device fof3 Linux - Newbie 0 07-17-2005 11:07 AM
amixer: Mixer attach default error: No such device minaspirit Linux - Hardware 0 10-20-2004 08:27 AM
amixer alsamixer I don't have a mixer lackluster Linux - Newbie 6 06-23-2002 02:36 AM


All times are GMT -5. The time now is 03:45 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration