LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   AMD Catalyst proprietary graphics driver kills my X stone dead (http://www.linuxquestions.org/questions/slackware-14/amd-catalyst-proprietary-graphics-driver-kills-my-x-stone-dead-4175461397/)

bogzab 05-10-2013 03:30 AM

AMD Catalyst proprietary graphics driver kills my X stone dead
 
Slackware 14.0 on Thinkpad Edge with AMD processor and AMD/ATI graphics. lspci tells me that the graphics adapter is a Mobility Radeon HD4200 series device. I downloaded the appropriate amd driver from their website by mkaing explicit choices for this device.

X works fine with the Xorg radeon driver except that the HDMI port provides video but no audio. I thought that using the catalyst driver might solve this annoyance and followed the very clear instructions here: http://docs.slackware.com/howtos:har...aphics_drivers.

All seemed to work - ie the fglrx slackware package got built, I installed that package and ran the
Code:

aticonfig --initial
command which generated an xorg.conf file containing references to the new display driver. I blacklisted the Xorg modules as advised.

However on re-starting the PC "startx" kills everything. Black screen, dead keyboard, dead mouse. Only the power button restores sanity.

I have reverted to the Xorg drivers and all is working fine again - but can anybody suggest what trick I may be missing?

Thanks

pan64 05-10-2013 04:09 AM

you need to be sure you have not mixed the libs, files or anything. You must be sure you have a clean and complete install. Probably you can check the Xorg log file about details.

zakame 05-10-2013 04:25 AM

HDMI audio is supplied by the radeon driver. Be sure to set "radeon.audio=1" in your kernel command line (in /etc/lilo.conf).

bogzab 05-10-2013 04:56 AM

Quote:

Originally Posted by zakame (Post 4948417)
HDMI audio is supplied by the radeon driver. Be sure to set "radeon.audio=1" in your kernel command line (in /etc/lilo.conf).

When I used the radeon driver (without setting the above kernel parameter) and tried playing sound through HDMI with an "aplay" command, it behaved like it was working (no error messages) but no sound emerged. When I booted with the additional radeon.audio=1 parameter the result was a notification - ALSA reported that the HDMI audio device was not working... I entered the parameter on boot-up rather than in the lilo.conf file - that should not make a difference?

chemfire 05-10-2013 06:42 AM

run

aplay -l

It may be that you have multiple sound devices. Usually HDMI audio is not device 0. You probably just need to edit you .asoundrc file and make whatever device the HDMI is your default.

bogzab 05-10-2013 09:04 AM

Quote:

Originally Posted by chemfire (Post 4948473)
run

aplay -l

It may be that you have multiple sound devices. Usually HDMI audio is not device 0. You probably just need to edit you .asoundrc file and make whatever device the HDMI is your default.

I did that already - that's how I knew which device to try and play through, so that my test was
Code:

aplay -D<devicename> <filename>
and that's what gave the results as described above. I also modified the .asoundrc file to prioritise the HDMI device but that made no difference either.


All times are GMT -5. The time now is 02:19 AM.