LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   amavisd-new & clamav socket permissions (http://www.linuxquestions.org/questions/slackware-14/amavisd-new-and-clamav-socket-permissions-4175463310/)

NetNightmare 05-24-2013 08:23 AM

amavisd-new & clamav socket permissions
 
Hello guys,

I could use the help of some extra eyes here , since I'm surely missing something obvious , I installed amavisd-new & clamav from Sbo ( on slack x64 14 ) and I m hitting this problem :

Code:

May 24 14:33:43 mail amavis[2777]: (02777-03) (!)connect to /var/run/clamav/clamd.socket failed, attempt #1: Can't connect to UNIX socket /var/run/clamav/clamd.socket: No such file or directory
May 24 14:33:44 mail amavis[2777]: (02777-03) (!)connect to /var/run/clamav/clamd.socket failed, attempt #1: Can't connect to UNIX socket /var/run/clamav/clamd.socket: No such file or directory
May 24 14:33:44 mail amavis[2777]: (02777-03) (!)Clam Antivirus-clamd: All attempts (1) failed connecting to /var/run/clamav/clamd.socket, retrying (2)
May 24 14:33:50 mail amavis[2777]: (02777-03) (!)connect to /var/run/clamav/clamd.socket failed, attempt #1: Can't connect to UNIX socket /var/run/clamav/clamd.socket: No such file or directory
May 24 14:33:50 mail amavis[2777]: (02777-03) (!)Clam Antivirus-clamd av-scanner FAILED: run_av error: Too many retries to talk to /var/run/clamav/clamd.socket (All attempts (1) failed connecting to /var/run/clamav/clamd.socket) at (eval 131) line 600.\n
May 24 14:33:50 mail amavis[2777]: (02777-03) (!)WARN: all primary virus scanners failed, considering backups
May 24 14:33:50 mail amavis[2777]: (02777-03) (!!)AV: ALL VIRUS SCANNERS FAILED

now I checked the following
Code:

root@mail:/etc/httpd/extra# id clamav
uid=210(clamav) gid=210(clamav) groups=210(clamav),255(amavis)

root@mail:/etc/httpd/extra# id amavis
uid=255(amavis) gid=255(amavis) groups=255(amavis),210(clamav)

added
Code:

AllowSupplementaryGroup yes
to clamd.conf and freshclam.conf

this is the socket :
Code:

root@mail:/etc# ls -la /var/run/clamav/
total 16
drwxrwx--x  2 clamav clamav 4096 May 24 14:32 ./
drwxr-xr-x 16 root  root  4096 May 24 13:26 ../
-rwxrwxrwx  1 clamav clamav    4 May 24 14:31 clamd.pid*
srw-rw----  1 clamav clamav    0 May 24 14:31 clamd.socket=
-rw-rw----  1 clamav clamav    4 May 24 14:32 freshclam.pid

this is clamd starting :
Code:

May 24 14:39:53 mail clamd[3196]: clamd daemon 0.97.8 (OS: linux-gnu, ARCH: x86_64, CPU: x86_64)
May 24 14:39:53 mail clamd[3196]: Running as user clamav (UID 210, GID 210)

and this is amavis :


Code:

May 22 16:40:55 mail amavisd-signer[2892]: 2013/05/22-16:40:55 AmavisSigner (type Net::Server::Multiplex) starting! pid(2892)
May 22 16:40:55 mail amavisd-signer[2892]: Binding to TCP port 20203 on host 127.0.0.1 with IPv4
May 22 16:40:55 mail amavisd-signer[2892]: Setting gid to "255 255"
May 22 16:40:55 mail amavisd-signer[2892]: Setting uid to "255"
May 22 16:40:55 mail amavis[2893]: starting. /usr/sbin/amavisd-new at mail.example.com amavisd-new-2.7.1 (20120429), Unicode aware, LANG="en_US"
May 22 16:41:21 mail amavisd-signer[2901]: Process Backgrounded

now .. anyone has any clue of why I am having this problem ? of course if I
chmod 777 the socket the problem is "solved" but first is not as intended and also I would have to script it at startup ....


All times are GMT -5. The time now is 05:59 AM.