LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Amarok stops working after playing one song? (http://www.linuxquestions.org/questions/slackware-14/amarok-stops-working-after-playing-one-song-4175412900/)

michaelinux 06-22-2012 05:18 PM

Amarok stops working after playing one song?
 
When i try to play a few songs in amarok, it stops working after the first song, then it just freezes and stops working, it doesn't even crash, it just stays there frozen.

this is part of what i got from amarok -debug:

About to finish
amarok: BEGIN: void EngineController::slotAboutToFinish()
amarok: [EngineController] Track finished completely, updating statistics
amarok: [SqlRegistryP] obtained max_allowed_packet is "1048576"
amarok: BEGIN: virtual void Playlist::Model::metadataChanged(Meta::TrackPtr)
amarok: BEGIN: void PlaylistInfoWidget::updateTotalPlaylistLength()
amarok: END__: void PlaylistInfoWidget::updateTotalPlaylistLength() [Took: 0s]
amarok: [Playlist::Model] Metadata updated for track "Bright Lights"
amarok: END__: virtual void Playlist::Model::metadataChanged(Meta::TrackPtr) [Took: 0.001s]
amarok: BEGIN: void Context::ContextView::slotMetadataChanged(Meta::TrackPtr)
amarok: BEGIN: bool EngineController::isStream()
amarok: END__: bool EngineController::isStream() [Took: 0s]
amarok: END__: void Context::ContextView::slotMetadataChanged(Meta::TrackPtr) [Took: 0s]
amarok: BEGIN: void LyricsAppletPrivate::_trackDataChanged(Meta::TrackPtr)
amarok: END__: void LyricsAppletPrivate::_trackDataChanged(Meta::TrackPtr) [Took: 0s]
amarok: BEGIN: void WikipediaEnginePrivate::_checkRequireUpdate(Meta::TrackPtr)
amarok: END__: void WikipediaEnginePrivate::_checkRequireUpdate(Meta::TrackPtr) [Took: 0s]
amarok: BEGIN: void OSDWidget::show(const QString&, const QImage&)
amarok: END__: void OSDWidget::show(const QString&, const QImage&) [Took: 0.003s]
amarok: BEGIN: void Playlist::Actions::requestNextTrack()
amarok: [Playlist::Actions] so far so good!
amarok: BEGIN: void Playlist::Actions:: play(quint64, bool)
amarok: BEGIN: void EngineController::setNextTrack(Meta::TrackPtr)
amarok: [EngineController] locking mutex
amarok: [EngineController] locked!
amarok: END__: void EngineController::setNextTrack(Meta::TrackPtr) [Took: 0s]
amarok: END__: void Playlist::Actions:: play(quint64, bool) [Took: 0s]
amarok: END__: void Playlist::Actions::requestNextTrack() [Took: 0.001s]
amarok: END__: void EngineController::slotAboutToFinish() [Took: 0.047s]
Got next source. Waiting for end of current.
New source: QUrl( "file:///media/Documents/Music/(2009) - Battle For The Sun/08 - The Never-Ending Why.mp3" )
Finally got a source
amarok: BEGIN: void LyricsEngine:: onTrackMetadataChanged(Meta::TrackPtr)
amarok: END__: void LyricsEngine:: onTrackMetadataChanged(Meta::TrackPtr) [Took: 0s]
amarok: BEGIN: void CurrentTrack::dataUpdated(const QString&, const Data&)
amarok: END__: void CurrentTrack::dataUpdated(const QString&, const Data&) [Took: 0.026s]


and then it stops working and i have to kill the process.
I'm using the Gstreamer backend and i have gst-plugins-base, gst-plugins-good, gst-plugins-ugly and gst-plugins-bad installed.


UPDATE: I just tried using amarok again, and for some reason it's working normally, i guess this is solved but with no real answer, it just started working from all of a sudden.

phi11ip 06-23-2012 05:53 AM

Had similar problems with my system - Slackware-Current64 with AlienBobs KDE 4.9RC2. Also using Gstreamer as backend. Downloading and installing gst-plugins-bad, gst-plugins-ffmpeg, gst-plugins-good, gst-plugins-ugly from AlienBob's download site cured the problem for me.

michaelinux 06-23-2012 07:15 PM

Quote:

Originally Posted by phi11ip (Post 4709935)
Had similar problems with my system - Slackware-Current64 with AlienBobs KDE 4.9RC2. Also using Gstreamer as backend. Downloading and installing gst-plugins-bad, gst-plugins-ffmpeg, gst-plugins-good, gst-plugins-ugly from AlienBob's download site cured the problem for me.

I'm not using Bob's packages, so i guess it won't help much installing those. :(\
I'm using KDE 4.8.2.

willysr 06-23-2012 07:50 PM

It doesn't matter if you are using KDE 4.8.2. You can compile those packages using my SlackBuild on SlackHacks


All times are GMT -5. The time now is 11:36 AM.