LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-02-2005, 06:32 PM   #1
ShoCkwave
Member
 
Registered: Mar 2004
Location: Turkey
Distribution: Ubuntu
Posts: 38

Rep: Reputation: 15
amaroK Fails to Start


I tried pre-compiled amaroK executables and also compiled source by-myself but I still have the same problem.

When I try to run amaroK, it appears for a while like 3-4 seconds then suddenly disappears. I dont know where can be a problem.

I use MySql installed on my system, running default at system startup. I think amaroK uses Sql to build collection list. I have set a password for account root on mysql. I enter this pass to /root/.kde/.../amarok* file.
But it still doesnt work. I was unable to figure out where can the problem be.

I appreciate any help. Thanks in advance.

Here, I provide the errors that happens in time by amaroK's execution.

Code:
root@DarkLord:~/Amarok/amarok-1.2.2# amarok
amaroK: [Loader] Starting amarokapp..
amaroK: [Loader] Don't run gdb, valgrind, etc. against this binary! Use amarokapp.
amarok: BEGIN: App::App()
amarok:   BEGIN: EngineBase* EngineController::loadEngine(const QString&)
amarok:     [PluginManager] Plugin trader constraint: [X-KDE-amaroK-framework-version] == 5 and [X-KDE-amaroK-plugintype] == 'engine' and [X-KDE-amaroK-name] != 'void-engine' and [X-KDE-amaroK-rank] > 0
amarok:     [PluginManager] Plugin trader constraint: [X-KDE-amaroK-framework-version] == 5 and [X-KDE-amaroK-plugintype] == 'engine' and [X-KDE-amaroK-name] == 'void-engine' and [X-KDE-amaroK-rank] > 0
amarok:     [PluginManager] Trying to load: libamarok_void-engine_plugin
amarok:
amarok:     PluginManager Service Info:
amarok:     ---------------------------
amarok:   &nbs p; name              &nbs p;           : 
amarok:     library         & nbsp;             : libamarok_void-engine_plugin
amarok:     desktopEntryPath               : amarok_void-engine_plugin.desktop
amarok:     X-KDE-amaroK-plugintype        : engine
amarok:     X-KDE-amaroK-name      &nb sp;      : void-engine
amarok:     X-KDE-amaroK-authors     & nbsp;    : (Max Howell,Mark Kretschmann)
amarok:     X-KDE-amaroK-rank     &nb sp;       : 1
amarok:     X-KDE-amaroK-version        ;   : 1
amarok:     X-KDE-amaroK-framework-version: 5
amarok:
QObject::connect: Cannot connect Engine::Base::statusText( const QString& ) to (null)::shortMessage( const QString& )
QObject::connect: Cannot connect Engine::Base::infoMessage( const QString& ) to (null)::longMessage( const QString& )
amarok:   END__: EngineBase* EngineController::loadEngine(const QString&) - Took 0s
amarok:   BEGIN: CollectionDB::CollectionDB()
amarok:     [CollectionDB] Available db connections: 1
amarok:     [CollectionDB] [ERROR!] [virtual QStringList SqliteConnection::query(const QString&)]  sqlite3_compile error:
amarok:     [CollectionDB] [ERROR!] no such table: tags
amarok:     [CollectionDB] [ERROR!] on query: SELECT COUNT( url ) FROM tags LIMIT 0, 1;
amarok:     [CollectionDB] [ERROR!] [virtual QStringList SqliteConnection::query(const QString&)]  sqlite3_compile error:
amarok:     [CollectionDB] [ERROR!] no such table: statistics
amarok:     [CollectionDB] [ERROR!] on query: SELECT COUNT( url ) FROM statistics LIMIT 0, 1;
amarok:     [void CollectionDB::createTables(DbConnection*)]
amarok:     [void CollectionDB::createStatsTable()]
amarok:     [CollectionDB] Available db connections: 5
amarok:     [Scrobbler] Couldn't open file: /root/.kde/share/apps/amarok/submit.xml
amarok:   END__: CollectionDB::CollectionDB() - Took 0.04s
QLayout: Adding KToolBar/mainToolBar (child of QVBox/unnamed) to layout for PlaylistWindow/PlaylistWindow
amarok:   Creating browsers. Please report long start times!
amarok:     BEGIN: ContextBrowser
amarok:       [void ContextBrowser::setStyleSheet()]
amarok:       BEGIN: amaroK::Color::Color(const QColor&)
amarok:         [ContextBrowser] Initial Color Properties: s:107 v:178
amarok:         [ContextBrowser] Unapplied Contrast: 53
amarok:         [ContextBrowser] Final Colour Properties: s:30 v:231
amarok:       END__: amaroK::Color::Color(const QColor&) - Took 0s
amarok:     END__: ContextBrowser - Took 0.03s
amarok:     BEGIN: CollectionBrowser
amarok:       [CollectionView::CollectionView(CollectionBrowser*)]
amarok:       [void CollectionView::renderView()]
amarok:     END__: CollectionBrowser - Took 0.02s
amarok:     BEGIN: PlaylistBrowser
amarok:     END__: PlaylistBrowser - Took 0.01s
amarok:     BEGIN: MediaBrowser
amarok:     END__: MediaBrowser - Took 0.01s
amarok:     BEGIN: FileBrowser
amarok:       [StatusBar] KSqueezedTextLabel, mainTextLabel: 15: 0
amarok:       [StatusBar] QHBox, progressBox: 23: 0
amarok:       [StatusBar] QLabel, unnamed: 15: 0
amarok:       [StatusBar] QWidget, positionBox: 26: 0
amarok:       [StatusBar] QWidget, unnamed: 16: 0
amarok:     END__: FileBrowser - Took 0.03s
amarok:   BEGIN: void App::applySettings(bool)
amarok:     BEGIN: void App::applyColorScheme()
amarok:     END__: void App::applyColorScheme() - Took 0s
amarok:     BEGIN: virtual void PlayerWidget::engineStateChanged(Engine::State)
amarok:     END__: virtual void PlayerWidget::engineStateChanged(Engine::State) - Took 0s
amarok:     [void ContextBrowser::setStyleSheet()]
amarok:     BEGIN: amaroK::Color::Color(const QColor&)
amarok:       [ContextBrowser] Initial Color Properties: s:107 v:178
amarok:       [ContextBrowser] Unapplied Contrast: 53
amarok:       [ContextBrowser] Final Colour Properties: s:30 v:231
amarok:     END__: amaroK::Color::Color(const QColor&) - Took 0s
QColor::setRgb: RGB parameter(s) out of range
QColor::setRgb: RGB parameter(s) out of range
QColor::setRgb: RGB parameter(s) out of range
amarok:     [virtual bool BrowserBar::event(QEvent*)] Line: 182
amarok:     [virtual void BrowserBar::polish()]
amarok:     BEGIN: void ContextBrowser::showHome()
amarok:       BEGIN: void ContextBrowser::showIntroduction()
amarok:       END__: void ContextBrowser::showIntroduction() - Took 0.02s
amarok:     END__: void ContextBrowser::showHome() - Took 0.02s
amarok:     [ThreadWeaver] Job completed: PlaylistReader. Jobs pending: 1
amarok:     BEGIN: EngineBase* EngineController::loadEngine()
amarok:       BEGIN: EngineBase* EngineController::loadEngine(const QString&)
amarok:         [PluginManager] Plugin trader constraint: [X-KDE-amaroK-framework-version] == 5 and [X-KDE-amaroK-plugintype] == 'engine' and [X-KDE-amaroK-name] != '' and [X-KDE-amaroK-rank] > 0
amarok:         [PluginManager] Plugin trader constraint: [X-KDE-amaroK-framework-version] == 5 and [X-KDE-amaroK-plugintype] == 'engine' and [X-KDE-amaroK-name] == '' and [X-KDE-amaroK-rank] > 0
amarok:         [PluginManager] Trying to load: libamarok_gstengine_plugin
amarok: [GstEngine::GstEngine()]
amarok:
amarok:         PluginManager Service Info:
amarok:         ---------------------------
amarok:         name                           : GStreamer Engine
amarok:         library               &nb sp;       : libamarok_gstengine_plugin
amarok:         desktopEntryPath              : amarok_gstengine_plugin.desktop
amarok:         X-KDE-amaroK-plugintype       : engine
amarok:         X-KDE-amaroK-name             : gst-engine
amarok:         X-KDE-amaroK-authors          : (Mark Kretschmann)
amarok:         X-KDE-amaroK-rank             : 255
amarok:         X-KDE-amaroK-version          : 1
amarok:         X-KDE-amaroK-framework-version: 5
amarok:
amarok: BEGIN: virtual bool GstEngine::init()
amarok:         BEGIN: virtual ThreadWeaver::~ThreadWeaver()
amarok:           [ThreadWeaver] Waiting on thread...finished
amarok:         END__: virtual ThreadWeaver::~ThreadWeaver() - Took 0s
amarok:         [virtual CollectionDB::~CollectionDB()]
amarok:         [CollectionDB] Running VACUUM
amarok:         [virtual EngineController::~EngineController()]
root@DarkLord:~/Amarok/amarok-1.2.2#
 
Old 04-02-2005, 10:25 PM   #2
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Try the newer version 1.2.3 and make sure you have gstreamer, gst-plugins and xine-lib installed.
 
Old 04-11-2005, 06:01 AM   #3
xushi
Senior Member
 
Registered: Jun 2003
Location: UK
Distribution: Gentoo
Posts: 1,288

Rep: Reputation: 45
Thanks,

I had a similar problem compiling, and turns out i had to upgrade my GStreamer, and install gst-plugin. That did the job.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
amarok wont start in Slackware jaakkop Linux - Software 1 07-17-2005 04:16 AM
Synaptic Fails to start lmanwarren Linux - Software 1 04-22-2005 11:17 PM
KDE-3.3 fails to start --- PLEASE HELP!! toffi22 Linux From Scratch 5 10-07-2004 12:50 PM
apache2 fails to start Nickelaway Linux - Software 3 07-23-2004 05:56 PM
kde fails to start... skinpainting Mandriva 3 02-18-2004 01:51 PM


All times are GMT -5. The time now is 12:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration