LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   amarok doesn't work (http://www.linuxquestions.org/questions/slackware-14/amarok-doesnt-work-300982/)

irfanhab 03-13-2005 12:09 AM

amarok doesn't work
 
Hi,


I've been a loyal fan of amarok, since it's 0.9 version, however the latest versions 1.2 and 1.2.1 don't work anymore


I click on a song, and the program disappears, and when I run it from the shell it says:

<code>bash-2.05b# amarokapp: relocation error: amarokapp: undefined symbol: _ZN6TagLib7FileRefC1Ev
amarokapp: relocation error: amarokapp: undefined symbol: _ZN6TagLib7FileRefC1Ev
amarokapp: relocation error: amarokapp: undefined symbol: _ZN6TagLib7FileRefC1Ev
</code>

it is very annoying! and even when I change the sound system from arts to xine or vice versa the program crashes at times.
I use xine at times, because my realplayer installation conflicts when arts is running, so does my mplayer, rather xine works fine for all.
I used amarok 1.1 for a long long time, and I used to switch b/w the engines without any issue.

Any clues?

I use slackware 10.0, with kde 3.3.0

masand 03-13-2005 06:16 AM

have u built amarok urself
or are u dependent on slackware packages??

and the latest stable is 1.2 i think
try that

regards

irfanhab 03-13-2005 06:47 AM

well I haev only tried the slack packages, and I have tried 1.2 too, it's still highly unstable

Seppel 03-13-2005 09:34 AM

I've got some self-compiled *tgz files of amaroK 1.2.1 and Xine-lib 1.0 for my personal use lying around here. They are compiled for i686, Slack 10.1.
I don't know if they will work with arts 'cause I don't use it. They work fine for me and are pretty stable as far as I can see. If you want, drop me an eMail and we'll see how I send them over to you. :-)

Greetings,

Seppel


All times are GMT -5. The time now is 09:37 AM.