LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-30-2010, 05:21 PM   #1
P42
LQ Newbie
 
Registered: Aug 2010
Location: Germany
Distribution: Slackware
Posts: 16

Rep: Reputation: 0
Amarok doesn't play files with umlauts in the filename (locale problem?)


Hello,

amarok at my computer doesn't play files with an umlaut in the filename. xmms does. the problem is not related to the read-only mounted fat partition my music is on, i tried copiing some tracks over. googling didn't help because there are so much problem with umlauts and amarok that don't match mine. the songs show up in the playlist just fine, but when i try to play them it just switches to the next track, and if amarok comes across such a track in the playlist during normal playback (without me explicitly clicking play/doubleclicking on the track) it stays and stops. My KDE is perfectly german, including amarok.

locale in Konsole however shows en_US for me and POSIX for root.

I don't know how to change that and i don't know how to get debug output from amarok besides starting it from console, which doesn't bring up anything useful here, so maybe pointing me in the right direction here or there would be enough.
amarok takes a while to start (like one minute), but that might be normal.

Last edited by P42; 11-30-2010 at 05:22 PM.
 
Old 11-30-2010, 05:58 PM   #2
brixtoncalling
Member
 
Registered: Jul 2008
Location: British Columbia
Distribution: Slackware current
Posts: 403

Rep: Reputation: 67
You can change your locale in /etc/profile.d/lang.sh

It's been a long time since I tried to play music in Amarok off a FAT or NTFS drive so I can't remember what needs to be done to get those kind of files working. I've had similar problems though.
 
1 members found this post helpful.
Old 12-01-2010, 03:57 AM   #3
P42
LQ Newbie
 
Registered: Aug 2010
Location: Germany
Distribution: Slackware
Posts: 16

Original Poster
Rep: Reputation: 0
As i already stated, the filesystem is not the problem, files on my ext4 "/" partition have the same problem.

As for changing the locale, there's really nothing more to do than this? no single program will break because of me just changing it?
 
Old 12-01-2010, 04:44 AM   #4
brixtoncalling
Member
 
Registered: Jul 2008
Location: British Columbia
Distribution: Slackware current
Posts: 403

Rep: Reputation: 67
Quote:
Originally Posted by P42 View Post
As i already stated, the filesystem is not the problem, files on my ext4 "/" partition have the same problem.
Well, your original post wasn't entirely clear about where you had copied, and I believe it is still possible to have problems after copying based on the origin of the file being FAT when your locale is not set up properly.

Quote:
As for changing the locale, there's really nothing more to do than this? no single program will break because of me just changing it?
That's it. Just change it to export LANG=de_DE.utf8 or whatever your locale is. I can't say for sure this will solve your problem with Amarok, however. You might want to try looking at the tags with a tag editor.
 
Old 12-01-2010, 08:26 AM   #5
P42
LQ Newbie
 
Registered: Aug 2010
Location: Germany
Distribution: Slackware
Posts: 16

Original Poster
Rep: Reputation: 0
After changing the locale, the Umlaute in dolphin had become questionmarks-in-a-diamond, and amarok woulnd't even add them. Funny that it worked with en_US.
However, umlaut-tainted songs from the ext4-partion now do play.

now i try attaching utf8 to the mount options

Last edited by P42; 12-01-2010 at 08:29 AM.
 
Old 12-01-2010, 09:20 AM   #6
P42
LQ Newbie
 
Registered: Aug 2010
Location: Germany
Distribution: Slackware
Posts: 16

Original Poster
Rep: Reputation: 0
Okay, after changing the locale and mounting the drive with ,utf8 the original problem is solved, amarok plays the songs without complaining.

However, I now have a new major problem: all files with an umlaut in the filename that i saved since i set my slackware system up are now unusable ("file doesn't exist" or the like errors). am i supposed to open a new thread on that? will the fix maybe even work when i change the locale back and only leave the mount option in?
 
Old 12-01-2010, 09:30 AM   #7
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,971

Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
Hello P42,

I'd suggest to read this: http://www.piir.ch/slackware-linux/unicode-utf-8.html
Slackware (by default) handles the locales in a slightly different way than other distributions.

Markus
 
Old 12-01-2010, 11:28 AM   #8
brixtoncalling
Member
 
Registered: Jul 2008
Location: British Columbia
Distribution: Slackware current
Posts: 403

Rep: Reputation: 67
Quote:
Originally Posted by P42 View Post
Okay, after changing the locale and mounting the drive with ,utf8 the original problem is solved, amarok plays the songs without complaining.

However, I now have a new major problem: all files with an umlaut in the filename that i saved since i set my slackware system up are now unusable ("file doesn't exist" or the like errors). am i supposed to open a new thread on that? will the fix maybe even work when i change the locale back and only leave the mount option in?
The source of the problem is probably that the FAT drive doesn't encode the names in unicode so when you copy them to ext3 the original non-unicode remains. With the default Slackware set up it 'understands' the non-unicode umlauts but when you change to utf8, it doesn't understand these previously created encodings properly. You have to rename the files and it should work. If you have lots of files you could write a script to do the renaming for you or use a tool from Slackbuilds if there is one.
 
Old 12-01-2010, 01:08 PM   #9
alekow
Member
 
Registered: Sep 2009
Distribution: Slackware
Posts: 127

Rep: Reputation: 17
I think that you should somehow convert names of the files containing german letters, which were written to your partition before mounting as utf. You can try doing it in midnight commander. Run mc, open location containing your files in one of the windows and try setting a different encoding (RIGHT (or LEFT) --> Encoding in the menu).
If the filenames look good now copy the files to a different location opened in the other mc window (you can as well try copying the whole directory, just make sure the encoding is set to the one you need). Now the filenames in the new location should be ok.

I'm quite sure that there is another solution, which may not require copying of the affected files, but this one is simple and was good enough for me ;-)
 
Old 01-10-2011, 06:38 PM   #10
P42
LQ Newbie
 
Registered: Aug 2010
Location: Germany
Distribution: Slackware
Posts: 16

Original Poster
Rep: Reputation: 0
there is a very nice tool on slackbuilds named convmv that converts the broken filenames (also recursively). the only other solution was to rename every file on the console, because every other way would fail with something like "no such file".


btw i read that vfat filenames are always stored in utf-16... mounting with utf-8 does it nevertheless

Last edited by P42; 01-10-2011 at 06:47 PM.
 
  


Reply

Tags
amarok2, locale, slackware, windows


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to get amarok to play mp3 files PlainDave Linux - Software 3 01-12-2008 11:50 PM
Ipod nano Amarok files don't play arubin Slackware 4 05-18-2007 02:03 AM
How to Play .rm Files in Amarok ejan Linux - Desktop 3 03-25-2007 07:04 PM
Amarok doesnt play mp3 files marcoguillen Linux - Software 1 12-06-2006 04:55 PM
Amarok and special characters (umlauts) Fonk Linux - Software 0 03-13-2005 03:32 PM


All times are GMT -5. The time now is 12:36 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration