LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 04-24-2012, 09:02 PM   #1
BoydRice
Member
 
Registered: Jul 2008
Location: Tacoma, WA
Distribution: Slackware64
Posts: 95

Rep: Reputation: 19
Amarok 2.5 not recognizing ipod


Hi,

Is ipod support broken in Amarok 2.5? I am running Slackware64 -current and Clementine recognizes my ipod but Amarok does not. The ipod is an 80 gb model at least 3 years old and used to work under Amarok in previous versions. As I understand KDE is no longer using Hal, could this be related? Any suggestions?

I could use Clementine but I would prefer not to as there is some strange behavior where the music I transfer to my ipod is sorted strangely.
 
Old 04-27-2012, 01:35 PM   #2
STDOUBT
Member
 
Registered: May 2010
Location: Stumptown
Distribution: Slackware 14.0/32bit + Xmonad
Posts: 280

Rep: Reputation: 74
Jeeze, 3 days.
I guess you're stuck with me...:^)

I can't speak to Clementine, Amarok, or even KDE for that matter, but I recently had to learn to access a friends ipod, and all I needed to install was:
libimobiledevice, libtasn1, usbmuxd, and used gtkpod to access it. Works great! (Not sure if I really needed libtasn1 though).

Last edited by STDOUBT; 04-27-2012 at 01:36 PM. Reason: typo
 
Old 04-27-2012, 02:53 PM   #3
BoydRice
Member
 
Registered: Jul 2008
Location: Tacoma, WA
Distribution: Slackware64
Posts: 95

Original Poster
Rep: Reputation: 19
Thanks, yeah I have most of those installed to access it via Clementine. I guess I will try out gtkpod but it is a shame since I would prefer to use amarok. Maybe I will install an older version of amarok to see if that would work and try the next release of amarok.
 
Old 04-27-2012, 03:00 PM   #4
stretchedthin
Member
 
Registered: Sep 2009
Posts: 45
Blog Entries: 32

Rep: Reputation: 16
You can try this worked for my ipod touch 2nd generation
Connect your ipod touch to Linux
 
Old 04-28-2012, 12:48 PM   #5
BoydRice
Member
 
Registered: Jul 2008
Location: Tacoma, WA
Distribution: Slackware64
Posts: 95

Original Poster
Rep: Reputation: 19
Thanks, but my ipod is detected and shows up in dolphin and thunar and even Clementine but the issue I would like to resolve is getting it recognized in Amarok.
 
Old 06-05-2012, 12:13 PM   #6
RayM
LQ Newbie
 
Registered: Jun 2012
Posts: 1

Rep: Reputation: Disabled
BoydRice, have you managed to solve your problem? I'm in exactly the same situation with a first gen iPod touch using Amarok 2.5 and libgpod 0.8.2.

Amarok 2.6 will be released in a few weeks, and it has a completely re-written iPod plugin. Perhaps that's the answer, but I don't have the energy to compile it now to test.
 
  


Reply

Tags
amarok2, ipod, slackware -current


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
VirtualBox not recognizing iPod Gauvenator Linux - Software 3 09-24-2009 03:23 PM
Amarok not seeing iPod CrownAmbassador Linux - Hardware 7 11-22-2006 08:12 PM
amarok/ipod everyonebleeds Linux - Software 1 08-31-2006 11:32 PM
Is amarok ipod only ? dukeinlondon Linux - Software 2 01-23-2006 05:50 PM
GTK Pod on Fedora Core III isn't recognizing iPod Mini Parapsychosis Fedora 4 10-13-2005 08:38 PM


All times are GMT -5. The time now is 10:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration