LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-31-2004, 11:55 PM   #1
Lechium
Member
 
Registered: Jun 2004
Distribution: Gentoo
Posts: 102

Rep: Reputation: 16
am able to run firefox off console as SU, but not as user...


Hi.
I had d/led firefox from slackwares website, and use installpkg to install it. Now if i type 'firefox' in console in SU mode it will run just fine, but if i'm in normal user mode it wount run... why?
 
Old 08-01-2004, 01:00 AM   #2
Cedrik
Senior Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 2,140

Rep: Reputation: 242Reputation: 242Reputation: 242
Because of permissions problem. Try to locate your firefox dir then look if it has permissions to read (and maybe execute too) for other user than root ( rwxr-xr-x ).
 
Old 08-01-2004, 04:23 AM   #3
Lechium
Member
 
Registered: Jun 2004
Distribution: Gentoo
Posts: 102

Original Poster
Rep: Reputation: 16
i did chown [username] /usr/lib/firefox-0.9.2 however it didnt chnage the situation for the better
what is happeneing?
 
Old 08-01-2004, 07:10 AM   #4
Cedrik
Senior Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 2,140

Rep: Reputation: 242Reputation: 242Reputation: 242
what about chown your_user ~/.firefox if it exists and try to search more firefox files in your system, locate firefox

also what is the output for :

find /usr/lib/firefox-0.9.2 -uid 0 -perm 700
find /usr/lib/firefox-0.9.2 -uid 0 -perm 600

Last edited by Cedrik; 08-01-2004 at 07:12 AM.
 
Old 08-01-2004, 07:55 AM   #5
Nikon01
Member
 
Registered: Jul 2003
Distribution: Slackware 10.0
Posts: 196

Rep: Reputation: 30
little help on finding files:

touch /var/lib/slocate/slocate.db
updatedb&
slocate firefox

slocate has yet to fail me. If you already know about that well then I'm just useless huh?
 
Old 08-01-2004, 02:35 PM   #6
aeNeo
Member
 
Registered: Jul 2004
Distribution: Slackware 10.0
Posts: 57

Rep: Reputation: 15
(post deleted)
 
Old 08-01-2004, 02:57 PM   #7
Andrew Benton
Senior Member
 
Registered: Aug 2003
Location: Birkenhead/Britain
Distribution: Linux From Scratch
Posts: 2,073

Rep: Reputation: 64
To just chown the firefox directory is not enough, you have to do it recursively,
chown -R username /path/to/firfox
that way it descends into the firefox folder and changes the permissions on every file. After you've run Firefox once and it's created your profile, chown it back to root, you don't want to be browsing with a browser you can write to.
chown -R root:root /path/to/firefox
 
Old 08-01-2004, 03:19 PM   #8
Lechium
Member
 
Registered: Jun 2004
Distribution: Gentoo
Posts: 102

Original Poster
Rep: Reputation: 16
recursing chowning worked, thanks.
however creating a profile (i even had set the setting folder to me in user folder) and giving firefox back to root didnt' do much.
can i set it so user can read but not write? or that is the default?
 
Old 08-01-2004, 03:25 PM   #9
Brane Ded
Member
 
Registered: Nov 2003
Location: over there
Distribution: Debian Testing
Posts: 191

Rep: Reputation: 30
Users should be able to read the directory by default. Try "chmod -R go+r /path/to/firefox"

That will give read permissions to pretty much everybody. It's good to keep directories under the ownership of root, so you don't accidentally nuke them one day. So keep it under root:root, and to make sure you can't write to it, "chmod -R go-w /path/to/firefox"

Last edited by Brane Ded; 08-01-2004 at 03:29 PM.
 
Old 08-01-2004, 04:41 PM   #10
Cedrik
Senior Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 2,140

Rep: Reputation: 242Reputation: 242Reputation: 242
Directories need to be executable as well (chmod +x)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
purpose of Java Console in Firefox? microsoft/linux General 1 10-04-2005 07:57 AM
firefox dos not open when run under user (opens only in root) saso Mandriva 8 06-15-2005 10:07 AM
how do I make sure that the user that is going to run the script is a root user??? nikold01 Linux - General 3 09-10-2004 07:54 AM
which libraries do I need to run firefox in console-mode? minike Slackware 3 09-05-2004 06:36 PM
How to Run Win32 Console App in linux Console Lokie Linux - Software 2 08-12-2004 10:00 PM


All times are GMT -5. The time now is 04:23 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration