LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-20-2009, 07:01 PM   #1
wakkana12
Member
 
Registered: Dec 2009
Posts: 171

Rep: Reputation: 15
alsamixer not running, i figured it has a conflict on pulse audio


this was the error i had when running alsamixer.
Code:
ALSA lib pulse.c:272:(pulse_connect) PulseAudio: Unable to connect: Connection refused


alsamixer: function snd_ctl_open failed for default: Connection refused

my audio and mplayer works fine earlyer, then my sister accessed her user and started playing some movies but a continues error prompt saying [ao alsa] : Unable to find simple pcm. so i tried running alsaconf, the alsaconf command works fine but when i tried using alsamixer the error above appear. now i got no sound. can someone help me? tnx..
 
Old 12-20-2009, 07:12 PM   #2
~sHyLoCk~
Senior Member
 
Registered: Jul 2008
Location: /dev/null
Posts: 1,173
Blog Entries: 12

Rep: Reputation: 129Reputation: 129
In your system settings->multimedia, ceck out if your sound device is selected also check the backend if it's xine.
 
Old 12-20-2009, 07:19 PM   #3
wakkana12
Member
 
Registered: Dec 2009
Posts: 171

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by ~sHyLoCk~ View Post
In your system settings->multimedia, ceck out if your sound device is selected also check the backend if it's xine.
im running slack on gnome.. and yah i have xine.. whoa* y is that in xine my sounds are running ok?
 
Old 12-21-2009, 05:01 AM   #4
Ivshti
Member
 
Registered: Sep 2008
Distribution: Linvo
Posts: 132

Rep: Reputation: 33
Try "alsamixer -c 0"
 
Old 12-21-2009, 05:47 AM   #5
wakkana12
Member
 
Registered: Dec 2009
Posts: 171

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Ivshti View Post
Try "alsamixer -c 0"
tnx... works like a charm.. but my main problem is that an error still occur when i try to play movies in my mplayer.. the same error occur..

anyway why does alsamixer not running w/ just alsamixer command?
 
Old 12-21-2009, 06:05 AM   #6
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,229

Rep: Reputation: 286Reputation: 286Reputation: 286
Quote:
Originally Posted by wakkana12 View Post
tnx... works like a charm.. but my main problem is that an error still occur when i try to play movies in my mplayer.. the same error occur..
For MPlayer, go to: preferences > audio, and make sure it is set to use alsa. Then restart MPlayer and see if you get sound.
 
Old 12-21-2009, 06:41 AM   #7
wakkana12
Member
 
Registered: Dec 2009
Posts: 171

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by tommcd View Post
For MPlayer, go to: preferences > audio, and make sure it is set to use alsa. Then restart MPlayer and see if you get sound.
i have no audio menu in the preferences do u mean sounds? im running on gnome by the way and in the sounds menu i dont have a "use alsa" command..
 
Old 12-21-2009, 06:44 AM   #8
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,229

Rep: Reputation: 286Reputation: 286Reputation: 286
Quote:
Originally Posted by wakkana12 View Post
i have no audio menu in the preferences do u mean sounds? im running on gnome by the way and in the sounds menu i dont have a "use alsa" command..
I mean the preferences for MPlayer, not in Gnome. Open MPlayer and in MPlayer go to: preferences > sound, and select alsa, ten restart MPlayer.
 
Old 12-21-2009, 06:55 AM   #9
wakkana12
Member
 
Registered: Dec 2009
Posts: 171

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by tommcd View Post
I mean the preferences for MPlayer, not in Gnome. Open MPlayer and in MPlayer go to: preferences > sound, and select alsa, ten restart MPlayer.
sori.. my bad.. ^^ and thanx.. it worked!! i have other users in this computer should i also configure their mplayer? or there something i could configure to make this a global setting for mplayer?
 
Old 12-21-2009, 07:00 AM   #10
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,229

Rep: Reputation: 286Reputation: 286Reputation: 286
Quote:
Originally Posted by wakkana12 View Post
sori.. my bad.. ^^ and thanx.. it worked!! i have other users in this computer should i also configure their mplayer? or there something i could configure to make this a global setting for mplayer?
Glad it worked!
I don't think there is anything you can configure globally to configure MPlayer to use alsa for all users. The preferences are stored in /home/user_name/.mplayer. This is so they can be set individually for each user.
 
Old 12-21-2009, 07:27 AM   #11
wakkana12
Member
 
Registered: Dec 2009
Posts: 171

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by tommcd View Post
Glad it worked!
I don't think there is anything you can configure globally to configure MPlayer to use alsa for all users. The preferences are stored in /home/user_name/.mplayer. This is so they can be set individually for each user.
so in every ~/.mplayer/gui.conf ill be editing this line "ao_alsa_mixer_channel = 'PCM'"? all the folders in my home directory with the .[name] are all configuration files of some programs? i've read somewhere that folders having . infront are hidden files..
 
Old 12-22-2009, 07:26 AM   #12
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,229

Rep: Reputation: 286Reputation: 286Reputation: 286
Quote:
Originally Posted by wakkana12 View Post
so in every ~/.mplayer/gui.conf ill be editing this line "ao_alsa_mixer_channel = 'PCM'"? all the folders in my home directory with the .[name] are all configuration files of some programs? i've read somewhere that folders having . infront are hidden files..
You could just edit: /home/user_name/.mplayer/config and add this to it:
Code:
# use alsa
ao=alsa
Save the file and exit and restart MPlayer. This should force MPlayer to always use alsa.
 
Old 12-22-2009, 11:42 AM   #13
wakkana12
Member
 
Registered: Dec 2009
Posts: 171

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by tommcd View Post
You could just edit: /home/user_name/.mplayer/config and add this to it:
Code:
# use alsa
ao=alsa
Save the file and exit and restart MPlayer. This should force MPlayer to always use alsa.
thnx.. its working fine now..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
pulse audio enhance my gentoo? hosler Gentoo 4 08-14-2009 08:22 AM
pulse audio sulekha Ubuntu 1 02-10-2009 05:48 PM
how can i get pulse audio to work i xfce deathalele Linux - Software 0 08-30-2008 07:02 PM
no sound with Pulse-audio and xmms Brynn Linux - Software 2 12-06-2007 04:03 PM
Pulse Audio problem in Fedora8 benjithegreat98 Fedora 3 11-12-2007 12:05 AM


All times are GMT -5. The time now is 12:41 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration