LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   alsactl and mocules.conf problem to restore/store values (http://www.linuxquestions.org/questions/slackware-14/alsactl-and-mocules-conf-problem-to-restore-store-values-165351/)

destin 04-02-2004 10:14 AM

alsactl and modules.conf problem to restore/store values
 
i run alsamixer, i unmute and set some values and then i type "alsactl store" and so everything in /etc/asound.state seems correct.

i put these 2 lines at my /etc/modules.conf

post-install snd-via82xx /usr/sbin/alsactl restore
pre-remove snd-via82xx /usr/sbin/alsactl store

(the driver name for my card is snd-via82xx)

i reboot and everything is muted and set to 0.
but i read this about putting those 2 lines at /etc/modules.conf:"This doesn't seem to work with a 2.6.0-test kernel. modprobe simply ignores lines with these statements. Update to this section would be appreciated."

Any ideas for how to solve this problem ??

PS:i have alsa(driver 1.0.3 , lib1.0.3b, utils 1.0.3) and kernel 2.6.4

bnice 04-02-2004 12:55 PM

File under "works for me(TM)" YMMV
 
Code:

root@bilbo/etc/rc.d# cat rc.local
#!/bin/sh
#
# /etc/rc.d/rc.local:  Local system initialization script.
#
# Put any local setup commands in here:
alsactl restore

If you really change settings every time you log in rather than having a default "save once" configuration, then create a file in your home directory named `.bash_logout` & call `alsactl store` from there.

moonloader 04-02-2004 07:19 PM

or as root in konsole command alsactl and fix your sound then command alsactl store,next time it will start as you configured it

destin 04-02-2004 08:22 PM

Quote:

Originally posted by moonloader
or as root in konsole command alsactl and fix your sound then command alsactl store,next time it will start as you configured it
I did give the commands you write as root.
I'll try what bnice wrote.

destin 04-03-2004 09:12 AM

Re: File under "works for me(TM)" YMMV
 
Quote:

Originally posted by bnice
Code:

root@bilbo/etc/rc.d# cat rc.local
#!/bin/sh
#
# /etc/rc.d/rc.local:  Local system initialization script.
#
# Put any local setup commands in here:
alsactl restore

If you really change settings every time you log in rather than having a default "save once" configuration, then create a file in your home directory named `.bash_logout` & call `alsactl store` from there.

What's inside rc.local get executed after the modules are loaded ??


All times are GMT -5. The time now is 11:48 AM.