LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   alsa / slackware current / Intel i810 (http://www.linuxquestions.org/questions/slackware-14/alsa-slackware-current-intel-i810-123882/)

hjles 12-08-2003 11:30 AM

alsa / slackware current / Intel i810
 
Hey all:

I know there are other recent threads about this topic, but none of them really seem to have come to a conclusion.

I have a toshiba laptop, and after a clean install of slackware current, sound no longer works. The onboard chipset is Intel i810.

Taking a look at the alsa website, it seems that versions 1.0rc1 had a "fix for Intel8X0", so I'm guessing that maybe this is a known problem, and the newest source will fix it. Actually, it looks like rc2 is out with more bugfixes.

My question: Can I take the slackware alsa source packages (driver, lib, and oss) and hack the slackbuild script to use the newer source tarballs simply editing the version number? Has anyone tried this?

Interesting side note: I just installed UHU linux (I don't speak Hungarian, but the package list looked impressive, and I'm alwasys up for a challenge). They are also using the 2.4.23 kernel, and the 0.9.8 alsa, and I have the same sound problems! By the way, UHU is nice, but the english support is non-existant for the install. You can switch the language of the desktop, but most of the apps are still Hungarian.

-Charlie

chunkymunky 12-08-2003 01:32 PM

Alsa Config
 
have you tried running alsaconf?

pi314159 12-08-2003 04:19 PM

Rank newbie that I am, I ran into this one a couple days ago - I might be able to contribute something useful for once! :D ...I have Slack 9.1 on a Dell laptop with the same chipset. Couldn't get the sound to work. I eventually ran alsaconf and used the arrow keys to turn up the sound. Still didn't work. I eventually found out that you use the 'm' key to mute and unmute sound stuff (channels, maybe? don't know the term.)

:twocents:

-pi314159

codec 12-08-2003 06:34 PM

my sister's PC has slackware 9.1 installed. The sound does work, it just has a small problem:

the pcm volume is at zero at startup, it is not a big deal for us. Just rise the volume before the music start and ok. The problem is the sound quality. She say the music is much better than before and keep listening music until 3am. It's really annoying :cry:

littleking 12-09-2003 06:19 AM

insmod i810_audio

insmod ac97_codec

mi6 12-09-2003 10:12 AM

I have a different laptop with an i810 chipset and working sound. My kernel is 2.2.23 and the upgraded alsa-* packages that go with it.

I just run alsamixer and unmute Master and PCM and turn them to my desired level. Then run alsactl store to make sure they return to that after reboot.

Here is my lsmod, I didn't clean it up to show only snd/alsa stuff, so extract what is applicable.

Code:

ppp_deflate            3256  0 (autoclean)
zlib_deflate          18328  0 (autoclean) [ppp_deflate]
bsd_comp                4344  0 (autoclean)
ppp_async              7488  1 (autoclean)
ppp_generic            15428  3 (autoclean) [ppp_deflate bsd_comp ppp_async]
slhc                    5008  0 (autoclean) [ppp_generic]
hsfbasic2              95948  2 (autoclean)
hsfserial              22932  2 (autoclean)
hsfengine            869292  0 (autoclean) [hsfserial]
hsfosspec              21856  1 (autoclean) [hsfbasic2 hsfserial hsfengine]
snd-pcm-oss            36964  0
snd-mixer-oss          11856  0 [snd-pcm-oss]
uhci                  24508  0 (unused)
usbcore                59276  1 [uhci]
hw_random              2712  0 (unused)
i810_rng                2528  0 (unused)
snd-intel8x0          18248  0
gameport                1420  0 [snd-intel8x0]
snd-pcm                55876  0 [snd-pcm-oss snd-intel8x0]
snd-timer              13476  0 [snd-pcm]
snd-ac97-codec        38040  0 [snd-intel8x0]
snd-page-alloc          5940  0 [snd-intel8x0 snd-pcm]
snd-mpu401-uart        3072  0 [snd-intel8x0]
snd-rawmidi            12704  0 [snd-mpu401-uart]
snd-seq-device          3888  0 [snd-rawmidi]
snd                    30212  0 [snd-pcm-oss snd-mixer-oss snd-intel8x0 snd-pcm snd-timer snd-ac97-codec snd-mpu401-uart snd-rawmidi snd-seq-device]
soundcore              3396  3 [snd]
ohci1394              24112  0 (unused)
ieee1394              42372  0 [ohci1394]
eepro100              19316  0 (unused)
mii                    2272  0 [eepro100]
ds                      6612  1
yenta_socket          10304  1
pcmcia_core            39872  0 [ds yenta_socket]
ide-scsi                9360  0
agpgart                43972  0 (unused)


hjles 12-09-2003 06:50 PM

follow up
 
Hey all;

Thanks for the great responses. I wish I knew more about the problem I was having, so that I could describe it more accurately. It's not that sound was totally broken, just that some apps had a problem with it (Mplayer, for one). I frequently run clean installs of slackware current from iso's I burn from a package tree I keep rsynced (I know, but it's fun), and I have never had this problem until the update to 2.4.23.

Long story short, I upgraded to Alsa 1.0.0rc2, and everything is cool!

-charlie

hjles 12-10-2003 04:59 AM

Wouldn't you know it?
 
Hey all:

Of course, one day after figuring out how to compile and install Alsa 1.0.0rc2 on my own, slackware-current has been updated to include it! Check the latest changelog. Hopefully, this will fix a lot of the problems people have been having.

-Charlie

Skoop 09-10-2004 08:18 AM

ok, this is bumping an old thread, sorry for that, but I'm running into an alsa problem on my new slackware 10 installation on my dell lattitude D505. I can configure alsa without a problem and during booting I see that everything is loaded.

however, when I want to change the volume:

rexima: mixer has no devices!

alsamixer: No mixer elems found

anyone know what might be causing this, and how to solve it? I take it there is a conf file somewhere where I need to enter a location of a mixer device? but which conf file, where?

codec 09-10-2004 08:50 AM

that mean the driver is not properly configurated. You can run alsaconf and install the sound driver.

Note that after kernel update, you may need to reinstall alsa-driver first.

icom158 09-10-2004 01:55 PM

Quote:

Originally posted by codec
my sister's PC has slackware 9.1 installed. The sound does work, it just has a small problem:

the pcm volume is at zero at startup, it is not a big deal for us. Just rise the volume before the music start and ok. The problem is the sound quality. She say the music is much better than before and keep listening music until 3am. It's really annoying :cry:

use alsactrl store to save settings after using alsamixer to raise volume

mazebane 01-24-2005 04:41 AM

I also have a Dell Latitude D505 and am getting the same problems as skoop.
I ran alsaconf, rebooted and still no mixer elems.
I installed alsa again and and that had no effect so i ran alsa conf, rebooted and i still get no elems when i run alsamixer.
Sorry to bump the thread again i have tried search everywhere and have had no luck.

mazebane 01-24-2005 05:18 AM

Well not 5 minutes later i ran across the solution!

Its a problem with the modem being detected so you have to blacklist it.
I added

snd-intel8x0m

to the

/etc/hotplug/blacklist

file, i then rebooted, ran alsaconfig and then alsamixer.

Sound works a treat now :)

I hope this helps someone else to as it has been a frustrating week for me.

sporks 01-24-2005 07:24 AM

:D This pops up here weekly it would seem. ;)

3887182 01-25-2005 06:11 AM

Your toshiba laptop has two sound cart , AC97 just the one is onbroad , you have aother card , i guess .

that's why u cant use "alsaconf " and so on .

try " aumix"

BTW what's ur model ? toshiba satellite 3000 ?


All times are GMT -5. The time now is 06:00 PM.