LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   alsa problem after the latest slackware-current update (http://www.linuxquestions.org/questions/slackware-14/alsa-problem-after-the-latest-slackware-current-update-438825/)

perfect_circle 04-25-2006 07:41 PM

alsa problem after the latest slackware-current update
 
After I updated my system I have a problem with alsa.
Although alsaconf runs fine, the sound card is detected and the modules are loaded at boot, I get a no soundcard found message in the boot process. The only way to overcome this is by running hotplug.
I'm not sure but I think it must have something to do with the new udev not building the device nodes.

Has anybody had the same problem?

I'm using the slackware-current 2.6.16.9 kernel

perfect_circle 04-25-2006 08:37 PM

This is strange.
If I run /etc/rc.d/rc.udev afterwards it creates the /dev/sound/* files and the sound works, but when udev is executed in the boot process it doesn't.

perfect_circle 04-25-2006 08:47 PM

I seem to be facing the problem for which the 090 was not included instead:
Quote:

I've had other reports of hardware that wasn't hotplugged correctly, too (and ran into some myself). Mostly it seems to be a question of figuring out the proper place in the boot process to put udev, but there are also a lot of things we're left to figure out concerning the udev rules. We'll get there, but maybe not in the next release.

davidsrsb 04-26-2006 01:51 AM

According to kernel.org the latest 2.6 fixes a hotplug race condition resent in the most recent Slack 2.6 kernel.

Alien Bob 04-26-2006 03:42 AM

To me - looking at the latest ChangeLog - it seems that you will need both udev and hotplug enabled (chmod +x /etc/rc.d/rc.hotplug ; chmod +x /etc/rc.d/rc.udev) for 2.6 kernels.
Also note that for the 2.6 kernel, if udev is enabled, the old hotplug will not be used. Udevsend will take the place of the hotplug program for handling hotplugging events - and this is configured in rc.hotplug.

Eric

Fluxx 04-26-2006 04:48 AM

The same behaviour here:

Without udev no devices, with udev and without hotlug no soundcard!

With udev and hotplug there is no problem with my soundcard, only the boot process needs more time.

Fluxx.

pdw_hu 04-26-2006 08:37 AM

Well if your soundcard is compiled as a module then it won't show up during boot, if it's in the kernel it will. As module alsaconf will detect it, if it's in the kernel it won't. Dunno why...
Add your module name to /etc/rc.d/rc.modules and it will (hopefully work).

perfect_circle 04-26-2006 12:17 PM

Quote:

Originally Posted by pdw_hu
Well if your soundcard is compiled as a module then it won't show up during boot, if it's in the kernel it will. As module alsaconf will detect it, if it's in the kernel it won't. Dunno why...
Add your module name to /etc/rc.d/rc.modules and it will (hopefully work).

This won't make any difference at all.
In rc.S the boot script the /etc/rc.d/rc.udev is executed in line 40 and the /etc/rc.d/rc.modules is executed in line 200.
and then rc.alsa is executed in rc.M. I don't think this will make any difference. SO the alsa modules are loaded after rc.udev

So the question is Am I obligated to use hotplug?

Fluxx 04-26-2006 02:15 PM

That was my first idea and I tried it immediately, without any positive effect. For me the only solution is to start hotplug and have a proper working soundcard.

No problem with a soundcard, a little problem with an old pc with an isa-pnp soundchip (onboard). With this machine hotplug needs about 40 seconds to finish, to add a "&" in rc.M doesn't help, because then the soundcard isn't detected in the right time and rc.alsa runs before.

No more ideas here ...

Fluxx.


All times are GMT -5. The time now is 09:46 PM.