LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-31-2011, 04:13 PM   #1
nova49
Member
 
Registered: Nov 2010
Distribution: Slackware
Posts: 74

Rep: Reputation: 0
alsa problem


The problem is that I am trying to get my microphone to work so I can use skype. Right now its not picking up any thing. I checked alsa and none of the mics were muted. The mic works fine on my other machine. I though it might be a drivers issue as I had the same problem in Debian. But sound works find in both the headset and my desktop speakers.

I'm using slackware -current. I have skype 2.1 installed. Its not a usb headset but a standard 3.5mm one. I wish there was a way to show you guys what my alsa looks like but I don't know of one. If you need any more information about the problem just ask.

Final note. I had the exact same problem with my previous Debian squeeze install. Not sure if there related.
 
Old 01-31-2011, 05:09 PM   #2
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,432

Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
This appears to be a hardware specific problem. Please post the make and model of your machine as well as the output of '/sbin/lspci'.
 
Old 02-02-2011, 08:55 AM   #3
Golf4Fun
LQ Newbie
 
Registered: Jan 2009
Posts: 16

Rep: Reputation: 0
Type alsamixer and press F5 - then take a screen capture of it and post the image.
 
Old 02-06-2011, 11:01 PM   #4
nova49
Member
 
Registered: Nov 2010
Distribution: Slackware
Posts: 74

Original Poster
Rep: Reputation: 0
Sorry it has been so long since I posted this. I got really busy with other stuff.

lspci
Code:
lspci
00:00.0 Host bridge: Intel Corporation 4 Series Chipset DRAM Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family) SATA IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
01:00.0 VGA compatible controller: ATI Technologies Inc RV770 [Radeon HD 4850]
01:00.1 Audio device: ATI Technologies Inc HD48x0 audio
02:05.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8110SC/8169SC Gigabit Ethernet (rev 10)
I built the computer myself so I cant give a make or model number. I can give you a list of the hardware though.

GIGABYTE GA-G41M-ES2H LGA 775 Intel G41 HDMI Micro ATX Intel Motherboard
Intel Pentium E6300 Wolfdale 2.8GHz 2MB L2 Cache LGA 775 65W Dual-Core Processor BX80571E6300
OCZ ModXStream Pro OCZ500MXSP 500W ATX12V V2.2 / EPS12V SLI Certified CrossFire Ready 80 PLUS Certified Modular Active PFC Power Supply compatible with core i7

Not sure if any other hardware would help. Hopefully this will help.
Attached Images
File Type: png alsamixer.png (66.0 KB, 65 views)
 
Old 02-06-2011, 11:54 PM   #5
icqraid
LQ Newbie
 
Registered: Jan 2011
Location: Oregon USA
Distribution: Slackware13.1 Ubuntu10.10
Posts: 25

Rep: Reputation: 0
Did I see your screen shot correctly? Do you have three Mic levels? The first is up, but not the other two.

I assume that you are other parts of the intel card are working (sound)?
The funny thing is that my mic is showing muted in alsaconf but it works in skype (also a 3.5mm mic)
 
Old 02-07-2011, 12:24 AM   #6
nova49
Member
 
Registered: Nov 2010
Distribution: Slackware
Posts: 74

Original Poster
Rep: Reputation: 0
There are 6 mic levels as it says on the screen shot. I tried them all on and all I got was static. I think it might be a driver issue since it doesn't work in slackware or debian but worked fine back when I was using ubuntu. Then again it could just be that I set up something wrong.
 
Old 02-07-2011, 12:30 AM   #7
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,432

Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
My googling suggests that this is a known problem that may have been fixed in alsa-1.0.24.
http://forums.debian.net/viewtopic.php?f=7&t=59680
 
Old 02-07-2011, 08:22 PM   #8
nova49
Member
 
Registered: Nov 2010
Distribution: Slackware
Posts: 74

Original Poster
Rep: Reputation: 0
I am going to attempt to compile alsa 1.0.24 and hopefully this will solve my problems. I should get back to you in a couple of days on news whether it fixed the problem or not. I have some reading to go do.
 
Old 02-08-2011, 06:19 AM   #9
Andersen
Member
 
Registered: Dec 2008
Distribution: Slackware
Posts: 85

Rep: Reputation: 34
I think that compiling new alsa is unnecessary. You should try pressing space bar on the "capture" item to switch it on.
Attached Images
File Type: png screenshot.png (3.3 KB, 35 views)

Last edited by Andersen; 02-08-2011 at 06:51 AM. Reason: changed screenshot
 
Old 02-08-2011, 10:02 AM   #10
icqraid
LQ Newbie
 
Registered: Jan 2011
Location: Oregon USA
Distribution: Slackware13.1 Ubuntu10.10
Posts: 25

Rep: Reputation: 0
While nova49's doesn't show the "capture" option (I'm now curious as to what it says, it does have Mic set to 77 but next to it is Front Mic and the level is zero and set to muted.

On another note, nova49 are you sure that it isn't the settings in skype. I had a huge list (maybe 10) of options for my mic, and I tried each one until I got one that worked. Since I have a Sound Blaster is is different, but mine uses ADC capture / standard PCM playback (hw: 0,0)
I leave the mic plugged in always, it doesn't interfere with the speakers but it works when skype is on.


How to the upgrade and compile of the alsa system go?
 
Old 02-08-2011, 10:52 AM   #11
Andersen
Member
 
Registered: Dec 2008
Distribution: Slackware
Posts: 85

Rep: Reputation: 34
Quote:
Originally Posted by icqraid View Post
While nova49's doesn't show the "capture" option (I'm now curious as to what it says, it does have Mic set to 77 but next to it is Front Mic and the level is zero and set to muted.
It shows "capture" item, (first from the right), only difference is that I took screenshot of the "capture" view, and his screenshot shows the "all" view.
Yes, "front mic" item is muted, but I think it's a playback item, meaning if he'd turn that item on, he would be able to hear his own voice in speakers or headphones, but it wont be of any help with applications.
I was having the same problem few days ago (with the similar sound chip), played a little with alsamixer, and managed to enable voice in applications (skype, audacity..) by turning on "capture" item, like I mentioned before.
 
Old 02-08-2011, 07:02 PM   #12
Nille_kungen
Member
 
Registered: Jul 2005
Posts: 213

Rep: Reputation: 43
The front mic is often the one on the chassis that you connect to the motherboard and doesn't need to be located in front of the chassis.
Do you only have one soundcard? since it looks like you got one Intel and one ATI for HDMI on your graphics card.
So you might need to tell skype or alsa what audio device to use.

Let's look at your devices
Code:
arecord -l
Now let's try the mic by recording 7 seconds and play it.
Code:
 arecord -d 7 mic-test.wav
 aplay mic-test.wav
 
Old 02-09-2011, 10:23 AM   #13
nova49
Member
 
Registered: Nov 2010
Distribution: Slackware
Posts: 74

Original Poster
Rep: Reputation: 0
Ill try all of this stuff once I get home. One note though I got the microphone to work kinda. The microphone category in alsa makes my voice come out of the speakers. Even though some of them are muted I tried all of them. None of them work with skype. I am also going to update alsa when I get home later today. It might help.
 
Old 02-09-2011, 07:10 PM   #14
nova49
Member
 
Registered: Nov 2010
Distribution: Slackware
Posts: 74

Original Poster
Rep: Reputation: 0
I tried the recording thing that was recommended and I couldn't hear any thing. I also made sure I did it will all of the captures set on. Ill post a picture to prove that I did it. I'm going to get to work on on reinstalling the kernel and alsa and get back to you with the results.
Attached Images
File Type: png alsamixer1.png (48.6 KB, 33 views)
 
Old 02-10-2011, 12:53 AM   #15
Andersen
Member
 
Registered: Dec 2008
Distribution: Slackware
Posts: 85

Rep: Reputation: 34
Quote:
Originally Posted by nova49 View Post
I tried the recording thing that was recommended and I couldn't hear any thing. I also made sure I did it will all of the captures set on. Ill post a picture to prove that I did it. I'm going to get to work on on reinstalling the kernel and alsa and get back to you with the results.
Nope, you did it wrong. As I can see from your screenshot, you still have your "capture" item turned off. Open alsamixer, go to the "capture" item, mark it and press the space bar to activate it. Just look again at this screenshot, and see how it should look like when it's activated (notice red CAPTURE, and L R above the item name) :
Attached Images
File Type: png screenshot.png (3.3 KB, 48 views)
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
problem with ALSA, no sound through alsa, oss works SB Live! 5.1 Michalxo Linux - Hardware 2 01-21-2007 05:24 AM
sound problem: maybe alsa config problem tajo01 Debian 6 04-28-2006 04:52 AM
[1] ALSA problem & [2] FreeFontPath problem MTT1k Linux - General 12 02-03-2006 05:36 AM
alsa problem falcon1959 Linux - General 1 06-24-2004 06:57 PM
ALSA problem Dopeskills Linux - General 0 02-08-2004 08:48 PM


All times are GMT -5. The time now is 08:43 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration