LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   ALSA not saving settings (http://www.linuxquestions.org/questions/slackware-14/alsa-not-saving-settings-540184/)

JMJ_coder 03-24-2007 09:23 AM

ALSA not saving settings
 
Hello,

I used the ALSA mixer to unmute and increase the volume. Whenever I would reboot the settings would revert and I would have to unmute and increase the volume again. I tried to run the command "alsactl store" and I get the reply:
Code:

# alsactl store
alsactl: relocation error: alsactl: symbol snd_ctl_elem_info_is_tlv_readable, version ALSA_0.9 not defined in file libasound.so.2 with link time reference

I tried to run alsaconf and it worked, but when I rebooted the computer, xmms didn't even recognize my soundcard being present and I had to run alsaconf again to be able to listen to sound.

What is going on? And how can I fix it?

soylentgreen 03-24-2007 09:58 AM

are you running the alsactl store as root?

Thomas Lemmens 03-24-2007 10:01 AM

After configuring ALSA you have to save your settings to the configuration file with the command "alsactl store <card #>". If you have only one soundcard, "alsactl store" does the job. So, examining this configuration file can help.

JMJ_coder 03-24-2007 01:49 PM

Hello,

Quote:

Originally Posted by soylentgreen
are you running the alsactl store as root?

Yes, I ran both alsactl store and alsaconf as root. Alsamixer is the only one that I ran as a user (but I have run it as root a couple of times).

JMJ_coder 03-24-2007 01:55 PM

Quote:

Originally Posted by Thomas Lemmens
After configuring ALSA you have to save your settings to the configuration file with the command "alsactl store <card #>". If you have only one soundcard, "alsactl store" does the job. So, examining this configuration file can help.

I do only have one soundcard. It is an integrated card from nVidia/Realtek. There is no configuration file, it should be /etc/asound.state or /etc/asound.names. I even tried to manually create the file asound.state and then run "alsactl store" and it still failed.

Wynd 03-24-2007 02:14 PM

Hello JMJ_coder,

Have you tried compiling alsa yourself?

+T+
wynd

JMJ_coder 03-24-2007 03:24 PM

Hello,

Quote:

Originally Posted by Wynd
Hello JMJ_coder,

Have you tried compiling alsa yourself?

+T+
wynd

How would I do this? There seems to be a half dozen packages that need to be done, along with replacing kernel modules, and I can't get the documentation to come up.

Wynd 03-25-2007 01:10 PM

Go to the ALSA site and download the sources for all the packages you have installed (I have -driver, -lib, -oss and -utils). Then uninstall your current ALSA packages, and just compile it like you would any other piece of software.


All times are GMT -5. The time now is 12:16 PM.